Go Down

Topic: Cannot upload to Arduino DUE (except when pressing button erase) (Read 3532 times) previous topic - next topic

alkuentrus

Hello :)

I am using arduino DUE for some projects for fun :) and I own 2 boards.
The fun fact is that one of them is working and programming just fine.
The other one, works fine and everything, however if i dont press the erase button, befores uploading the sketch, it doesn't receive it (and says Arduino: 1.8.5 (Windows 7), Placa:"Arduino Due (Programming Port)"
 
No device found on COM9
Ocorreu um erro a enviar o rascunho)

It's not a big deal to press that button, but I'd like the hear your opinions.

Best regards
:)


ard_newbie


KG_DK

I have the same fault some time ago.
Sometimes it is because of the serial monitor, then I press the erase button and then uploaded the BLINK project, then the fault disappear.

alkuentrus

Yes, that's the trick im using.... However, I have other board Due that doesn't make that...

In the mean time i have just found that if i program the sketches from the arduino web ide, i works fine...

... Its a kind of magic, lol...

Kikiyoto

I have the same problem, I can't load the program without pressing erase (for 1 sec) before.
But it is a big problem cause I'm using a shield that make it very hard to press.

There is some other way to do it?
I'm kind of newbie in this, but from the oficial description I understood it's possible to erase via USB. Can someone help me?

ard_newbie

The Sam3x requires a full flash erase before a sketch upload. The flash erase is performed automatically (in fact this is what it is supposed to be done) whenever you upload your sketch via the arduino IDE (either with a USB cable connected to the programming port or the native USB port).

How do you upload sketches ?

alkuentrus

@ard_newbie:

Yep, It should be done like you said, however, it only works if I press erase button before uploading the sketch (I tested a few different computers and same result).


I just figured a a wayaround this... Using the arduino online IDE, programming online, it does work without any problem.

@kikiyoto, try the Arduino online IDE, and tell us if it does work...

Kikiyoto

How do you upload sketches ?
Arduino IDE for windows 10
USB cable on programmin port

@kikiyoto, try the Arduino online IDE, and tell us if it does work...
I will!


Thanks for you both!

----------------------
offtopic
@alkuentrus Brasileiro?


Kikiyoto

After a few days, I've finally made the tests.

I found another solution, much easier: using the Native port.
At the moment I made about 5 uploads using the Native USB port and it worked.
Using the programming port still fails ("ocorreu um erro enquanto o sketch era carregado"/error ocurred while loading sketch)

Arduino Online IDE: It worked, in both ports!


Português :)
Obrigado!

Speklap

I'm using the cli tool of Platformio to upload sketches to arduino. So I can use my own texteditor plus platformio auto detects the ports. It never gave me problems, while arduino ide did with port selections.

Go Up