Go Down

Topic: Versions des IDE arduino, vous utilisez finalement quoi ? (Read 1 time) previous topic - next topic

Artouste

Bonsoir
Pour résumer : 8)

Mon PC "test arduino sous W7 " n'a pas survécu à l'épisode caniculaire passé  (pas trop grave en soit le HDD est sorti OK :smiley-mr-green: et je gère plutôt pas mal mes sauvegardes   :smiley-cool:   )

bref j'ai "récupéré" mi semaine dernière un "tout neuf sous W10"

C'etait donc  aussi l'occasion pour repartir d'un "bon pied" ;)

J'ai fais le choix de simplement reprendre la 1.6.5 r2 précédemment installée que j'utilisais le plus souvent et de charger  la 1.8.3

j'ai testé la 1.8.3 (en compile et upload) avec ce que j'utilise +/- couramment
- uno
- nano
- mega
- attiny
- atmega 1284
- digispark
- esp8266
- esp32

Je n'ai pas eu de problèmes graves/particuliers (hormis qq drivers récalcitrants au début  ;D  ) avec ce que j'avais sous la main (compile,upload BOOTloader ou USBASP OK )

la 1.8.3 avait passé tous "mes"  tests sur "mes" cibles (ce qui n'en fait absolument pas un test exhaustif ;)  )

J'ai néanmoins rencontré avec (voir ce topic) de la réponse "pas gentille du compilo " :smiley-cool:

edit : lien brut = http://forum.arduino.cc/index.php?topic=483657.msg3318590#msg3318590

J'ai ... à peu prés compris qu'en 1.8.3 le "chemin" n'est pas reconnu/reconstitué , alors qu'il l'est en 1.6.5

si un "codeur" peut m'expliquer "simplement" le pourquoi du comment  de la différence  ;)  , je suis preneur !
merci









Artouste

bonsoir
on a le droit de faire un "UP" dans le bar ? :smiley-mr-green:

Jambe

bonsoir
on a le droit de faire un "UP" dans le bar ? :smiley-mr-green:
Faut éviter, c'est très mal vu  :smiley-mr-green:  :smiley-mr-green:  :smiley-mr-green:


Je suis pas un fana de mise à jour, du coup j'en suis toujours resté à la 1.6.5, longtemps réputée pour être parmi les plus stables.

Ton "soucis" me conforte dans ma position

Artouste

Faut éviter, c'est très mal vu  :smiley-mr-green:  :smiley-mr-green:  :smiley-mr-green:


Je suis pas un fana de mise à jour, du coup j'en suis toujours resté à la 1.6.5, longtemps réputée pour être parmi les plus stables.

Ton "soucis" me conforte dans ma position
Bonsoir
Je ne serais pas aussi catégorique 8)

avec mon ancienne "base"
Je ne pouvais  pas par exemple compiler mes digispark avec la 1.6.5
ça fonctionnait avec la 1.6.7

la 1.8.3 passe  tous mes tests "perso" sur "mes" cibles
sauf le cas évoqué


elektrax

je reste a la 1.6.4, et compilation digispark et attiny85 ok
j'utilise parfois la 1.0.5 sur un autre pc pour des anciens croquis

bricofoy

1.8.2 sous linux chez moi. Comparé aux version 1.6.x il y a un gain d'optimisation non négligeable, le même projet utilise moins de flash quand il est compilé avec la 1.8.
La compilation est aussi plus rapide, ce qui vu que je bosse sur un netbook est un atout en ce qui me concerne :)

Pas de soucis particuliers à noter, j'ai bien eu un comportement étrange avec certaines librairies à un moment car les inclusions ne se font pas de la me manière qu'avant (mais je ne me souviens plus de ce que c'était précisément, et je ne retrouve plus le post là dessus)
-tu savais que si tu passe le CD de windows à l'envers, tu entends une chanson satanique ?
-non, mais il y a pire : à l'endroit, ça l'installe !

elektrax

 je n'ai jamais compris le systeme de mettre les biblios dans le répertoire de croquis en créant un repertoire "libraries", idem pour le hardware

https://github.com/Optiboot/optiboot/issues/168

download file from https://github.com/Optiboot/optiboot/releases/download/v6.2/optiboot.zip
extract it inside your sketch folder so that the boards.txt file has the following path
sketchFolder\hardware\optiboot\avr\boards.txt

IDE 1.6.4

ben non : "extract ......" , il faut creer le répertoire hardware, ok, j'extrais le zip optiboot, j'ai un réperoire optiboot dans lequel aucun sous repertoire, donc je retourne a hardware, je cree les sous répertoires

çà ne sert à rien je n'ai pas de boards.txt ni de dossier "sketchFolder", les croquis sont

C:\Users\username\Desktop\Documents\Arduino\"liste croquis.ino"

of course you should keep the folder structure (so the bootloaders hex files will be in folder sketchFolder\hardware\optiboot\avr\bootloaders\optiboot, for instance)

avec windows et arduino moitié anglais moitié francais, j'abandonne....

je cherche encore (de temps en temps) a graver un optiboot de 500 octets dans un 328p dil28 en 8mhz ext sous 3v3, au lieu du boot promini 8/3v3 qui occupe 2k de la memoire flash


Go Up