Go Down

Topic: [solved]load boatloader on 328 from 168 (Read 704 times) previous topic - next topic

-TJ-

Feb 06, 2014, 09:50 pm Last Edit: Feb 07, 2014, 10:45 am by -TJ- Reason: 1
Hi,

I've a Duemilanove ATmega 168 for a few years now and recently I bought some ATmega328-PU chips. Burning the bootloader on them looked quite simple, but doing it my self seems impossible.

I followed the ArduinoToBreadboard tutorial.
Uploaded the ArduinoISP sketch with no problems.
Wired up my 328 on a breadboard (and triple checked it...)

But now the difficult/troubling part. In the Programmer menu I selected "Arduino as ISP".
Which board setting should I choose? I want 328 bootloader, but i'm using a 168...

With the board setting:  Duemilanove ATmega 168 I received the message:
   
Quote
avrdude: Expected signature for ATMEGA168 is 1E 94 06
   Double check chip, or use -F to override this check.


But with the board setting:  Duemilanove ATmega 328 I receive the message:
Quote
avrdude: Expected signature for ATMEGA328P is 1E 95 0F
        Double check chip, or use -F to override this check.



Are these two versions just incompatible? :( Or should I be able to burn the bootloader? What am I doing wrong then?

Thanks in advance!

johnwasser

If you have ATmega328-PU chips that would explain the problem.  You need ATmega328P-PU to be Arduino compatible.  You may be able to work around the problem by creating a hardware/boards.txt file containing:

Code: [Select]

uno_nonP.name=Arduino Uno w/ ATmega328 (non-P) processor
uno_nonP.upload.protocol=arduino
uno_nonP.upload.maximum_size=32256
uno_nonP.upload.speed=115200
uno_nonP.bootloader.low_fuses=0xff
uno_nonP.bootloader.high_fuses=0xde
uno_nonP.bootloader.extended_fuses=0x05
uno_nonP.bootloader.path=optiboot
uno_nonP.bootloader.file=optiboot_atmega328.hex
uno.bootloader.unlock_bits=0x3F
uno.bootloader.lock_bits=0x0F
uno.build.mcu=atmega328
uno.build.f_cpu=16000000L
uno.build.core=arduino
uno.build.variant=standard
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

-TJ-

Oh no! stupid me! =(

I had all ready found those work arounds but I thought it was the other way around (pico editions where the trouble makers). But my versions are the wrong ones. :0

I fixed it now, thank you very much!!

Go Up