Blink Without delay help again.

It may not need any parentheses at all

Ah, ok... thanks

It should be noted, though, that the ternary operator is not the most appropriate here, as its return value is discarded.
An if-then-else statement should be used instead.

Also, the TurnOff and TurnOn functions change a global variable and then return its value, which is then discarded. This is fine as long as it's a leftover from previous implementation attempts, but should be fixed in a complete sketch, because such hard-to-read code is a recipe for headaches in the long run.

ok guys could you all help me to turn this into a class?
heres what i think so far

class Blink
{
  public:
            Blink(int pin);
            int TurnON();
            int TurnOFF();
 private:
            uint8_t pin;
            unsigned long Ptimer;
            unsigned long Ntimer;
            bool LedState;
};

 Blink::Blink( int pin)
{
  pinMode(pin,OUTPUT);
}

  

int Blink::TurnOFF()
{
   if(Ntimer-Ptimer>=100UL)
  {
   Ptimer=Ntimer;
   LedState=!LedState;
   digitalWrite(pin,LedState);
   return LedState;
  }
}

int Blink::TurnON()
{
 if(Ntimer-Ptimer>=1000UL)
  {
   Ptimer=Ntimer;
   LedState=!LedState;
   digitalWrite(pin,LedState);
   return LedState;
  }
}
void setup(){}
void loop(){}

would this be correct ? it does compile but im lost when i get to this part.

Before turning the code into a class I'd rename the variables. Ptimer and Ntimer are really poor names, because without reading and understand the full code one can't tell what their role is.

The standard names in blink-without-delay style code is prevMillis and currMillis (or something like that).

would this be correct ?

No. The constructor will be called before the init() function is called. It is the init() function that sets up the hardware, so calling pinMode() before init() is a waste of time.

Your class needs a begin() method, called in setup(), where hardware-related stuff is done.

The pin argument to the constructor will not be known to the rest of the methods.

Why is the pin field of one type while the pin argument a different type? You don't plan to use pin -14 do you? Or pin 12,349?

tuxduino i notice that in reply #8 u said that my code change the global variable and then discarded. although i dont really follow what you mean, i wish to change my code to something better, so i hope you would help me tuxduino. How can i make it to become a better code, thus later on i could make it as a function and a class so that i could use it again for other led or what not.

uint8_t pin;

This needs to be initialised before use, and use different names to avoid insanity (pin/pin).

basic assignment:

 Blink::Blink( int i_pin)
{
  pin = i_pin;
  pinMode(pin,OUTPUT);
}

initialisation list:

Blink::Blink( int i_pin) : pin( i_pin )
{
  pinMode(pin,OUTPUT);
}

To use you need to create a variable of type 'Blink'

Blink b_BlinkObj( 4 ); //on pin 4, you probably use different.
void setup(){}
void loop(){

static bool b_Test = false;

if( b_Test )
  b_BlinkObj.TurnON();
else
  b_BlinkObj.TurnOFF();
b_Test = !b_Test;
}

but like everyone said, arduino functions must be used in or after setup

Ok now i really dont know how to make a constructor.
is there any pointer that i could use PaulS?

Ok now i really dont know how to make a constructor.

First, you make a list of things that the constructor is supposed to do. Then, you decide whether it is appropriate (possible) for the constructor to do each thing on the list.

Look here:

http://www.cplusplus.com/doc/tutorial/

Look at the "Object Oriented Programming" setcion

ash901226:
tuxduino i notice that in reply #8 u said that my code change the global variable and then discarded. although i dont really follow what you mean, i wish to change my code to something better, so i hope you would help me tuxduino. How can i make it to become a better code, thus later on i could make it as a function and a class so that i could use it again for other led or what not.

Just remove the return statements in turnon and turnoff, and declare them void.

Then, as I said before, change the names of ptimer and ntimer to something that matches their role in the code.

Your code looks a bit convoluted, though (at least to me), I'd start over by copying the blink without delay example (you find it in the IDE somewhere under File => examples)

BTW, do you know the difference between global and local variables, and do you know what "return value" means, when talking about functions ?

tuxduino:

ash901226:
tuxduino i notice that in reply #8 u said that my code change the global variable and then discarded. although i dont really follow what you mean, i wish to change my code to something better, so i hope you would help me tuxduino. How can i make it to become a better code, thus later on i could make it as a function and a class so that i could use it again for other led or what not.

Just remove the return statements in turnon and turnoff, and declare them void.

Then, as I said before, change the names of ptimer and ntimer to something that matches their role in the code.

Your code looks a bit convoluted, though (at least to me), I'd start over by copying the blink without delay example (you find it in the IDE somewhere under File => examples)

BTW, do you know the difference between global and local variables, and do you know what "return value" means, when talking about functions ?

tuxduino actually i copied the blink without delay. i just thought that making it into a function will help reduce the complexity.before i was using void as it shouldn't return a thing but well my judgment get the best of me in saying no harm done if i put return. haha ok for the global and local variable. ok a global variable can be use and change by any part of the program this is consider as a bad programming practice that i still cant turn my head around. ok for local variable, only the particular section of the code where the variable is initialize could the variable be used.
return value means in function. urm i cant really explain it but i guess i could give you an idea of my understanding,
lets say that i have a fuction that could make a calculation of something
maybe
int Circle(int Radius)
{
int area=2*(22/7)*Radius;
return area;
}
so basically what it does is when the function circle is call with the radius of the circle inside the bracket, the function will make some calculation with the formula of 2 x phi x radius. the answer to that equation is the are of a circle,where by once complete the function will return the area to the loop in which the circle function is call.

am i rite will all this or is there any flaw in my logic/understanding it.

heres my code for the blink without delay.

const uint8_t Led=13;
boolean LedState=LOW;
unsigned long PreviousMillis=0;
unsigned long CurrentMillis;
unsigned long TimerOFF=1000;
unsigned long TimerON=100;

void setup()
{
  pinMode(Led,OUTPUT);
}
void loop()
{
  CurrentMillis=millis();
  if (LedState==LOW)
  {
    if (CurrentMillis-PreviousMillis>=TimerON)
    {
      PreviousMillis=CurrentMillis;
      LedState=HIGH;
    }
  }
  else
  {
    if (CurrentMillis-PreviousMillis>=TimerOFF)
    {
      PreviousMillis=CurrentMillis;
      LedState=LOW;
    }
  }
  digitalWrite(Led,LedState);
}

would this be better in term of implementation.

If you look at the example, the simplest way to vary the on/off time, is to change the value of"interval" when you change the state of the LED.
There is no reason for "currentMillis" to have global scope.

(edit: this is a reply to comment #18)

Good answers :slight_smile:

As for the "no harm if I put a return there"... well technically it's true but it's a good habit to know if a code line is of any use instead of putting it in "just in case". :slight_smile:
In your particular piece of code, the (logical) error is changing a global variable and returning that same variable. You must decide how your function and the code that uses it communicate: either via the function return value or via a global variable.

Yes, global variables are generally a bad programming practice, but in an Arduino sketch it's ok to have a few global variables that match the particular hardware setup one is using.
For example, it's common to have an lcd global variable of type LiquidCrystal if a sketch uses an lcd display.

If all your program is doing is blinking ONE led, it's ok to have e.g. ledPin and ledState global variables.
Instead, if you want to write a couple of functions that can be used to blink any led the user specifies, then global variables must be avoided. A class should be used: the variables used to make the led blink (and remember its state) get incapsulated as private data members, and the functions become methods, which work on those private variables.
Each instance of that class (i.e. object) will have its own private state variables, so each led will blink independently of the other leds.

The keyword here is "state". If you have int sum(int a, int b) { return a + b; } you don't have any state to keep between two calls of that function. Instead when you blink an led you call e.g. updateLed() and you have to remember in which state the led was the last time you called that function. Local variables are not enough, as they last only for a function call. Globals (or better yet class private data members) are needed.

I hope it all makes sense... :slight_smile:

Code in reply #19 is much better. AWOL is right, CurrentMillis could be local to loop().

i know AWOL, but what I'm trying to achieve here is that the on time is different with the off time, the implementation if this little exercise have a very really application in the future, i am trying to simplify stuff to the very basic so that i can program in the simplest term and when its time for me to make the project at least i have a good(if any) understanding of how to do it. so would this be better?

const uint8_t Led=13;
boolean LedState=LOW;
unsigned long PreviousMillis=0;
unsigned long TimerOFF=1000;
unsigned long TimerON=100;

void setup()
{
  pinMode(Led,OUTPUT);
}
void loop()
{
  unsigned long CurrentMillis=millis();
  if (LedState==LOW)
  {
    if (CurrentMillis-PreviousMillis>=TimerON)
    {
      PreviousMillis=CurrentMillis;
      LedState=HIGH;
    }
  }
  else
  {
    if (CurrentMillis-PreviousMillis>=TimerOFF)
    {
      PreviousMillis=CurrentMillis;
      LedState=LOW;
    }
  }
  digitalWrite(Led,LedState);
}

but what I'm trying to achieve here is that the on time is different with the off time,

...which is exactly what happens with the example if you change the value of "interval" when you change the state of the LED.

Awol,
It is to my limited understanding of C++/C programming that would say in my humblest opinion that the interval only set the duration between how long it will turn on/off.
lets say that i change the interval to 2000
it would mean that the led will turn on for 2 second and then turn off for 2 second and the cycle will repeat it self.
what I'm trying to achieve now is to turn the led on for maybe 3 second and then off for maybe 5 second.
I hope that my explanation is correct and I will be glad if I'm wrong cause only then i could improve my understanding and my self as a whole.

Ash I think AWOL's point is this...

If you change interval on the fly, at the time you change the LED state, the interval will be correct for the next pass with the LED in the new (on or off) state and will time that on or off section correctly. Then next time the LED state changes, the interval will get changed for that new (off or on) state. Difficult to explain in words.... yet another case where a flowchart will help.