Go Down

Topic: ENC28J60 (Read 3323 times) previous topic - next topic


Aug 30, 2010, 05:53 pm Last Edit: Aug 30, 2010, 06:03 pm by ironbot Reason: 1
Hi Great Forum!

I've managed to implement an Arduino embedded server based on:

I have HanRun magjack just as in that tutorial, mounted on a SparkFun breakout board:

In this article:
Under the section "Step by step: Assembly and testing", It is recommended to first implement ENC chip independent of Atmega, test it, then step toward connecting the working circuit with ENC chip to Atmega (Arduino in my case).
I went with this approach as it is the first time I'm doing it and I'm a novice and have to test and go on, TDD ;)

Now after finishing ENC28J60 part, I implemented the Step two of the article, which says: "older the ENC28J60, the magjack and all other parts around the ENC28J60 on the board, but not the Atmega88 microcontroller. Connect the circuit again to 5V power on Raw-DC-IN (limit the current to about 300mA,check that you get again 3.3V). Now connect an Ethernet cable from you Hub or Switch to the circuit. The green LED on the Magjack should go on and stay on. The link LED on your Hub/Switch should also go on".

My result is that, when I connect my ENC from MagJack to my laptop (on Win XP) Ethernet port, Windows first says "a network cable is connected" and then fades out with the same red X on the network connection.

Also, worst than that: my "green" LED (link) of the Rj45 MagJack goes on first, then after some seconds starts to do a few blinking and then fades out.

When I connect the Ethernet cable from ENC board to my working router, the indicator of the new network connection of the port goes on first, and the green LED on the MagJack also goes on. Then after some seconds the indicator on the router turns off, and the same way as before, the green LED on the MagJack fades out (slowly).
I also double checked the soldered connection based on the schema and they seem right and ok.

For the Ferrite Bead I used one that I took out of an old mainboard. It has 5 turns, an ordinary coil. I don't think the reason could be that, but I stated as it may help for gurus to guess my problem.

Edit: one more piece of information on problem is that when the LED goes off, if I just turn off the power (3.3V) and turn it on, the green LED won't go on, as if nothing works still. I have to wait for some around 30 seconds, and then again turn the power on. As if there is something charged that must be discharged.

Please guide me step out of the problem :D


At the first glance it looks as if a polyfuse is reacting to a much too high current flow...


Well, but there is no fuse, or it is hidden inside ENC28J60?

I just programmed my Arduino328 with the ethershield_ping.pde of that tutorial I mentioned, even when the green LED is still bright green, ping returns 100% lost. Network can't see it yet :(

Please guide :)


Where do you get your 5V (?) "raw in" from?


Aug 30, 2010, 10:53 pm Last Edit: Aug 30, 2010, 10:57 pm by mpeuser Reason: 1
All right! Do you see the polyfuse? It's called PTC here what is the same

You will need more power for theENC chip.
Exchange this for a 500mA type (that is o.k.!) or remove it (*sigh* that is really not o.k....)

BTW: That is a great tutorial series from SparkFun. There would be 90% less traffic here in this forum if everybody worked through it  ;D


deSilvia many thanks!

I removed my SparkFun power source and connected 3.3v from Arduino board, it worked!

Now green LED won't go out.

Next I tried to ping again (I programmed Arduino with ping example as above said).

The ip there is When I plug Ethernet cable to the laptop (on Win XP) it won't detect the device. I then set the ip of network adapter to both as ip and gateway (MAC Next I disable/enable network card. A set is recognized.

Green LED now turns off and on, blinking when I ping, but I always get "request timed out" (and one blink for each of them!).

I feel I'm close, but I don't know what to do next?

Any idea please?

Go Up