Go Down

Topic: New Arduino Uno, can't upload Blink (Read 9496 times) previous topic - next topic


Hello All,

I am new to using Arduinos, but I am an experienced programmer, know C and JAVA, and have also done various projects with VHDL.

I recently purchased an Arduino Uno and am in the process of trying to get things set up for the first time.  I followed the driver installation instructions for Windows 7 (x64), and when I try to upload the Blink example, I get the following verbose output:

Using Port            : \\.\COM3
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

Can anyone help me out with what's going on here?  I just got the board and I can't even upload...if problems persist I may boot into Linux (also x64) and see if things will work.

Coding Badly


...what have you tried to diagnose the problem?


All of them.  I don't have any programs that scan serial ports, I don't have firewall software that blocks access to serial ports, I'm not reading data over the USB with another program...every other solution looks trivial.  Board is on, proper port selected, and proper board selected.  Nothing is plugged in except USB, and nothing is touching the board.

I've gotten things working on my Linux partition, so it's not a major issue.  Would just be nice to get things working on Windows as well.

Mark Bramwell

When you check out Device Manager, does it show COM3 and COM3 disappears when you unplug the arduino?


Yes, COM3 disappears when I unplug the Arduino Uno.


Sounds like the exact problem I have But im using a mac.


I'm not certain (don't have an UNO yet), but I remember reading that the new boot loader is at 115800bps, not the standart 115200bps.

not sure if that's the actual issue, or how to fix it, good luck


Well I think it's a problem only in Windows 7...I can get things to work fine in Linux or using a virtual machine for Windows XP inside Windows 7, but not with Windows 7 itself...


What does the Device Manager show for the Uno?  You may have to manually update the driver and point it at the .inf file that comes with Arduino 0020 / 0021.  


Oct 17, 2010, 02:27 am Last Edit: Oct 17, 2010, 02:30 am by egdinger Reason: 1
Make sure you have the correct board type selected. When I first installed 0021 Duemilanove was the default, and I had to set it it to Uno.

You can do this from Tools->Board->Uno.

I got this same error message when it was wrong.
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Should add I'm using Windows 7 64bit professional.


how about running it as an administrator, and in compatibility mode?  Some times it will work for most programs. ;)


I've got a similar situation.
Windows 7 - 64 bit

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

My Duemilanove would appear on com 4 and run OK.
I plug in the Uno and it does appear in the device manager but the option in the IDE to change the COM port never shows COM 4. I changed the Board to the Uno.

Ran as Administrator and tried compatibility mode. Same results.

System is an Acer laptop.
Suggestions? Or is this a Window 7 64bit thing?


Got it!
Went to device manager, right clicked on the arduino and updated the driver. When asked for the driver location navigate to the IDE's drivers folder in the Arduino0021 folder.

Installed on COM 5!
Commence au festival! :D


Thanks.  I added a note about this to the troubleshooting guide: http://arduino.cc/en/Guide/Troubleshooting.  It may have something to do with Windows 7, 64 bit being pickier about having signed drivers or something like that.

Go Up