Go Down

Topic: Endereço IP para se conectar a Placa não encontro (Read 587 times) previous topic - next topic

LNExGASI

Foi enviado o endereço ip para a placa Arduino e não estamos conseguindo mais encontrar. Estava funcionando e do nada parou de funcionar. Segue informações :

#include <SPI.h>
#include <Ethernet.h>

// Informacoes de endereco IP, gateway, mascara de rede
byte mac[] = { 0xA4, 0x28, 0x72, 0xCA, 0x55, 0x2F };
byte ip[] = { 192, 168, 0, 49 };
byte gateway[] = { 192, 168, 0, 51 };
byte subnet[] = { 255, 255, 255, 0 };


Obs.: Não encontramos mais este endereço ...0.49


Está conectado a um roteador Switch de 8 portas da D-Link, na mesma rede dos Micros.

O que poderia ser ?

bubulindo

This... is a hobby.

LNExGASI

Vou tentar detalhar mais, vamos lá

Temos uma placa Arduino Uno R3, conectada a uma Placa HR9111 (ARJ 45), com 2 Módulos Rele 10A 250VC e 10125.

Estavamos visualizando o endereço IP, via Switch, interligando  a placa (Arduino) e computador, com os ips

- Micro                                               192.168.0.19
- Placa Arduino                                    192.168.0.49
- Switch Encore de 16 portas 10/100
- DHCP Roteador D-link 905                    192.168.0.51

Estava funcionando perfeitamente!

Acabou a energia e nosso Switch (Encore), foi substituído por um outro Switch (Encore) de 8 portas 10/100.

A partir desta substituição, não visualizamos mais o endereço IP da placa Arduino! As Leds, ficam acessas, enviamos códigos de programação para a placa, via USB, mas não conseguimos mais visualizar o endereço IP (49).

Em alguns foruns, estavam comentando em substituir os capacitores para resolver este tipo de problema, na entrada dos ARJ45.

Poderiam me ajudar ?

LNExGASI


bubulindo

Como é que o router está configurado?
O meu por exemplo não aceita IP's fora duma certa gama... poderá ser isso?
This... is a hobby.

giova014

Quote
Em alguns foruns, estavam comentando em substituir os capacitores para resolver este tipo de problema, na entrada dos ARJ45.
Não são capacitores, são resistores.

Se estiver usando o Shield Ethernet W5100, leia e siga este post: https://forum.arduino.cc/index.php?topic=323798.0
Arduino!!

Go Up