Go Down

Topic: Lecteur QR code + LCD + imprimante (Read 4208 times) previous topic - next topic

DjLab

La doc que j'ai est celle-ci :

https://www.waspbarcode.com/barcode-scanners/~/media/560BB1AAC625462682662E352B6BDCC5.ashx

Outre les différentes config RS-232 en page 9, il y a aussi "keyboard interface" en page 10-11 et 12?

DjLab

Je viens de tester en reliant les masses "mécaniques" de l'usb du lecteur et du shield, rien de plus.
La config USB Com to simulate RS-232 standard interface ne change rien non plus.

J-M-L

donc vous avez


220 V --> TRANSFO 5V 1A --> + et GND du câble USB

shield D+ et D- --> D+ et D- du câble USB

GND transfo --> GND Shield


c'est ça?
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages privés SVP

DjLab


J-M-L

est-ce que vous avez un hub USB alimenté pour tester?

shield --> hub --> Lecteur QR Code
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages privés SVP

DjLab

Non, je vais essayé d'en trouver un demain au travail, car ce projet est au final pour simplifier la vie des opérateurs qui aujourd'hui jouent de la loupe pour lire ce fichu QRcode qui fait 5x5mm....................

J-M-L

et leur smartphone ne les lit pas? il y a plein d'apps gratuites qui le font :)
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages privés SVP

DjLab

C'est déjà la guerre avec les portables, alors là je vous dit pas, et puis 5x5mm je ne suis pas sur que ça marche  :)
Sinon voici le petit schéma vite fait.

Artouste

A ce stade
fait un test comme suggéré par JML avec un HUB USB alimenté
attention il y a HUB et HUB , certains HUB sont plus "sophistiqués" que d'autres.

tu n'a pas fait de test U et I sur tes differents dispo cibles pour voir ?
cela pourrait donner une idée de voir ce que consomme ton scanner connecté sur ton shield ou sur un autre dispo et si "on" detecte une nego .

DjLab

Oui, je test demain avec plusieurs HUB (je vais voir avec le service informatique, il doive bien avoir ça).
Sinon niveau conso sur mon alim j'ai 50mA sans voir de pointe de courant, sur le shield pareil 50mA sans pointe.
Lorsque je passe par le PC et que le lecteur s'initialise j'ai 100mA.

Artouste

...  sur mon alim j'ai 50mA sans voir de pointe de courant, sur le shield pareil 50mA sans pointe.
Lorsque je passe par le PC et que le lecteur s'initialise j'ai 100mA.
tu a aussi verifié le niveau de tension en même temps ?

Bon !
A suivre demain donc 8)

DjLab

Oui, la tension était bonne.
J'ai testé avec un autre lecteur de code barre, mais seulement 1D, lui aussi en USB, ça marche du premier coup sur le shield.
Je cherche un HUB et vous tiens au courant.

J-M-L

Ok donc tout semble bien indiquer un pb d'alimentation.
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages privés SVP

DjLab

Autre petit test, en ne reliant que le +5V et le GND de l'USB du PC à ceux du lecteur, pas d'initialisation, il faut que les broches Data soient reliées.
J'essaie de trouver un HUB alimenté.

J-M-L

même si vous mettez les 2 broches à GND?
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages privés SVP

Go Up