Go Down

Topic: Adafruit Datalogger SD Card Errors, Help! (Read 181 times) previous topic - next topic

jt_3232

Aug 10, 2017, 11:50 pm Last Edit: Aug 11, 2017, 06:23 pm by jt_3232
Hi, I'm working with the Adafruit Datalogger Shield which has an SD card slot and also the PCF8523 RTC.

I finally figured out the RTC, but now I can't figure out the SD Card. After formatting the SD card correctly with the official program, I run CardInfo using a SanDisk 8GB micro SD and adapter, it tells me:


Initializing SD card...Wiring is correct and a card is present.

Card type: SD1
Could not find FAT16/FAT32 partition.
Make sure you've formatted the card



However, with other cards, I get the normal:


Initializing SD card...initialization failed. Things to check:
* is a card inserted?
* is your wiring correct?
* did you change the chipSelect pin to match your shield or module?



Also, when I run sd_read_write it gives me the error: couldn't open log file.

When I run SDInfo from the SDFat library, I get the:


SdFat version: 1.0.3

Assuming the SD is the only SPI device.
Edit DISABLE_CHIP_SELECT to disable another device.

Assuming the SD chip select pin is: 10
Edit SD_CHIP_SELECT to change the SD chip select pin.

type any character to start
error: cardBegin failed
SD errorCode: 0X25,0XFF

type any character to start



We just got about 8 of these shields and really want them to work before the solar eclipse on the 21st.


P.S. We got 4 RobotDyn datalogging shields and had no trouble with them, unlike the Adafruit ones.


Thanks for any/all help!

Go Up