Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.7 (Read 92008 times) previous topic - next topic

ballscrewbob

@ fedreserve

Nice I hadnt seen that hotfix.

Long term fix though is to install the full driver package from Nvidia which has the proper update calls to Nvidia and bypasses the MS offerings.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

sktwpthemes

great news. New version is user friendly on desktop.

oqibidipo


ARDUINO 1.8.2 2017.03.22

[ide]
* Fix command line: works again with relative paths (regression)
* Fix command line: "--save-prefs" works again (regression)
* AVR toolchain has been updated with a tentative fix for the
   ld-returned-5-exit-status bug

* Update arduino-builder to 1.3.25
  - avoid name clashing for libraries
  - cache core archives to speedup compilation consistently
* Allow BoardManager to fetch FreeBSD tools (thanks @kevans91)
* Serial monitor: the input string box is automatically focused when window
   is selected
* Serial monitor: now can not be opened during upload
* Serial monitor: now properly decodes UTF8 characters (thanks @aknrdureegaesr)
* Serial monitor: added 500k, 1M and 2M baudrates (thanks @dsstutts)
* Updated RSyntaxTextArea to 2.6.1 (textarea component)
* Updated jmdsn (mDNS discovery)
* Allow plugins to attach a listener to compile progress (thanks @tomneutens)

[core]
* Add Atmel-ICE and JTAGICE3 programmers for AVR chips (thanks @matthijskooijman)
* AVR: Set unused bits of extended fuse to 1, should remove some avrdude warning
   during burn bootloader (thanks @descampsa)
* AVR: USB: send ZLP when needed (allows full 64 bytes packets)
* AVR: USB: use IAD descriptors instead than Generic (thanks @cuitoldfish)

[other]
* SAM platform source code has been moved to its own repository
  (https://github.com/arduino/ArduinoCore-sam) - all PRs and issues
  have been moved as well
* Update Wifi101 Firmware Updater plugin



kiavash599

Hi,
Symantec Endpoint detect it as virus and delete it

kiavash599

Problem on 1.8.2 same as 1.8.1
OS: Windows 10 Ent.


c:\program files\arduino\hardware\tools\avr\bin\../lib/gcc/avr/4.9.2/../../../../avr/bin/ar.exe: unable to rename 'C:\Temp\arduino_build_603859\core\core.a'; reason: Permission denied

Using library MLX90614_library in folder: C:\Users\*****\Documents\Arduino\libraries\MLX90614_library (legacy)
exit status 1
Error compiling for board Arduino/Genuino Uno.

ddlorang

Install script seems to be broken.  I download/unpacked the tarball and ran ./install.sh.  Got a bunch of error messages:

Adding desktop shortcut, menu item and file associations for Arduino IDE...xdg-mime: file '/home/dave/install/arduino/arduino-1.8.2/lib/cc.arduino.arduinoide.xml' does not exist
xdg-icon-resource: icon name 'cc.arduino.arduinoide' does not have a proper vendor prefix
A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
with a dash ("-"). An example icon name is 'example-cc.arduino.arduinoide'
Use --novendor to override or 'xdg-icon-resource --manual' for additional info.
x

I looked at the script and the RESOURCE_NAME seems to be wrong.  Is cc.arduino.arduinoide.  (Maybe should be: arduino-arduinoide?  That is what the name of the .xml file matches.)


pert

Install script seems to be broken.  I download/unpacked the tarball and ran ./install.sh.  Got a bunch of error messages:

Adding desktop shortcut, menu item and file associations for Arduino IDE...xdg-mime: file '/home/dave/install/arduino/arduino-1.8.2/lib/cc.arduino.arduinoide.xml' does not exist
xdg-icon-resource: icon name 'cc.arduino.arduinoide' does not have a proper vendor prefix
A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
with a dash ("-"). An example icon name is 'example-cc.arduino.arduinoide'
Use --novendor to override or 'xdg-icon-resource --manual' for additional info.
x

I looked at the script and the RESOURCE_NAME seems to be wrong.  Is cc.arduino.arduinoide.  (Maybe should be: arduino-arduinoide?  That is what the name of the .xml file matches.)
Relevant pull request:
https://github.com/arduino/Arduino/pull/6110

ddlorang

Thanks pert,

Not experienced with github yet,  but I made the changes to my install.sh as described and it works fine now.

:-)

nemir976

Install script seems to be broken.  I download/unpacked the tarball and ran ./install.sh.  Got a bunch of error messages:

Adding desktop shortcut, menu item and file associations for Arduino IDE...xdg-mime: file '/home/dave/install/arduino/arduino-1.8.2/lib/cc.arduino.arduinoide.xml' does not exist
xdg-icon-resource: icon name 'cc.arduino.arduinoide' does not have a proper vendor prefix
A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
with a dash ("-"). An example icon name is 'example-cc.arduino.arduinoide'
Use --novendor to override or 'xdg-icon-resource --manual' for additional info.
x

I looked at the script and the RESOURCE_NAME seems to be wrong.  Is cc.arduino.arduinoide.  (Maybe should be: arduino-arduinoide?  That is what the name of the .xml file matches.)


I just experienced this output myself. The fix is simply to change the resource name in the sh file to the same name you have in your posts. After that it will install correctly.

pert

Glad to hear it's working for you now ddlorang! That pull request also means the issue has been brought to the Arduino developers' attention and will be solved one way or another before the next release.

JimHarman

Please note that the Release Notes linked from the main download page are still for 1.8.1 as of 3/26/17

pert

Please note that the Release Notes linked from the main download page are still for 1.8.1 as of 3/26/17
I've reported this issue to the developers:
https://github.com/arduino/Arduino/issues/6125
Thanks for bringing that to our attention JimHarman!

gelfling6

I concur on the edit for install.sh, change near the top, Line #9
 
Wrong: RESOURCE_NAME=cc.arduino.arduinoide

Corrected: RESOURCE_NAME=arduino-arduinoide

It was throwing the errors at me too.. just installed without errors after the patch.



Don't know if this was addressed, I've run into an odd problem.. (look-up thread, The not-so-amazing disappearing ESP8266 ), unless you're constantly connected to the net, if you fire-up the IDE, go to tools > Board > Choose something OTHER than the ESP8266, it goes to the Arduino boards. No problem. But, no connection to the internet, close, then restart the IDE, scroll down to the bottom of the AVR board selections, and.. where did the ESP-8266 selections go? close, re-connect to the net, start the IDE again, go through tools > boards, scroll down, and... when it reads the json file off the net, the selections re-appear.   This strikes me as flat-ignoring if the definitions are there, when it fails to obtain the json file.
this happens on various platforms (mainly x64, running either Windows-8.1 or Linux. same result, IDE 1.8.x, and json file for ESP8266 by ESP8266 Community Ver. 2.3.0..  Is there a fix, where if it cannot obtqain the json file, simply keep and add the additional board definitions?

pert

#73
Apr 07, 2017, 12:21 pm Last Edit: Apr 07, 2017, 12:23 pm by pert Reason: Embed images
There's a cool new feature in 1.8.2 I just discovered. If you place the cursor at the close bracket and the opening bracket is not shown on screen a tooltip showing the text of the opening bracket will appear after a second over the header bar. I originally discovered it as an annoying bug:
https://github.com/arduino/Arduino/issues/6157
but that shouldn't be encountered very often and the actual feature seems fairly useful:

It does get in the way a bit, especially if you put your opening braces on their own line in which case the tooltip is two lines long:

but I think I'll get used to it over time. It doesn't work so well if your opening brace is more than two lines, as it may be for the people who like to put each function parameter on a different line:

ballscrewbob

#74
Apr 07, 2017, 04:00 pm Last Edit: Apr 07, 2017, 04:03 pm by Ballscrewbob
Hi Pert.

It may go further than that...

Also have the ability to AUTO highlight or follow other functions on CREATE when one is selected ;)

Selecting a variable can highlight the rest allowing a user to see where all those same variables are used.
Same for other items. Simply swipe select as you would for cut and paste.

Will make chasing down spelling errors or following something through the sketch a lot easier.



It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up