Go Down

Topic: Please upgrade your Yún - latest is 1.5.3 (Read 38822 times) previous topic - next topic

impressiver

#45
May 24, 2016, 09:19 am Last Edit: Jun 01, 2016, 04:49 am by impressiver
Heads up: The latest version is 1.6.2.

Make sure to pay close attention to the upgrade guide, or you could end up with a brick:

Quote
If you have a Yún with an older firmware: (1.5.3) before proceed you need to to upgrade the bootloader following the bootloader update procedure. If you don't upgrade the bootloader first, your Yún will become unusable.
Before you begin, know that following the official upgrade process is done at your peril (even though every Yun shipped prior to this update requires a firmware upgrade):

Quote
WARNING: Following this guide will VOID the WARRANTY of your Yún
Hopefully some more information will come out soon from the Arduino folks to clear things up a bit.

Update: I've seen a few reports of failed updates, mostly due to not upgrading the firmware. Use the steps in this post as a guide.

escuincle

I was able to get into the Lininino Web, but I did the upgrade recommended, OpenWrt-Yun image, and when it was done the YUN WIFI signal disappeared. I don't see it now on any of my devices, I wonder what I did wrong and how can I restore it. Anybody could help with this issue?  Thanks.

Wile

#47
Jul 29, 2016, 02:39 am Last Edit: Jul 30, 2016, 03:06 am by Wile
Anyone has taken a look here : https://forum.arduino.cc/index.php?topic=406295.0 ?

There's a SFTP problem...

FrederickP

The described firmware version in that thread seems to be 1.6.2.

I had some trouble with that one too, see my latest post here for a solution that worked for me:

https://forum.arduino.cc/index.php?topic=402375.0

fweens

#49
Nov 26, 2016, 05:52 pm Last Edit: Nov 26, 2016, 06:33 pm by fweens
Hi there!

I need your help...

I've tried to upgrade my Yun to the latest version and it didn't work... So I tried the following (as said here https://www.arduino.cc/en/Tutorial/YunUBootReflash):

setenv serverip 192.168.1.231;
setenv ipaddr 192.168.1.146;
tftp 0x80060000 openwrt-ar71xx-generic-linino-u-boot.bin;
erase 0x9f000000 +0x40000;
cp.b $fileaddr 0x9f000000 $filesize;
erase 0x9f040000 +0x10000

tftp 0x80060000 openwrt-ar71xx-generic-yun-16M-kernel.bin;
erase 0x9fEa0000 +0x140000;
cp.b $fileaddr 0x9fea0000 $filesize;

tftp 0x80060000 openwrt-ar71xx-generic-yun-rootfs-squashfs.bin;

erase 0x9f050000 +0xE50000;
cp.b $fileaddr 0x9f050000 $filesize;

bootm 0x9fea0000

The last command returned:
ar7240> bootm 0x9fea0000

## Booting image at 9fea0000 ...
Bad Header Checksum
ar7240>

## Booting image at 9fea0000 ...
Bad Header Checksum
ar7240>


In fact when you download the base images zip file, it contains the openwrt-ar71xx-generic-yun-16M-kernel.bin kernel file but not the openwrt-ar71xx-generic-yun-rootfs-squashfs.bin...

May be it's the explanation ? But don't know how to fix it...
Best,

Franck

Renaudp

Hello,

Can you tell me how to check if my yun must be upgraded?
Where can I see the current version.

Thx,
Renaud

cmartu

Hi, I subscribe to Renaudp Question:

How to check if my Yun must be upgraded?

The posts in this topic and the Upgrade procedure on Arduino site are really confusing for me:

1. impressiver in post #45 is saying: Heads up: The latest version is 1.6.2. and he makes a link to 1.5.3 on Arduino site. So what is the version to upgrade to??

2. in post #4 is saying: "If files does not exists, then you running Linino." The response I get is: "No such file or directory"
    I didn't start Linino and I don't know how to get to OpenWRT to find out what is in my Yun.

Can anybody help us to clarify this?

TrashCompactor

Why does https://www.arduino.cc/en/Main/Software show a Yun Image for 1.5.3 which according to their change page (https://github.com/arduino/openwrt-yun) was last updated in 2014?

I thought OpenWRT was supported better and updated more frequently than Linino but Linino's latest version is from 2015.

Is OpenWRT Yun still supported?

sscirrus

I'm trying to update to Python 3 on Yun, which doesn't seem to be supported, but I strongly need Python 3 for a few reasons to do with my project.

Are we getting a new OpenWRT distribution any time soon?

aliabdrazak

Downloading http://download.linino.org/linino_distro/lininoIO/latest/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://download.linino.org/linino_distro/lininoIO/latest/packages/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * opkg_verify_file: Unable to get data from file /etc/opkg/trusted.gpg: No such file or directory

johnchen16

I was happily using 2 Yúns until purchasing 2 more newer units with the badly working osjs web interface.  I upgraded to 1.5.3 encountering more issues.  After a long journey with installing several images I finally located the 1.4.1 image that was the same on my older units.  You can get the 1.4.1 image to downgrade via this link:

https://arduino.cc/download_handler.php?f=/openwrtyun/1/YunSysupgradeImage_v1.4.1.zip

The uboot flash method never seems to work for me.  Instead the sysupgrade command via USB drive always worked.  You can do this from a sketch console or ssh.

[insert USB drive with the .bin file in the root dir]

cd /mnt/sda1
sysupgrade -n -v openwrt-ar71xx-generic-yun-16M-squashfs-sysupgrade.bin

[reboots after flashing, connect via WiFi, then login using password "arduino"]

Check for the golden version 1.4.1:

cat /etc/openwrt_release
...
DISTRIB_REVISION="r41503"
...

Yún happy again!  :)

Go Up