Go Down

Topic: Arduino IDE Mac problema (Read 1 time) previous topic - next topic

brioches95

Volevo aggiornare l'ide dal 1.6.3 alla versione 1.6.4, ho quindi disinstallato l'app e installato quella nuova ma ora l'app si chiude da sola quando inizializza i pacchetti. Ho provato a reinstallare la IDE 1.6.3 ma il problema persiste. Come risolvo?   

gpb01

#1
Oct 20, 2015, 08:36 pm Last Edit: Oct 20, 2015, 08:37 pm by gpb01
Premesso che l'ultima versione dell'IDE non è la 1.6.4, ma la 1.6.5-r5 ...

... su che macchina sei ? Con che versione di sistema operativo ? Cosa ti accade esattamente (... che, da quanto hai descritto, non si capisce) ?

Guglielmo
Search is Your friend ... or I am Your enemy !

brioches95

Si certo ecco tutto.
Specifiche computer: macbook pro 12,1 OS x 10.11
Per il software ho cambiato idea e preferisco mantenere la 1.6.3 ma non riesco più a utilizzarlo. All'avvio del'Arduino IDE inizia a caricare, mostra il logo e sotto compare "initializing packages..." poi si chiude l'app.

SukkoPera

Prova a rinominare la cartella Libreria/Arduino nella tua home.
Make your Sega MegaDrive/Genesis region-free with Arduino! https://goo.gl/X7zBcq

Guida rapida a ESP8266: https://goo.gl/kzh62E

gpb01

#4
Oct 20, 2015, 10:36 pm Last Edit: Oct 20, 2015, 10:37 pm by gpb01
Si, la prima prova, come giustamente dice SukkoPera, è quella di rinominare la ~/Documents/Arduino e la ~/Library/Arduino aggiungendoci -old (... io uso il SW in Inglese, se tu lo hai in Italiano dovresti trovare gli equivalenti).

In questo modo, all'avvio, l'IDE non troverà le cartelle e le creerà di nuovo senza leggere cose che potrebbe non capire.
Se tutto va bene, tu potrai recuperare dalla ~/Documents/Arduino le tue librerie e le altre cose che ci sono dentro e ripristinarle ;)

Se neanche così va ...
... prova a cancellare proprio l'IDE 1.6.3 e riscaricarlo dal sito di Arduino.cc

Io ti consiglio comunque di passare alla 1.6.5-r5 ... sono stai risolti molti problemi ed aggiornate molte cose :)

Guglielmo
Search is Your friend ... or I am Your enemy !

brioches95

Ho pravo entrambe le cose ma niente. Preferirei tenere una versione "vecchia" dell'ide in quanto uso un Arduino nano e un Arduino due tarocchi. Fino al'IDE 1.6.3 mi permette di usarli ancora, poi no. Se mi sapete consigliare il modo per installare la 1.6.5 mantenendo la possibilità di usare ancora le schede che ho, lo faccio al volo!  grazie :)

gpb01

#6
Oct 23, 2015, 10:19 am Last Edit: Oct 23, 2015, 10:20 am by gpb01
Perché non dovrebbe permetterti di usarli ? ? ? :o :o :o

Non è che NON hai lanciato il "Board manager" ed installato le board mancanti ? Nella nuova versione dell'IDE inizialmente non ci sono più tutte le board, ma solo quelle di base.
Sei poi tu con il "Board manager" ad installare altre board, anche quelle NON prodotte da Arduino, ma che forniscono i files per essere integrate.

Riporto una frase di PaoloP presa da un altro thread ...

Grazie al board manager adesso è facile inserire i core per altre schede.
Ad esempio --> https://github.com/arduino/Arduino/wiki/Unofficial-list-of-3rd-party-boards-support-urls
Guglielmo
Search is Your friend ... or I am Your enemy !

brioches95

Perché non dovrebbe permetterti di usarli ? ? ? :o :o :o

Non è che NON hai lanciato il "Board manager" ed installato le board mancanti ? Nella nuova versione dell'IDE inizialmente non ci sono più tutte le board, ma solo quelle di base.
Sei poi tu con il "Board manager" ad installare altre board, anche quelle NON prodotte da Arduino, ma che forniscono i files per essere integrate.

Riporto una frase di PaoloP presa da un altro thread ...

Guglielmo
Si lo avevo fatto ma ciò nonostante mi vedeva la board ma non gli caricava lo sketch, ci riproverò con l'ide 1.6.5 e seguirò il Tuo link. Grazie :)

brioches95

Ho installato la IDE 1.6.5 ma quando cerco di caricare il programma su arduino due mi da il seguente errore:

Cannot run program "{runtime.tools.arm-none-eabi-gcc.path}/bin/arm-none-eabi-g++" (in directory "."): error=2, No such file or directory

Che fare?

gpb01

... verificare se il file esiste direi che è la prima cosa  :D

Code: [Select]
~/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-g++
Se esiste ... qualche cosa è andata male durante l'installazione ... proverei a rimuovere il package ed a reinstallarlo.

Guglielmo

P.S.: Ha me compila senza errori per la DUE - OS X 10.11.1
Search is Your friend ... or I am Your enemy !

brioches95

... verificare se il file esiste direi che è la prima cosa  :D

Code: [Select]
~/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-g++
Se esiste ... qualche cosa è andata male durante l'installazione ... proverei a rimuovere il package ed a reinstallarlo.

Guglielmo

P.S.: Ha me compila senza errori per la DUE - OS X 10.11.1
Ma dove devo cercare? Io ho provato anche tramite terminale ma non trovo nemmeno le cartelle:

Inizialmente ho cercato: cd /Library/Arduino15/.../arm-none-eabi-g++
Ma mi dava:  No such file or directory
Allora ho verificato se fosse la cartella o il file così: cd /Library
Ma son finito delle librerie di sistema.
Ho cercato cd /Arduino15
ma mi da comunque errore: -bash: cd: /Arduino15: No such file or directory
Mi da errore anche se parto dalla home: cd ~/Library/.../arm-none-eabi-g++

Girando invece tramite la GUI nei documenti dove salvo le librerie e gli sketch non trovo nulla, ma nemmeno se apro le cartelle in Arduino.app .
Dove sbaglio?

Grazie 1000 per la pazienza :)

gpb01

#11
Oct 28, 2015, 07:26 pm Last Edit: Oct 28, 2015, 07:27 pm by gpb01
Se dal "Board Manager" hai scaricato il core di Arduino DUE lo trovi nella path che ti ho indicato sopra, partendo dalla tua home/library/...

Guglielmo

P.S: Naturalmente DEVI rendere visibile la ~/Library che, a partire da Yosemite, è marcata "hidden" ... se cerchi su Google trovi come fare.
(il simbolo ~ indica appunto la home)
Search is Your friend ... or I am Your enemy !

brioches95

Ho risolto tutto finalmente! :D Ora non mi da errori e mi carica gli sketch su Arduino due! Grazie 1000!! :D

Go Up