Go Down

Topic: Why can't i burn i sketch onto my ATmega8 with AVRISP MKII? (Read 1 time) previous topic - next topic



If i put my ATmega8 on the UNO card and plug in the AVRIPS MKii programmer. Then i can brun a sketch whitout using a bootloader. That works great! Still im using the internal 8 Mhz crystal.

But if i put the ATmega8 on a breadboard and plug this

Into this

And burn a sketch with the programmer. I got this error message:

Binary sketch size: 914 bytes (of a 7 680 byte maximum)
avrdude: stk500v2_command(): command failed
avrdude: stk500v2_program_enable(): bad AVRISPmkII connection status: RST fail, Target reverse inserted
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

I have tried to add a pull up resistor 10k, 4.7k and 1k between RST (pin1) and pin VCC (pin7) and try to burn a sketch with the programmer. The results was the same error message as before.

Do you know how i need to build my setup to burn the sketch onto the ATmega8 with my AVRSIP Mkii programmer?


you should connect vcc and gnd in to pins 20 and 22.

Go Up