Go Down

Topic: Eagle PCB IC pads to polygon fill (Read 513 times) previous topic - next topic

mOskit

Hello All

Could somebody help me to set the eagle pcb so it will fill the atmega2560 ground pins please?

They don`t want to attached to the copper pour when ratnes.

Thanks for any help

Bananaguns

Is the polygon named GND as well? It's important for whatever signal you want connected to a plane to have the same.name as the plane. To do this simply type "name" and press enter then click on the edge of your polygon then enter GND into the name feild to rename it, then type "rats" (both without the quotes) and press enter and it should connect them.
If you have done this, then you may need to right click the edge of where you drew the polygon, open the information window, then deselect the thermals checkbox, apply the change, then run ratsnest again. That should only be the problem if one of your values is too large or too small.
Alternatively you can also just connect the ground whatever the airwire is showing you have I connected to in the schematic and run the trace through the ground plane and it will all just be a solid copper fill in the Gerber, though without fixing the problem this will probably lead to having to ignore errors when running DRC and isn't the way I'd personally go unless I just didn't feel like dealing with it.

westfw

#2
Feb 04, 2018, 10:30 am Last Edit: Feb 04, 2018, 10:30 am by westfw
Quote
Could somebody help me to set the eagle pcb so it will fill the atmega2560 ground pins please?
It's common for the design rules and or a "power" signal class to have a minimum trace width and/or clearance that makes it impossible for the autorouter to connect them.   Just make your own manual routes of smaller width from the pins to somewhere within the polygon, and "approve" the width violations when you do the DRC.

Like in the green circle here:



Go Up