PinChangeInt library- To attach interrupts to multiple Arduino (Uno/Mega) pins

Calling it changedPins is better, just as you say.

don't know if the boolean expression is optimized right,

(portRisingPins & (PCintPort::curr | portFallingPins)
equals ??
(portRisingPins & PCintPort::curr ) | ( portFallingPins & ~PCintPort::curr )
??

because of the ~ (negation) you may not apply de Morgans law? or did I miss something?.
Could you print both expressions to debug to check this? (no free arduino nearby)