Go Down

Topic: chip killing laptop?? (Read 2395 times) previous topic - next topic


Oct 05, 2009, 12:53 pm Last Edit: Oct 05, 2009, 12:55 pm by The_Bongmaster Reason: 1
Hey i think my laptop (an Omnibook XE3) is killing my chips :S
this is using a RS232-TTL adapter..
I thought it was funny when one of the leds on the adapter was lit up after plugging it into the serial port on the laptop.

Attempting to upload to any arduino failed saying it couldnt sync. trying it on another pc resulted the same after trying it on that laptop, witch made me think there is summin up.. now i have pretty much no working chips.. well some work but i cannot reprogram them, and i dont know if my parallel port programming cable works because its throwing back errors too.

now i have on working board that i know of and thats a custom one with lillypad bootloader. unfortunately it wont drive my lcd for some unknown reason.., i wont dare try programming it from that Death Laptop >_>..

annoyingly it killed the chip on my brand new RBBB just after i finished building it -_-

so any chance i can force these chips back into working? i just ordered a usbisp for a more stable icsp device..

oh and one more thing.. i got hold of another omnibook XE3, this one was the one that did in the new chip.. it seems the whole range of HP Omnibook XE3's are arduino chip killers via RS232 Serial.. >_>


Do you have a data sheet for this device?
I haven't come across this before but is it an RS232 to TTL board or is it a USB to RS232 board?

If it is RS232 to TTL then you need an RS232 port on the PC, which are increasingly rare nowadays. Still you need to power the arduino with something if you aren't using USB is that connected to the correct place?

The only way you will kill the arduino is to put too much voltage into it. This can happen if the output of your board is not TTL. Have you measured it?


Oct 05, 2009, 04:54 pm Last Edit: Oct 05, 2009, 04:55 pm by The_Bongmaster Reason: 1
ok. the rs232 to ttl converter is one i made ages ago and has worked well for ages. the laptops are old and both have rs232 9 pin.

I wouldnt get very far with it if i didnt have a rs232 port on the lapy XD

and yes i did have the board powered.

the converter i made is to spec with the arduino serial version (non max232) its just a level converter using transistors and stuff.. like i said its been working really well on old laptop.

the thing is that the red led lit up the moment i plugged it into the omnibook, thats not supposed to happen, but it worked at 1st..

the old laptop, a compaq armada didnt have this problem. it worked fine.

i recently got hold of another slightly older model omnibook, that did the same thing, lit up the red led (rx boardside)

this is without the board connected by the way, the led is being lit via the power coming from com1.

so something in the omnibook series of laptops is sending power out when it isnt supposed to. a hardware bug on their part it seems.

when i plug in the usb to ttl i have (reclaimed usb arduino) the lights are fine. but couldnt test it on the board as the damage had been done. it appears that them laptops may have damaged the serial portion of the chips or something..

now i only have 2 chips that respond to programming (tested on main pc using usb-ttl)

i hope that explains things better :)


I think your problem is that your home made board is not working any more. The laptop can't just send out a signal to fry your chip. It sounds like your transistors are blown or shorted or something. What you need to do is to take measurements with an oscilloscope or at least a volt meter without the arduino connected to see if high voltages are getting through.
It could be that the design of the RS232 to TTL converter is not all it should be and feeding it with a real signal blew it. So many laptops especially of the older vintage had very poor weak serial signals.


board works fine on other machines O_o

its just on these omnibooks.. dunno why.. its just them..

usb to rs232 is fine tho.. not a single prob there..

will do tests later and stuff..

back to main problem tho.. the chips that wont respond to serial any more.. will attempted reburning of the bootloader work?


I've seen lots of problems with the transistor trick RS232 to TTL interface designs.  Those that use a 2n7000 have caused me particular grief due to ESD sensitivity.

Make sure your adapter is working before you write off the chips.

Use an interface circuit with a real RS232 transceiver (e.g. MAX232) or a TTL to USB style adapter for more trouble-free electronics tinkering.



i got some max232 chips, so i should really make a chip version xD

the transistors i used were 3906 and 3904 ( i think) too tired to look atm XD


I also managed to cross-reference all the requirements with my system information with the help of canyourunit.com, and it all passes the recommended requirements, except it didn't do it for the sound.
So my sound is Realtek High Definition Audio (Driver 6.0 version), and the minimum requirement is DX 8.1 Compatible Audio. Could someone give me some insight as to what that means and if I pass it?
If not, will I still be able to run the game?
In the embrace of the great Nurgle, I am no longer afraid, for with His pestilential favour I have become that which I once most feared: Death.


Go Up