Go Down

Topic: "Error compiling for board Arduino/Genuino Mega or Mega 2560." (Read 494 times) previous topic - next topic

MattTuck

Hey folks,

Arduino IDE won't let me compile or upload my sketches to a Mega 2560. Here's the error message:

Code: [Select]
Arduino: 1.6.10 (Mac OS X), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

/Applications/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware "/Applications/Arduino.app/Contents/Java/hardware" -hardware "/Users/Tuck/Library/Arduino15/packages" -tools "/Applications/Arduino.app/Contents/Java/tools-builder" -tools "/Applications/Arduino.app/Contents/Java/hardware/tools/avr" -tools "/Users/Tuck/Library/Arduino15/packages" -built-in-libraries "/Applications/Arduino.app/Contents/Java/libraries" -libraries "/Users/Tuck/Documents/Arduino/libraries" -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10610 -build-path "/var/folders/qf/hy__ltxs14n43dyw93nlx8z00000gn/T/buildc5a7555fdd875a9f81fc278e7ff6d383.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose "/Applications/Arduino.app/Contents/Java/libraries/Servo/examples/Sweep/Sweep.ino"
failed MSpanList_Insert 0x310000 0x621542c5b76 0x0
fatal error: MSpanList_Insert

runtime stack:
runtime.throw(0x2b050b)
/usr/local/go/src/runtime/panic.go:491 +0xad fp=0x7ffeefbff3b0 sp=0x7ffeefbff380
runtime.MSpanList_Insert(0x2ce168, 0x310000)
/usr/local/go/src/runtime/mheap.c:692 +0x8f fp=0x7ffeefbff3d8 sp=0x7ffeefbff3b0
MHeap_FreeSpanLocked(0x2cad60, 0x310000, 0x100)
/usr/local/go/src/runtime/mheap.c:583 +0x163 fp=0x7ffeefbff418 sp=0x7ffeefbff3d8
MHeap_Grow(0x2cad60, 0x8, 0x0)
/usr/local/go/src/runtime/mheap.c:420 +0x1a8 fp=0x7ffeefbff458 sp=0x7ffeefbff418
MHeap_AllocSpanLocked(0x2cad60, 0x1, 0x0)
/usr/local/go/src/runtime/mheap.c:298 +0x365 fp=0x7ffeefbff498 sp=0x7ffeefbff458
mheap_alloc(0x2cad60, 0x1, 0x12, 0x0)
/usr/local/go/src/runtime/mheap.c:190 +0x121 fp=0x7ffeefbff4c0 sp=0x7ffeefbff498
runtime.MHeap_Alloc(0x2cad60, 0x1, 0x10000000012, 0xf989)
/usr/local/go/src/runtime/mheap.c:240 +0x66 fp=0x7ffeefbff4f8 sp=0x7ffeefbff4c0
MCentral_Grow(0x2d2ad8, 0x0)
/usr/local/go/src/runtime/mcentral.c:197 +0x8b fp=0x7ffeefbff560 sp=0x7ffeefbff4f8
runtime.MCentral_CacheSpan(0x2d2ad8, 0x0)
/usr/local/go/src/runtime/mcentral.c:85 +0x167 fp=0x7ffeefbff598 sp=0x7ffeefbff560
runtime.MCache_Refill(0x30c000, 0x12, 0x0)
/usr/local/go/src/runtime/mcache.c:90 +0xa0 fp=0x7ffeefbff5c0 sp=0x7ffeefbff598
runtime.mcacheRefill_m()
/usr/local/go/src/runtime/malloc.c:368 +0x57 fp=0x7ffeefbff5e0 sp=0x7ffeefbff5c0
runtime.onM(0x226d78)
/usr/local/go/src/runtime/asm_amd64.s:273 +0x9a fp=0x7ffeefbff5e8 sp=0x7ffeefbff5e0
runtime.mallocgc(0x120, 0x1c0540, 0x0, 0x0)
/usr/local/go/src/runtime/malloc.go:178 +0x849 fp=0x7ffeefbff698 sp=0x7ffeefbff5e8
runtime.newobject(0x1c0540, 0x30c000)
/usr/local/go/src/runtime/malloc.go:353 +0x49 fp=0x7ffeefbff6c0 sp=0x7ffeefbff698
runtime.newG(0x276ba)
/usr/local/go/src/runtime/proc.go:233 +0x2a fp=0x7ffeefbff6d8 sp=0x7ffeefbff6c0
allocg(0x2bd660)
/usr/local/go/src/runtime/proc.c:925 +0x1f fp=0x7ffeefbff6e8 sp=0x7ffeefbff6d8
runtime.malg(0x8000, 0x2bd700)
/usr/local/go/src/runtime/proc.c:2106 +0x1f fp=0x7ffeefbff718 sp=0x7ffeefbff6e8
runtime.mpreinit(0x2bdac0)
/usr/local/go/src/runtime/os_darwin.c:137 +0x27 fp=0x7ffeefbff730 sp=0x7ffeefbff718
mcommoninit(0x2bdac0)
/usr/local/go/src/runtime/proc.c:201 +0xc9 fp=0x7ffeefbff758 sp=0x7ffeefbff730
runtime.schedinit()
/usr/local/go/src/runtime/proc.c:138 +0x55 fp=0x7ffeefbff780 sp=0x7ffeefbff758
runtime.rt0_go(0x7ffeefbff7b0, 0x19, 0x7ffeefbff7b0, 0x0, 0x19, 0x7ffeefbff988, 0x7ffeefbff9c0, 0x7ffeefbff9cc, 0x7ffeefbff9dc, 0x7ffeefbff9e6, ...)
/usr/local/go/src/runtime/asm_amd64.s:95 +0x116 fp=0x7ffeefbff788 sp=0x7ffeefbff780
arduino-builder returned 2

Error compiling for board Arduino/Genuino Mega or Mega 2560.



pert

Why are you using such an outdated version of the Arduino IDE?

If you update to a recent version your problem will be solved. You can download the Arduino IDE from:
http://www.arduino.cc/en/Main/Software

MattTuck

I just haven't used this laptop for any Arduino projects in a while. And it did. Thanks for catching that... It hadn't occurred to me that I could be using an old version of their IDE.

pratmishra

Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 794 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xc0
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xc0
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
 i have been facing this problem
please help!!!
 I contacted microsoft technical support but they said need to contact arduino tech support

bartolobot

     Are you still having this issue or did you find a solution?
I am having same problem, here"s my error code:
Code: [Select]
Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 1302 bytes (0%) of program storage space. Maximum is 253952 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 8183 bytes for local variables. Maximum is 8192 bytes.
avrdude: verification error, first mismatch at byte 0x0000
         0x14 != 0x06
avrdude: verification error; content mismatch
avrdude: verification error; content mismatch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Go Up