Go Down

Topic: ITEAD 3G SIM5216A Module AT command ERROR message (Read 924 times) previous topic - next topic

acitta

Hi, I recently bought a ITEAD 3G SIM5216A Module . I have it set up running on an UNO. When I plug it in 2 leds come on. When I push the power button 4 leds light up and stay on. I've lowered the baud rate to 9600 and can communicate basic AT commands with the module. (e.g. if I type AT i get OK as a response)

My problem is that almost none of the at commands in the sim5216 manual work. All but the very basic at commands work.

Attached below is the at command + response shown in my serial monitor when trying a few at commands from the manual. As you can see basic information requests return something so it's not a communication problem. But trying to start any sort of useful sms commands just returns ERROR.

I've tried using different baudrates, external power vs no external power, different sim cards (that work in my 3G phone), AT commands from other manuals (ie what worked on my sim900).  Am I missing something basic?

Code: [Select]
GSM Initiate
at

OK
ati

Manufacturer: SIMCOM INCORPORATED
Model: SIMCOM_SIM5216A
Revision: SIM5216A_V1.5
IMEI: 359769034496882
+GCAP: +CGSM,+DS,+ES

OK
AT+CGMI

SIMCOM INCORPORATED

OK
at+CGMR

+CGMR: 1575B14SIM5216A

OK
at+CSCS?

ERROR
AT+CIMI

ERROR
AT+CCAP

ERROR
at

OK
AT+CMOD

ERROR
AT+CSMS

ERROR
AT+CSMS=?

ERROR

acitta

I bought this module because I'm using aldi mobile sim card (on the telstra network)

[quote author =http://whirlpool.net.au/wiki/aldi_mobile]
ALDImobile operates on the Telstra Wholesale network providing access to Telstra's 2G, 3G/UMTS (850/2100MHz) and 4G/LTE (700/1800MHz) networks on compatible devices.
[/quote]

The sim5216A only works on the 850 and 1900Mhz frequencies. Is it possible that my unit is set on 1900MHz rather than 850? Even if that were the case I wouldn't have thought I would be getting the ERROR response to every AT command, but rather an error response type.

Below are some more at command responses. SIM failure is a bit of a concern!

Code: [Select]

GSM Initiate
AT+CPIN?

+CME ERROR: SIM failure
AT+CSQ

+CSQ: 14,99

OK
AT+CREG?

+CREG: 0,0

OK
AT+CPSI?

+CPSI: NO SERVICE,Online,000-00,0xD750,21910597,WCDMA 850,200,4436,0,11.0,94,26,25,500

OK

OK






acitta

ok once again the error was between the serial monitor and the seat. When plugging the module it to the uno the serial cable connection on the UNO pushes on the sim card causing the micro sim to pop out of it's outer sim case. I had removed the outer sim case and just stuck the sim onto the connecters with tape. Turns out you need some pressure to establish a connection on the sim holder. All is good now. Thanks for reading!

kaushikchothani


dannable

Quote
once again the error was between the serial monitor and the seat.
There was no error with the setup.
Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

Go Up