How can I simplify this simple code?

ZacharyBruno:
boolean Plane::planeDisplaced(String dir, float input) {

You seem to be routinely passing numeric values around as Strings (and presumably parsing them again and again each time you need to access the value). You should really consider using numbers instead of strings. You could slightly simplify your bounds check using abs(), but I don't see it making a huge difference. Get rid of those Strings, though.