Go Down

Topic: arduino yun- WiFi bad - Linino is Bad Data CRC (Read 632 times) previous topic - next topic

a2961656123

U-Boot 1.1.5-linino-g17593166-dirty (Oct  4 2015 - 02:12:32)

Linino Board (ar9331) U-boot
DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 218k for U-Boot at: 83fc8000
Reserving 192k for malloc() at: 83f98000
Reserving 44 Bytes for Board Info at: 83f97fd4
Reserving 36 Bytes for Global Data at: 83f97fb0
Reserving 128k for boot params() at: 83f77fb0
Stack Pointer at: 83f77f98
Now running in RAM - U-Boot at: 83fc8000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16777216, sector count = 256
Flash: 16 MB
In:    serial
Out:   serial
Err:   serial
Net:   eth0: b4:21:8a:00:00:00
eth1: b4:21:8a:00:00:01
eth0, eth1
autoboot in 4 seconds (stop with 'lin')...
linino>

U-Boot 1.1.5-linino-g17593166-dirty (Oct  4 2015 - 02:12:32)

Linino Board (ar9331) U-boot
DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 218k for U-Boot at: 83fc8000
Reserving 192k for malloc() at: 83f98000
Reserving 44 Bytes for Board Info at: 83f97fd4
Reserving 36 Bytes for Global Data at: 83f97fb0
Reserving 128k for boot params() at: 83f77fb0
Stack Pointer at: 83f77f98
Now running in RAM - U-Boot at: 83fc8000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16777216, sector count = 256
Flash: 16 MB
In:    serial
Out:   serial
Err:   serial
Net:   eth0: b4:21:8a:00:00:00
eth1: b4:21:8a:00:00:01
eth0, eth1
autoboot in 4 seconds (stop with 'lin')...
## Booting image at 9fea0000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2014-11-14   8:00:46 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1185448 Bytes =  1.1 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9fea0040 ...Bad Data CRC
linino>

I cannot get the results for either the 5 s hold-down or the 30 s hold-down of the WLAN RST button.
What can I do ?

ShapeShifter

I cannot get the results for either the 5 s hold-down or the 30 s hold-down of the WLAN RST button.
That's not surprising, don't bother trying.  For the five and thirty second resets to work, you need to wait for the Linux system to be fully booted before starting the button press. Your system is not booting; it's failing very early in the process. The code that looks for the button press is a long way away from running. As you found, those resets aren't going to help you.

Quote
What can I do ?
I will let one of the Linux experts reply and give more details, but I'm thinking you may have to manually reflash the system: Reflashing the OpenWrt-Yun image on the Yún

a2961656123

That's not surprising, don't bother trying.  For the five and thirty second resets to work, you need to wait for the Linux system to be fully booted before starting the button press. Your system is not booting; it's failing very early in the process. The code that looks for the button press is a long way away from running. As you found, those resets aren't going to help you.

I will let one of the Linux experts reply and give more details, but I'm thinking you may have to manually reflash the system: Reflashing the OpenWrt-Yun image on the Yún
Thanks ShapeShifter, I  choose "Newline" in the dropdown list beside baud rate, fixed!

Go Up