Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.5 (Read 72219 times) previous topic - next topic

pert

Hi, I'm something of a newbie on Arduino.
To make things worse, I use either a Macbook2 or an iMac.
When I (try to) load the IDE it always flags the same 2 errors, bot relating to the libraries:-
1:- Standard Libraries not loaded because "can only use names starting with a letter.
2:- Same error message as above.
Can anyone know of this error or a fix.
Thanks in advance.
Bill Robertson
Are you using Arduino IDE 1.8.5? Older IDE versions are more picky about library names.

If you are using the latest IDE version and still getting this warning then you need to find the lbiraries that are causing it and fix the folder name. You will find the libraries under {Sketchbook folder}/libraries. You can find/set the location of the sketchbook folder in the Arduino IDE at File > Preferences > Sketchbook location.

pert

Hi, I'm something of a newbie on Arduino.
To make things worse, I use either a Macbook2 or an iMac.
When I (try to) load the IDE it always flags the same 2 errors, bot relating to the libraries:-
1:- Standard Libraries not loaded because "can only use names starting with a letter.
2:- Same error message as above.
Can anyone know of this error or a fix.
Thanks in advance.
Bill Robertson
Oh, I see now. I already tried helping you in your other thread a week ago:
http://forum.arduino.cc/index.php?topic=521956
Instead of following my instructions and replying if there was still a problem you ignored me and made an even more vague post here, where it's off topic. If this is the best you can do I recommend you give up on Arduino now because you'll have no chance of success.

pert

I get the following error:

Error downloading http://downloads.arduino.cc/packages/package_index.json
Are you still having the problem?

billrobertson

Oh, I seem to have got up your nose somehow.
For whatever reason I did not find your response only the above

Go Up