Go Down

Topic: AI Thinker A6 gsm module - many problems (Read 1 time) previous topic - next topic

egzi

Hi.

I'm trying to make a remote weather station for some time now. I watched Andreas Spiess on youtube talking about A6 module, its cheap so I bought one.
Unfortunately it turns out it is totally unreliable and I'm having a headache because of it. First problem appeared when I was playing with it, I called AT+COPN command, it started to flood the screen of command terminal with operator names in a infinity loop then crashed. When powered on it showed some startup responses, some random characters and it didn't want to respond to any commands. I tried different things with it and sometimes I managed to start it up properly. After some time it started to work again.
Overall it still sends some random characters from time to time or hangs.
Sometimes TCP connect command returns "unknown error" or "execute error", what it means nobody knows. To fix it you have to reset the module.
When remote host closes TCP connection A6 module automatically closes GPRS session. When you close TCP connection on your own it doesn't happen. The problem is that sometimes server closes connection before you are able to send any command. GSM operators usually charge for every started 100kB in GPRS session. So when I send 1kB and GPRS session is being closed I am being charged 100 times more than I could be. In an application where you constantly send small amounts of data it is not trivial.
Multiconnection mode (AT+CIPMUX=1) doesn't work, first TCP connection starts properly, second returns execution error.
AT+CREG response is +CREG: 1,10 instead of +CREG: 1,0.

I tried to contact AI thinker through an email and skype couple of times but they don't respond.

egzi

Another problem. When I send GET to data.sparkfun.com everything is more or less ok, but when I send GET to wunderground.com, server returns "success" but gsm module stops responding after that and has to be hard reset. The function that sends GET is the same for both servers the only difference is the text string that is being sent to server. What a piece of crap, save yourself a trouble and don't buy it.

truebucha

So I have one SIM800C and could not get further than network connection - after that module reset itself during transmission. And there are many people with that crap problem. I added some capacicators to the default that already presents on the module and can't get it work either on two parallel  18650 accu. So you varian is not so useless. (http://www.edaboard.com/showthread.php?t=207589&page=1&s=e70c6caf3814b16c7cde790419926fa7)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy