PWM - Peltier working code

void GetTemp() {
 temperature = getVoltage(temperaturePin);
 temperature = (((temperature - .5) * 100)*1.8) + 32;
}

GetTemp() is a poor name for this function. I expect a function with Get in the name to return a value. This one does not.

I'm kinda wondering if there is a another way to do it.

Of course there is. Ditch the String class. The dtostrf() function puts the decimal point in a fixed position in tBuffer. You don't need the overhead and problems of the String class to move the characters to the right of the decimal point one place to the left.

What does this issue have to do with the post title?