Go Down

Topic: Arduino Uno WiFi not working (Read 4586 times) previous topic - next topic

tcibils

The issue seems to remain...


I have updated the firmware using the following :
 - Tutorial : http://www.arduino.org/learning/tutorials/advanced-guides/arduino-uno-wifi-firmware-updater
 - Troubleshooting : http://www.arduino.org/forums/uno/how-to-update-uno-wifi-firmware-on-ide-1-8-0-1080

Using IDE Arduino 1.8.3, firmware ESP8266 (0.0.3), I've reached the window saying "The firmware has been updated!". The WiFiLink library, used through library manager, is version 1.0.1.



My code is as follows :

Code: [Select]

#include <WiFiLink.h>


char ssid[] = "WiFiName";
char pass[] = "WiFiPassword";

int status = WL_IDLE_STATUS;


void setup()
{
  Serial.print("1");
  Serial.begin(9600);
  Serial.print("2");
  status = WiFi.begin(ssid, pass);
  Serial.print("3");
  Serial.print(WiFi.status());
}

void loop() {}


And the result printed are "12", as if the "WiFi" functions freeze everything.


Would someone have an idea of why the issue remains...? Maybe I didn't upgrade the firware correctly ?

Juraj

not the right firmware. full answer on arduino.org forum http://www.arduino.org/forums/general-discussion?p=6027#p6027

R10HJS

Same issue here. It seems that any call to any WiFi.xxx function makes the program freeze.

I've indeed also received advice to upgrade the firmware : http://www.arduino.org/forums/general-discussion?p=5980#p5980
Hi,

Specifically created an account to say thank you!  This has been driving me nuts; I couldn't establish a connection using the regular firmware so tried flashing WifiLink; then I had the freezing problem, so flashed master... and now it works!

Next step will be to integrate OTA flashing into the 'master' build, as per instructions... but for now, I have outbound TCP, which is fantastic.

Thank you :-)

-H

Juraj


Go Up