Go Down

Topic: sending 7520/3020 receiveData timeout after 400ms on chromebook (Read 978 times) previous topic - next topic


keeps saying this on upload attempt.

held in reset button
reinstalled extension
reselected board
unplugged everything
updated chrome
signed out/in to create
tried different cable

nothing works



using genuino uno.
ive had this before but problem usually goes away after an hour or so.  it's been a couple days.

lmk if i've forgotten some important info.


Hi @rideoncleveland,

What version of Chrome OS are you using?

Can you try loading a simple blink sketch? Also, do you have access to another PC that is not a Chromebook to try to upload with the regular IDE?


Version 62.0.3202.82 (Official Build) (32-bit)

looks like the latest.

no other computer, unfortunately.

no sketches load, even the simple blink.


I just updated my Chromebook to Version 62.0.3202.82 (Official Build) (64-bit).

Uploading an empty sketch and blink to my Uno worked without any issues.

Have you tried a different USB port on the Chromebook and/or different USB cables. Also, is anything plugged into the Uno apart from the USB cable?


I also have this problem and my arduino nano are not dead


Hi @Eric-Sanner,

Were they working before? Are the Nano's based on a ATMega328p?


i took a break hoping that things may just start working again as sometimes they do.  same error.  basic blink. 

if it's not my uno, how can I get a checkup on my create app connection? 

Go Up