Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 366604 times) previous topic - next topic

Jantje

In Sloeber (whitch is a layer on top of CDT a real C++ide ) just create your workspace in the parent of your arduino sketches.
Then create new arduino sketches with the wizard using the same name as the foldernames.
Done**.


*Unless there is some ino incompatibility like using enums defined in the .ino as parameters/return values of methods.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

manny2002

Simply drag the serial monitor outside of the eclipse window.
Thanks.
At first didnt work, but then I realized it needs to be done while Eclipse is not full screen.

zenseidk

Hello,
I get a strange error when launching sloeber:

JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.8
-Dorg.eclipse.update.reconcile=false
-Xms40m
-Xmx512m
--add-modules=ALL-SYSTEM
-jar /home/zenseidk/sloeber//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/zenseidk/sloeber/sloeber-ide
-name Sloeber-ide
--launcher.library /home/zenseidk/sloeber//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.550.v20170928-1359/eclipse_1629.so
-startup /home/zenseidk/sloeber//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.appendVmargs
-exitdata 230010
-perspective io.sloeber.application.perspective
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dorg.eclipse.update.reconcile=false
-Xms40m
-Xmx512m
--add-modules=ALL-SYSTEM
-jar /home/zenseidk/sloeber//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar

The IDE does not start, any suggestions?

I tried downloading the newest stable build and it gives me the same error.

I am able to launch other eclipse based IDE's with no issues.

HDo_777

Me also  >:(  >:(  >:(

Hello Jan Baeyens,

I get this error, when I try to upload my sketch or to add a serial port to the monitor.

Do you have a solution to fix this error? What can I do?

Please click to this link to see the picture:
https://drive.google.com/open?id=1jXto7x-QpsXm0q41MhZRFRAwY7zJ2gdx


Greets :)

Go Up