Go Down

Topic: TemperatureWebPanel: No such file or directory (Read 1 time) previous topic - next topic

Renaudp

Dec 08, 2016, 09:58 pm Last Edit: Dec 10, 2016, 11:44 am by Renaudp
Hello,

I have an issue when testing TemperatureWebPanel.
I have created the required folder: arduino/www and after uploading the code, a new directory
TemperatureWebPanel containing index.html and zepto.min.js was added.
I have set Enable Rest API password protection to 0 in the Arduino Settings
When go to arduino.local/sd/TemperatureWebPanel in my browser, I got the following error message:
No such file or directory

Any idea what is wrong?
Thx,
Renaud

Renaudp

Hello again,


The ajax call back is working. In the browser, http://arduino.local/arduino/temperature, returns the correct value:
Current time on the Yún: Fri Dec  9 16:41:50 UTC 2016

<br>Current temperature: 133.11 &deg;C<br>This sketch has been running since Fri Dec  9 16:40:43 UTC 2016
<br>Hits so far: 2

Unfortunately, I have trouble to access http://arduino.local/sd/TemperatureWebPanel. The browser always report: No such file or directory
Is the sd path defined by default? How can I check this?

Any help will be appreciated.
Renaud

DarkSabre

Renaudp,

My SD card paths are always /mnt/sda1/<files> when you are looking at it from FTP or SSH.

I'm not familiar with the process of hosting off of the Yun, so I'm afraid I can't help any further.

Renaudp

#3
Dec 09, 2016, 07:18 pm Last Edit: Dec 11, 2016, 11:48 am by Renaudp
Indeed, I have the same.
For info, it is a brand new Yun out of the box.

I noticed some error reported in the system log:
Dec 11 10:46:05 arduino user.info sysinit: handle umount errors
Dec 11 10:46:05 arduino user.info sysinit: check umount sda

Renaudp

Well, I did a restore from the interface and now the Yun does not login anymore :(((((((((((


Renaudp

Now I can login to the interface again  :)
But when I go to http://arduino.local/sd/TemperatureWebPanel
I always have "No such file or directory" in my browser.
I really don't know what is wrong with this test.

mm17

Hi,

I also had same issue after many search I just found this solution and it works.


try to copy your folder in /osjs/dist:
for example:

Type in terminal if your using Mac OS or you can SSH if using Windows through putty :

cp -r /www/sd/ /osjs/dist/


Regards.

EpicenterY

Well, I did a restore from the interface and now the Yun does not login anymore :(((((((((((


Hey, did you solve this log-in problem? I have same problem in here.

please help me.
I build precision cnc machine and now I want to make that connect to the internet. please help me.

ltheoret

#8
Jan 18, 2018, 11:44 pm Last Edit: Jan 18, 2018, 11:53 pm by ltheoret
Hi,

Yes I have had OS.js jam at the same spot. for me I had to switch to FireFox and not use Microsoft products.

Luc

J2D2

Hello everybody,
I just wanted to let people that will face the same issue with the Yun (no such file or directory) that the solution of mm17 is working fine:

Hi,

I also had same issue after many search I just found this solution and it works.


try to copy your folder in /osjs/dist:
for example:

Type in terminal if your using Mac OS or you can SSH if using Windows through putty :

cp -r /www/sd/ /osjs/dist/


Regards.

Don't start other crazy solution like you can read somewhere else, if you see in the Arduino File Manager in the www folder that your picture or code has been transferred to it.
Best regards.
J2D2

Go Up