Go Down

Topic: yun.local doesnt work (Read 4233 times) previous topic - next topic

Max_Be

Im having big Trouble with my yun. Im not able to connect with yun.local. I can connectit through the ip address and configure my yun. But still cant witch .local.
(My arduino is developed with doghunter if that coud help)
I installed bonjour but it just says that there are no bonjour Printer available.
Please Help

artisticforge

Im having big Trouble with my yun. Im not able to connect with yun.local. I can connectit through the ip address and configure my yun. But still cant witch .local.
(My arduino is developed with doghunter if that coud help)
I installed bonjour but it just says that there are no bonjour Printer available.
Please Help

You are using an Arduino YUN board
Which version of Arduino IDE are you using?
What operating system are you using?
Linux, MacOSX, MS Windows, other

What name did you give the YUN?

Most of the time it should be "arduino.local"

After the first configuration of the YUN, it would be the name you gave the yun  with ".local"

If you are using Linux you can use mdns-scan to search for the Mdns/bonjour/zeroconf hosts.

><>

Max_Be

Yes Im using an Arduino Yun board(from arduino.com and developed with doghunter)
the IDE Version is 1.8.5
Im using Windows 10
I named my Yun Yun:D ->yun.local

thx for the fast reply

artisticforge

Yes Im using an Arduino Yun board(from arduino.com and developed with doghunter)
the IDE Version is 1.8.5
Im using Windows 10
I named my Yun Yun:D ->yun.local

thx for the fast reply

It is not clear what you named the Arduino YUN Board.
if you did name it "Yun:D"  i am not sure what the '.local' name would be.
I will have to try that later with one of my Arduino YUN boards.

I do not do Windows so I will not be much help.
There is probably a Windows program similar to mdsn-scan but I do know what it is.
><>

Zaszigre

#4
Jan 16, 2018, 10:08 am Last Edit: Jan 16, 2018, 10:13 am by Zaszigre
Hello !
instead of using yun.local, you can try arduino.local , linino.local or picolo.local (don't ask me why, It happened sometime that My Yun where accessible through those URLs).

If doesn't work, try 192.168.240.1 if you're using Yùn as an access point or 192.168.1.133 if your board is connected to another Wireless network (if two Yun are connected, the second one would probably take the following address : 192.168.1.110, That's how mines behaved).

If It steel doesn't work, upload YunSerialMonitor sketch to you board and type:
# ~2
# ifconfig

and Ip Adress of the yùn will appear (if it's up).
else you can hold the wifi reset button for +5 second.
or using `uci set wirless.@wifi-iface[0].key=value` to reset your wifi config (but i'm not a expert, search on the internet)
or:
# reset-to-factory-anyway
but you'r going to loose everything and will need to go through the setup step all over again.

Hope for you the first solution will work because otherwise,, it will be a deep fall through hell. :)
let us know at every step how it turn out. And remember I'm not an expert, There may be a better option.

ltheoret

Hi Max_be,

I see from your post that you can ssh in with the IP address, Well just ssh in and look at the board name between the user 'root' and the command prompt. see photo. This work with most Linux flavors and all the YUN, NUY, Dagino and TIAN boards.



Luc

ltheoret

Hi Max_be

Just noticed you named your YUN 'YUN:D'
well the network is looking YUN at port D.
I would stay away from special characters in the device name.

Luc

Go Up