Arduino Forum

Using Arduino => General Electronics => Topic started by: MrGarak on Sep 28, 2012, 07:54 pm

Title: 6v to DC input jack seems to work fine?
Post by: MrGarak on Sep 28, 2012, 07:54 pm
I've done a lot of reading up on DC input jack voltage, and how ideally this should be 7.4v or so minimum. I have a bunch of extra unused wall warts around, 6v, 7.5v, and 9v. Took my crappy analog multimeter out to test some of their voltages with the arduino powered up. I first compared it to known reference voltages from 9v and 1.5v batteries to get an idea of the measurement error of the meter. With that in mind I found to my dismay all my 9v adapters were putting out 13v or so, and even the 7.4v was putting out 11v. As stated, these readings were with the arduino powered up. Noticed the vreg got a bit warm with all these adapters. With these results I figured the 6v one would be my best bet, but of course murphy dictated this one actually put out precisely the advertised 6v even under no load. At any rate, the arduino seems to work fine with the 6v adapter, and the vreg is running nice and cool. I suspect I will probably run into problems with this, though? I measured the 5v rail on the arduino and it's within spec no matter which adapter I use. Unfortunately I'd probably need a real multimeter to get the kind of accuracy needed to figure that out, however.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Far-seeker on Sep 28, 2012, 08:14 pm
It can work, but to absolutely ensure the regulator will output a stable 5 VDC within a reasonable tolerance the input has to be at least 1.5 Volts above 5 VDC.

Edit:  And 7.5 VDC can be easily achieved with standard alkaline batteries and is much more common voltage level for wall-warts to output than 6.5 VDC.  Technically though, a nominally 6 VDC lead acid battery with a full or nearly full charge will have an actual voltage above 6 VDC, and probably above 6.5 VDC.  So depending upon the additional current draws, a nominally 8 VDC, 10 W or more solar cell could keep a battery at a high enough voltage for a dependably stable output.
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Sep 28, 2012, 08:38 pm
Two points:

1) if you look at those datasheets for the devices, many of them will go down to 2-ish volt or even 1-ish volt for newer devices. So they don't have to work at 5v. The arduino happens to be designed to work with 5v. But if you were to jump that regulator, you can go down much lower than 5v. BTW, they don't need that 5v to be precise either.

2) even in a non-LDO regulator, the minimum voltage drop over the regulator is substantially lower than 1.4v at low current levels. The LM317, for example, has two p-n junction on the output path. So it needs 1.3 - 1.4v to deliver full regulation at its rated current (0.5 - 1.5a). However, your mcu will drow substantially less than that - on the tune of 20ma on a good day. So the required voltage drop will be substantially less than 1.4v.

Title: Re: 6v to DC input jack seems to work fine?
Post by: Far-seeker on Sep 28, 2012, 08:56 pm

1) if you look at those datasheets for the devices, many of them will go down to 2-ish volt or even 1-ish volt for newer devices. So they don't have to work at 5v. The arduino happens to be designed to work with 5v. But if you were to jump that regulator, you can go down much lower than 5v. BTW, they don't need that 5v to be precise either.


If you do want to be precise, the ATmegaV328P microcontroller on the Uno has an operational range of 1.8 to 5.5 VDC.  However, the operating voltage heavily influnces the clock speed.  For example, a 16 Mhz clock is only really possible between 4.0 and 5.5 VDC (see  Figure 29-145 of the datasheet (http://www.atmel.com/Images/doc8161.pdf)).  That's why ATmegaV328P-based boards operating on 3.3 VDC are usually only 8 Mhz (half the speed of the official Uno).

Edit: Just to be clear I am in agreement with dhenry's second point.  :)
Title: Re: 6v to DC input jack seems to work fine?
Post by: oric_dan on Sep 28, 2012, 11:28 pm
@OP, it's normal for [non-regulated] wallwarts to be outputting 4-5V
above their rated voltages for "small" load currents. The voltage only
drops to near the rated voltaqe for load currents near the max for the
given device.

So-called regulated wallwarts should always produce near the rated
output voltage, however.

A 6V non-regulated wallwart will probably work fine as long as the total
Arduino load currents are small.
Title: Re: 6v to DC input jack seems to work fine?
Post by: MrGarak on Oct 05, 2012, 09:14 pm
Thanks for the info. Yea, even when under load the voltages from the 7.5 and 9v wallwarts are around 11-13v. Not good. The current ratings on them vary from 450ma to 1A. I would have thought the 450ma one would have dropped to the spec voltage under load, but it didn't. The 6v one is the only one that appears to work, but I guess I'll find out for sure if there are any problems once I test it under a higher load (lcd screen, ethernet shield).
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 05, 2012, 10:03 pm
Quote
Not good.


It does not matter, as your arduino will re-regulate that anyway. So as long as the voltage coming from your little adapters doesn't go above what the arduino onboard regulator expects (18v max rating).

So anything less than that and more than 6.5v functions the same to the arduino.
Title: Re: 6v to DC input jack seems to work fine?
Post by: MrGarak on Oct 05, 2012, 10:08 pm
Yes, I understand it will regulate it, but the vreg chip gets hot using anything except the 6v adapter. I'd ideally like to waste less power and generate less heat. Unfortunately, I have not been able to find an adapter that puts out 7.5v, despite having two which claim to. The 6v adapters I have work great, and the vreg never gets warm, but I have read on these forums that you ideally want at least 7.5v input to the dc barrel jack due to voltage drop from the regulator. Despite this, my 6v adapter seems to work so far, but I've yet to try it under higher load.
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 05, 2012, 10:10 pm
Quote
the vreg chip gets hot using anything except the 6v adapter.


You have then unusually high current. The mcu doesn't consume much current. Something else must be drawing that current. The onboard regulator really isn't meant to power heavy loads.
Title: Re: 6v to DC input jack seems to work fine?
Post by: MrGarak on Oct 05, 2012, 10:14 pm
Hm, that's odd, not sure what would be using that much current. I was only running a LED blinking sketch when testing the adapters and checking the vreg heat. The LED was wired in series with a 1k ohm resister, and was only drawing ~5ma. With the 6v adapter the vreg ran cool, but with any of the others which input 11-13v, it got warm to hot.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Far-seeker on Oct 05, 2012, 10:21 pm

With the 6v adapter the vreg ran cool, but with any of the others which input 11-13v, it got warm to hot.


This is as expected.  A linear regulator converts the excess voltage into heat, so the greater the difference between the input voltage and the output of 5 VDC the more heat it will generate.
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 05, 2012, 10:22 pm
Quote
with any of the others which input 11-13v, it got warm to hot.


Let's say that warm means temperature increase of 30c. The package has a thermal resistance of 100c/w (less than that actually). That means a power dissipation of 0.3w. At a voltage drop of 13v -> 5v, that means a current consumption of 40ma.

With the same math, assuming hot means temperature increase of 50c, you get a current consumption of 60ma.

I would have expected the load to be 20ma max and 10ma typical for your situation.
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 05, 2012, 10:29 pm
To give you some sense, I have a board with the following load: 3 avrs, 1 pic, 1 1602 lcd, two hc132 oscillator (14Mhz + 70k), two hc04 oscillators (4Mhz + 12Mhz), 1 4-digit 7-segment led, 1 25Mhz oscillator, 1 14.7Mhz oscillator, one rgb led, 9 bright leds, 2 7-segment leds.

Powered from a 15v Verizon phone adapter, regulated down to 3.3v, the linear regulator (to220, no heatsink) is lukewarm. I think I measured my current consumption at one time and it was around 50ma.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 06, 2012, 01:00 am
Somehow those numbers don't tally with your list of equipment. 50mA sounds more like the quiescent current for the listed devices. The 2 7 segment devices alone IF displaying anything would be drawing 5mA/seg typical minimum current, assuming you are displaying 6 1's... is .005 X 2 segments X 6 digits = 60mA. A typical backlight whether EL or LED will draw 100 mA.
15V - 3V3 = 11.7 X .05A = 0.585W so the 'basic setup' doing nothing causes the regulator to dissipate 585mW, add 100 mA from the LCD backlight and the power dissipated is now 1.755W and that is well past the point where a prudent engineer would have added a heat radiator of some type. My break point is 10 deg C + ambient above that and I make available a 50mm X 2mm piece of aluminum. Everyone is different and if what you have works for you then by all means go with it... The numbers don't seem right to me so... My $0.02's worth.

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 06, 2012, 01:42 am
I may be able to help with your math.

Quote
X 6 digits = 60mA.


Really? What about multiplexing?

Quote
A typical backlight whether EL or LED will draw 100 mA.


I must have an atypical lcd: its backlighting works fine with a 330ohm resistor to the 3.3v rail.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 06, 2012, 03:11 am
Indeed. My offering was simply an opinion it either fits or it doesn't as to multiplexing I chose that example on purpose to reflect the effects of multiplexing, the current drain will still be very similar, Mux'd LED's were all we had for years as indicators. Long before LCD's were more that a laboratory fantasy, They've been used in one form or another for more than 40 years of my direct knowledge. that having been said. I guess the remaining opinion I hold is that it is possible that there is a driver on board the LCD, it is there on my graphic LCD's for PWMing the backlight. 3V3 / 330 ohms = 10 mA. Impressive efficiency or base bias current for an NPN transistor? measuring the drop across the resistor should tell. Again IMO and good fuel for a discussion?

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 06, 2012, 03:28 am
Quote
the current drain will still be very similar,


Let's think it through. 5ma per segment and you have 2 segments -> 10ma per digit when that digit is on, 0ma per digit when that digit is off.

Let's say that you "mux" them 1ms per digit.

ms 1: digit 0 is on, digit 1..7 are off. Total current consumption: 10ma (for digit 0).
ms 2: digit 1 is on, digit 0, 2..7 are off. Total current consumption: 10ma (for digit 1).
ms 3: digit 2 is on, digit 0..1, 3..7 are off. Total current consumption: 10ma (for digit 2)
...

Do you see a pattern now? What's the new math?


Quote
I guess the remaining opinion I hold is that it is possible that there is a driver on board the LCD


You guessed right. Many of those lcds have backlight rated at 20ma max and no big difference at 10ma.

Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 06, 2012, 04:03 am
I was also going to recommend that the OP look up the ecact part number of the regulator, there are graph's of dropout voltage vs load current that will serve him well as would looking at the schematic of the regulator and noticing how the reverse voltage protection is done there is a silicon diode in series with the positive DC input lead. The symbol indicates it is a junction type diode so it will have between .5 and .7 V drop across it depending on temperature and load current I just looked at the attached data sheet and again something doesn't add up right. If we accept his measured 6V at the PSU connector and (oops I just realized I don't for sure know which board he has and how it is reverse protected) a .63V typical drop across a si junction then there is 5.36V left to the regulator and according to the attached data sheet it should be out of regulation for all but the lightest loads unless there is another 1/2 volt or so present but unaccounted for. The 7V lower limit is spot on and good engineering according to the data sheet. If it were my problem I'd take a switcher and use the highest "power output" supply I had and set the output of the switcher to either 5V and supply the board directly or take the much safer route of supplying 7V to the board and let the internal supply do it's job, this also allows the switcher to be noisier that usual with no side effects as the linear regulator and attendant filtering will clean it up quite nicely. I would also use a 2A fuse and a 1.5KE6.8 Tranzorb or a 6.8V 2W Zener and a silicon diode to on the output of the switcher and slightly lower the switcher output voltage for board protection should the switcher fail, I've used a grip of LT1170's with one failure and that was caused by the power transformer being wired across a leg of a 440V 3 Phase Pump service and neutral(about 277V If I remember right) the electrician was using a defective wiggie and didn't really know what he was doing. Most switchers (All I own {5} have an area that can be soldered to a copper strap. I would use a .5mm X 50 mm piece of copper sheet metal and solder it to the area just under the actual switcher all of mine and all I've seen have a great lot of Via's at that point for heat conduction to the bottom side of the PCB and I would use a 1.5 - 2mm screw and nut W/Washer to mount it to something that would help in removing whatever excess was developed by the switcher. Efficiencies run about 90% so with a 1A load you would have to get rid of a half watt, Easy. Again just my $0.02's worth or  IMO

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 06, 2012, 01:32 pm
Quote
according to the attached data sheet it should be out of regulation


Those minimum voltage differential requirements are specified at pretty high current levels (usually at or close to the rated current levels). An arduino board will not draw anything close to that kind of current. So smaller voltage differentials will work - there are two charts in the datasheet that indirectly speak to that.

Plus, out of regulation doesn't mean it doesn't pass power anymore. It just that its ability to regulate output voltage is gone.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 06, 2012, 07:56 pm
Well it would be a nice world is that were something you could take to the bank... but "Out of Regulation" is undefined and as such is highly questionable and based more on wishful thinking than reality. The reality is that you have a very high gain DC amplifier with an unstable reference voltage. a more understandable comparison might well be that you have a really big car (The Regulator) moving across an area (output Voltage) without a driver (The Reference Voltage) High gain because the reference term is a current (Typ 100uA) controlling a regulator capable of an Ampere of current and it doesn't take a genius to figure out that 100 uA is a tenth of a milliamp and as the name implies a milliamp is 1/1000th of an ampere so we have a gain of 10 X 1000 and no stable input reference. The typical result for an NPN pass type (AKA 78XX series) is oscillation and for the PNP Pass types like the AMS1117 the reference term is a part of the load current... So there is a minimum current that must be drawn from the regulator for the regulator to be stable and a processor unfortunately doesn't fit that condition... again the result is typically oscillation. I first ran into this issue trying to shift the output voltage of an LM2931AZ-5.0 (Data sheet attached) from 5 to 6.2V. Normally the ground pin which carries the reference current for the regulator is connected to a resistor to ground and the output of the regulator is fed back to the ground pin creating a "new" Ground reference voltage and thus shifting the output voltage by the amount of voltage dropped across the resistor to ground. Simple? Right? NO because if the input voltage is slow to come to value even be as little as a hundred uS it causes the regulator to oscillate at about a MHz or so and since the output filter is a short circuit at that frequency the regulator gets hot, goes into thermal limiting, cools down and then does the whole thing again and again it can be simulated easily by placing a 10 ohm resistor in series with the supply lead and not bypassing the input... Just 10 ohms. An interesting side note is that a 78l05 plugged into the same circuit works perfectly because the 78XX series of devices uses an NPN pass transistor and the reference supply is different, internally. In short IF a Regulator isn't biased properly it's output is undetermined and really undeterminable. The Chip designer had some variables and some constants in his design, load current and Minimum reference supply voltage, If you don't meet those conditions then your circuit's response is undeterminable. This statement makes me want to ask where you buy your drugs from...
Quote
Plus, out of regulation doesn't mean it doesn't pass power anymore. It just that its ability to regulate output voltage is gone.

Now what can that mean? What kind of POWER DOES IT PASS... if at all. My intent here is to point out that just because it might work in basic testing is no guarantee that it will work accurately and to "Some" specification under varying input and load conditions. which is basically what you said when you said that it wasn't a "regulator" anymore the problem is that not meeting basic spec means literally that the "regulator" is more a liability than an asset. IMNSHO

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 06, 2012, 08:21 pm
Quote
The reality is that you have a very high gain DC amplifier with an unstable reference voltage.


I don't know where you got that "unstable reference voltage".

Quote
a more understandable comparison might well be that you have a really big car (The Regulator) moving across an area (output Voltage) without a driver (The Reference Voltage) High gain because the reference term is a current (Typ 100uA) controlling a regulator capable of an Ampere of current and it doesn't take a genius to figure out that 100 uA is a tenth of a milliamp and as the name implies a milliamp is 1/1000th of an ampere so we have a gain of 10 X 1000 and no stable input reference. The typical result for an NPN pass type (AKA 78XX series) is oscillation and for the PNP Pass types like the AMS1117 the reference term is a part of the load current... So there is a minimum current that must be drawn from the regulator for the regulator to be stable and a processor unfortunately doesn't fit that condition... again the result is typically oscillation.


Let me be the first one to say that I have absolutely no clue what the above is talking about and I doubt you do.

Those regulators work not by amplifying some kind of current. The current" is needed to run a voltage reference / error amplifier. In the case of LM117/317 for example, that current runs the bandgap voltage reference. That current itself has nothing to do with the output current, otherwise.

The minimum voltage drop you observed is due to Vce of the regulator. In the case of a regulator regulator (like LM317 or AMS1117), it is two Vbe voltage drop as the regulator works as a follower. In the case of a true LDO, that's the Vce of a common collector amplifier.

[/quote]I first ran into this issue ...[/quote]

I have no idea what you are talking about and I doubt you do either.

Quote
Now what can that mean? What kind of POWER DOES IT PASS


The kind of power that powers your arduino.

Quote
My intent here is to point out that


My intent here is to point out that just because the in-output voltage differential goes below the figure specified in the datasheet doesn't mean you cannot power your arduino with it.

If you would like to discuss more on technical terms, I am happy to.
Title: Re: 6v to DC input jack seems to work fine?
Post by: MrGarak on Oct 07, 2012, 01:46 am
Ok, I've had a chance to do some more experimenting with this. As suspected, the 6v supply just isn't enough. I noticed this by the LCD screen's behavior on the 6v supply, it was sluggish when updating and kind of glitchy. On USB or the higher voltage supplies it works normally. I tried a 7.5v 1A supply, and it put out 10v under the arduino load. Vreg chip got hot enough to get that burning feeling after checking its temp for 4-5 seconds. I found a 600ma 7.5v supply which I had to rewire for positive tip polarity, tried it out. That one had 9v under load. Unfortunately, vreg chip is still burning hot. Back to using USB cable for now, and vreg chip is running nice and cool with that. Might have to get one of those well regulated USB charger supplies, I've run out of suitable wall warts to test.
Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 07, 2012, 04:14 am
As to
Quote
Let me be the first one to say that I have absolutely no clue what the above is talking about and I doubt you do.
I wouldn't try discussing anything with an expert of your caliber... I'd be fighting with an un armed man... The regulator can't get hot on USB power... it isn't used, that's what the OP-AMP does it turns on a fet when there is no DC power applied... connecting the USB power to the board... 5V directly from the USB power... this also seems rather strange consiidering your hardware list and I quote:
Quote
To give you some sense, I have a board with the following load: 3 avrs, 1 pic, 1 1602 lcd, two hc132 oscillator (14Mhz + 70k), two hc04 oscillators (4Mhz + 12Mhz), 1 4-digit 7-segment led, 1 25Mhz oscillator, 1 14.7Mhz oscillator, one rgb led, 9 bright leds, 2 7-segment leds.

Powered from a 15v Verizon phone adapter, regulated down to 3.3v, the linear regulator (to220, no heatsink) is lukewarm. I think I measured my current consumption at one time and it was around 50ma.

50 mA would cause a small heat rise in the linear regulator a Backlight @ ~150mA would make it quite warm, uncomfortably so but not noticeable if operated from USB power as the regulator wouldn't be in circuit. I was really beginning to wonder if you would ever realize that... Small Detail. And Yes, I have forgotten more about linear regulators that you will ever learn, I made my first discrete 40 years ago... from the style of your writing I'd put you at under 30... well under, so don't even try to question my experience or knowledge until you've walked a mile in my shoes.

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: dhenry on Oct 07, 2012, 04:31 am
Quote
I made my first discrete 40 years ago...


Isn't that the same year when you invented the internet?
Title: Re: 6v to DC input jack seems to work fine?
Post by: Docedison on Oct 07, 2012, 04:38 am
You are cute and ever so typical... that joke fell on it's face about 30 seconds after it was born... Like I said a battle with an un armed man

Bob
Title: Re: 6v to DC input jack seems to work fine?
Post by: Far-seeker on Oct 09, 2012, 04:53 pm

Might have to get one of those well regulated USB charger supplies, I've run out of suitable wall warts to test.

FYI, there are well regulated power supplies other than USB chargers, some even come in wall wart form.  Generally, if the label states it's a regulated supply that can be trusted.  However, by now you should be able to verify that easily and such verification never hurts.
Title: Re: 6v to DC input jack seems to work fine?
Post by: CrossRoads on Oct 09, 2012, 05:16 pm
Have you looked at switching regulator wallwarts?
http://www.dipmicro.com/store/DCA-07510
These do not put out the high voltages that you seem to be seeing with your other sources.