Arduino Forum

Products => Arduino Due => Topic started by: michaeluna on May 25, 2013, 11:43 pm

Title: Errors in Due board/schematic files
Post by: michaeluna on May 25, 2013, 11:43 pm
Hi all. I'm wondering if anyone else has tried to build their own Due from the files posted, and found errors?

For reference, these are the files currently linked from the Due product page: http://arduino.cc/en/uploads/Main/arduino-Due-Reference-design.zip

So far, the design errors I've found are:

- The Y4 crystal should be 16mhz, not 12mhz as is shown in the schematic and board file.

- The USB jack for the Native port has a footprint that doesn't match that of the Programming port. If you plan to use the same part for both USB ports, it won't fit. I recommend copying the part from the Programming port over to the Native and redoing the connections. The jack I used is this one: http://www.digikey.com/product-detail/en/10118194-0001LF/609-4618-2-ND/2785389

One other thing to watch out for, and this isn't an error in the design but will trip you up, is that you have to flash the 16u2's firmware before it will work as intended. There's a great thread on how to do that here: http://forum.arduino.cc/index.php?topic=147639.0

I ask because I'm certain there are more errors, and I'm currently in the weeds trying to suss them out. I've gotten my board to show up in Windows as an Arduino Due and it will assign a COM port, but the Arduino IDE consistently says it's unable to find a device on that COM port. Which I'm pretty sure means that the 16u2 is functioning correctly, but the SAM3x8E is not. Or the communication lines between the 16u2 and the SAM3x8E are not properly connected, but I just checked those and I'm pretty sure those are fine.

I'm now digging through all the connections required to power and clock the SAM3x8E, to make sure it's up and running on it's own. But it's slow going as I'm not a professional engineer and I've never worked on something of this complexity before.

In any case, I would very much appreciate any information from someone who's attempted this before and especially if you've discovered any additional errors in the released design files.

Much thanks!
Title: Re: Errors in Due board/schematic files
Post by: stimmer on May 26, 2013, 12:17 am
The two different USB sockets is not an error - the native port is a micro-AB socket and the programming port is a micro-B socket (this is clearly marked on the diagram). This is needed when using the native port as a USB host - A USB host adaptor should have a USB micro-A plug and will not fit a micro-B socket.

However, the cheap Chinese USB host adaptors that you see on Amazon and Ebay have often been (incorrectly) made with a micro-B plug. If you did duplicate the programming port socket on the native port it might still work as a host if you can get one of those adaptors with the wrong plug.
Title: Re: Errors in Due board/schematic files
Post by: graynomad on May 26, 2013, 01:23 am
Quote
The Y4 crystal should be 16mhz, not 12mhz as is shown

Correct, Y4 is labelled incorrectly.

Quote
The USB jack for the Native port has a footprint that doesn't match that of the Programming port.

Correct again, but they shouldn't be because they are different connectors.

______
Rob
Title: Re: Errors in Due board/schematic files
Post by: michaeluna on May 27, 2013, 10:30 pm
Do either of you have a part number handy for the USB Micro-A connector? I'm having trouble locating that type of connector. This isn't correct, is it? http://www.mouser.com/ProductDetail/Hirose-Connector/ZX40-A-SLDA/?qs=sGAEpiMZZMulM8LPOQ%252bykzmHhzPuOAFGEUTwYyFb6Wg%3d
Title: Re: Errors in Due board/schematic files
Post by: graynomad on May 28, 2013, 01:18 am
Never seen one of them before, I don't know what it is.

This is the sort of thing you are looking for.

http://au.element14.com/molex/105017-0001/micro-usb-b-receptacle-smt-ra-5way/dp/2293836 (http://au.element14.com/molex/105017-0001/micro-usb-b-receptacle-smt-ra-5way/dp/2293836)
http://www.digikey.com/us/en/ph/FCI/MicroUSB_Connector.html (http://www.digikey.com/us/en/ph/FCI/MicroUSB_Connector.html)
https://www.sparkfun.com/products/8533 (https://www.sparkfun.com/products/8533)

______
Rob
Title: Re: Errors in Due board/schematic files
Post by: michaeluna on May 28, 2013, 06:47 am
That's it, thank you!

I'm still not getting my board to boot up yet, but in the meantime I'm finding all sorts of errors I made with other parts of the circuit. I'll post here if I find any other flaws that originate with the Arduino open source files.
Title: Re: Errors in Due board/schematic files
Post by: graynomad on May 28, 2013, 09:22 am
Quote
I'm finding all sorts of errors I made with other parts of the circuit.

You wouldn't be the first :)

I'm currently designing a Due-style board as well, I'm happy to look at your circuit if you like. Maybe we're both making errors :)

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: michaeluna on Jun 14, 2013, 07:11 am
Adding another mystery here:

The Due .sch and .brd files show IC10 up in between the two header rows.

(http://i.imgur.com/7YtQ3xh.png)

A Due I ordered and received this week has IC10 in the lower left near the power jack.

(http://i.imgur.com/7AjTKvs.jpg)

Now I'm beginning to wonder how many other small inconsistencies are present in the files, and whether the files represent a viable circuit at all. I built a board using them and I've been trying to get it to work for weeks with no luck.
Title: Re: Errors in Due board/schematic files
Post by: Aiekakiku on Jun 14, 2013, 03:35 pm
I'm trying to debug my own board based on the due schematics.  So I made the mistake placing a 12MHz cristal for 16U2.
Now I'm waiting 16Mhz one.  At least, the SAM3X8E is moving from the JTAG port,  AtmelStudio, pwm_led_example.c + SAMICE.
One thing I'm wondering is 4pin "DEBUG" connector.  maybe SWD ports but doesn't work.  even it's white dot mark doesn't mean The '1'  pin.
Title: Re: Errors in Due board/schematic files
Post by: graynomad on Jun 14, 2013, 03:48 pm
@michaeluna
That was reported soon after the Due was released, no reasonable reason (IMO anyway) was offered for the downloadable files being different to the production boards.

@Aiekakiku
The schematics are wrong WRT that crystal and at least on other item (that doesn't affect anyone making a similar board).

All in all it's clear that the offered "design files" are not the exact files used to create the production board.

Quote
I built a board using them and I've been trying to get it to work for weeks with no luck.

Do you want to share your schematics? I've only designed a SAM board so far not actually built it, but I may spot something.

Re the debug connector, AFAIK you need to use JTAG to enter SWD mode anyway so I'm not sure what use it is. I may be wrong on that but that's how I interpret the data sheet.

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: Aiekakiku on Jun 15, 2013, 03:40 pm
My own board based on the due schematic can be recognized by arduino 1.5.2 afetr  replacing  12MHz cristal with 16MHz.
then  I can write down Blink sketch on it.   It works, but  I feel something wrong around the reset circuit.

>but the Arduino IDE consistently says it's unable to find a device on that COM port.
Actually I got this message. then reset the board and it come to be able to write sketch. something wrong.

PS. 'DEBUG' connector worked,  JLink Debuger requirs one more pin  ' Vref ' .
Title: Re: Errors in Due board/schematic files
Post by: Aiekakiku on Jun 15, 2013, 04:07 pm
I think I found something.   R23 10K on MASTER_RESET signal.  It's not good.   In my memmory.   NRSTB pulled up inside cpu with 15k orhm.

So 16U2 can't draw the signal down to the graund.   Acturally it saw  it dwon to half level.   After short the R23, my own board is smoosely recognized and recieve the scketch and move correctly.

But it causes another problem.  Maybe short is not good.   Do I need 1k or some resistor instead?  or  16U2(22) RESET_CMD  pin is Open Drain?
Title: Re: Errors in Due board/schematic files
Post by: graynomad on Jun 15, 2013, 04:47 pm
You might have a point there. The internal pullup is a nominal 15k and the MASTER-RESET signal is driven through a series 10k (R23 as you say), that forms a voltage divider that will be about .94V on the reset pin when asserted by the 16U2.

I can't find the valid voltage levels for the NRSTB pins but the max Vil for a standard pin is 0.3 x VDDIO, or .99V.

That's pretty close and not a great choice given that the pullup resistor can range from 10 to 20k. Of course NRSTB may have a different threshold.

Can you verify that R23 is actually 10k?

The only reason I can think of for having R23 at all is to protect the 16U2 in the case of it asserting MASTER-RESET at the same time as the reset PB was pressed. Therefore I assume that pin 22 on the 16U2 is not open drain.

I would replace the 10k with a 1k as you say, just to be on the safe side.

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: Aiekakiku on Jun 15, 2013, 05:01 pm
I can't find out the acutual value of R23 on the real due board.  because  it doesn't have silk name on the board.
I looked into the Arduino-usbserial.c.  It says

void setResetPin(bool v) {
   /* Target /RESET line  */
....
   /* INACTIVE => set as INPUT (internal pullup on target /RESET keep it at 3.3v) */
...
}

Maybe, maybe it would never drive the reset Hi.  I'm not sure.

Title: Re: Errors in Due board/schematic files
Post by: graynomad on Jun 15, 2013, 05:05 pm
OK, sounds like something put in as a "maybe we'll use it one day" feature that is not used.

If that's the case this is another discrepancy between the design files and the real thing.

I'd say you don't need R23 at all.

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: michaeluna on Jun 16, 2013, 01:55 am
Graynomad, you're a helpful dude. Thank you so much for your expertise.

Here's my schematic. I literally just opened the Due release files and added some of my own circuitry to it to make this musical instrument I've been designing.

(http://i.imgur.com/icCvn1q.jpg)
Title: Re: Errors in Due board/schematic files
Post by: michaeluna on Jun 16, 2013, 02:29 am
I have a question related to JTAG here, because that's the next avenue I'm exploring to figure out what's up with my boards.

The 10-pin connector the JTAG on the Due boards has 1mm spacing, which is super small. I'm looking high and low for the connector cable to attach to those pins and I'm not finding it anywhere. Maybe it's because I din't know what it's proper name is? In any case, do any of you have a link to the type of cable that connects to those pins?

In my next revision of the board I'm switching that header to the standard size. And making both USB jacks identical, that was a huge headache as well...
Title: Re: Errors in Due board/schematic files
Post by: graynomad on Jun 16, 2013, 02:40 am
The spacing is actually 1.27mm or .05", they are reasonably common although nowhere near as much as the .1" version.

http://www.embeddedartists.com/products/acc/acc_idc_10.php (http://www.embeddedartists.com/products/acc/acc_idc_10.php)

Or if you need to convert to the standard 20-pin JTAG this should work

https://www.olimex.com/Products/ARM/JTAG/ARM-JTAG-20-10/ (https://www.olimex.com/Products/ARM/JTAG/ARM-JTAG-20-10/)

Quote
And making both USB jacks identical

So they should both be micro AB sockets then I assume.

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: graynomad on Jun 16, 2013, 02:48 am
@michaeluna
I gather that schematic is not yet finished? There are a lot of unconnected nets.

Where do all the debounced switch inputs go?

EDIT: I also juts noticed that none of the wire joins have dots, that normally means they are not connected.

_____
Rob
Title: Re: Errors in Due board/schematic files
Post by: chriskner on Jun 17, 2013, 02:50 pm
Michaeluna,

From going over the DUE schematic some time ago, I remember questioning the existence of T2.  It is a P-channel fet that always seems to be turned on.  It doesn't harm anything I suppose.  However, it would never turn off unless the 5V power port suddenly became negative.  I've seen uses like this for battery-polarity reversal protection.  I'm not sure how it applies here though.

I had some other minor comments that can be found here:
http://forum.arduino.cc/index.php?topic=146574.msg1101238#msg1101238 (http://forum.arduino.cc/index.php?topic=146574.msg1101238#msg1101238)

Also, when it is obvious, I think that judicious use of power-ports and net-labels make a schematic easier to read, and preferable over crossing wires (i.e. the bank of switches, digital pots, and so forth).  If you're trying to convey special pcb grouping, routing, or operation with the display of the wires on the schematic, then a few words on the schematic print would go a long way to explain your intentions.

Rob is right-on about the junction dots.

Best of luck with your project.

Chris
Title: Re: Errors in Due board/schematic files
Post by: emech on Aug 26, 2013, 05:06 am
I would like to confirm the post from Aiekakiku (thanks!) http://forum.arduino.cc/index.php?topic=168399.msg1279303#msg1279303 (http://forum.arduino.cc/index.php?topic=168399.msg1279303#msg1279303)
R23 is the wrong value. It should be 1K

On my DUE it was preventing the 16U2 from resetting the SAM3X and causing the "No device found on COMxx" errors.
It also prevented the SAM3X from being reset after successfully loading a sketch.
I suspect that many others have this same problem on the DUE.

my related post with details: http://forum.arduino.cc/index.php?topic=167492.msg1366523#msg1366523 (http://forum.arduino.cc/index.php?topic=167492.msg1366523#msg1366523)

Update: See also http://forum.arduino.cc/index.php?topic=167492.msg1373055#msg1373055 (http://forum.arduino.cc/index.php?topic=167492.msg1373055#msg1373055) for the necessary 16U2 firmware fix
______
Andrew
Title: Re: Errors in Due board/schematic files
Post by: aureliusss on Aug 26, 2013, 06:28 pm
i think this thread should ''official'' and all the differences between reference schematic and real board should be posted here
Title: Re: Errors in Due board/schematic files
Post by: Docedison on Sep 11, 2013, 05:40 am
@michaeluna... I've been doing schematic drawings for nearly 50 years and "That" is the most unique and difficult to follow schematic drawing I've seen yet.
That having been said and it wasn't intended as a criticism by any means your work, as far as it goes is OK.
Remember always that a schematic is a road map first and in many cases additional material not usually included in the BOM is represented on the schematic.
Individual circuits like the Power Supplies, Controller and I/O circuitry are usually in separate area's... The Uno drawing is an example of one that is close to the ideal.
I used a high end cad package when I last worked (2008) and I do realize that struggling with a 'difficult' free package has it's special challenges, ones you have done well with.
My best piece of advice would be to study how others (professionals) compose their drawings and try to incorporate (copy the style) of the most legible and understandable ones into your style.
A Schematic drawing is an engineering document used for many different purposes and by many different people. All the way from the poor techie that has to use it for troubleshooting to the people who actually order parts and use the schematic as a means of verifying the BOM for accuracy... of parts and sometimes the count as well.
And let's not forget the other engineers that may need to use the drawing as well... Great work for a beginner.

Doc
Title: Re: Errors in Due board/schematic files
Post by: xuthus on Apr 01, 2017, 05:19 pm
I have found a group label inconsistencies in the schematic.  The naming of the AD inputs is flipped in the schematic.

Sources: Atmel SAM3X datasheet 23-Mar-15
                  Arduino DUE Schematic (download fom site dated ?)

Peripheral from pg.18
Datasheet Labels from pg.40

 Pin #  Peripheral  Label (Datasheet) Label (Schematic)

78          PA16              AD7                 AD0
79          PA24             AD6                 AD1
80         PA23             AD5                 AD2
81           PA22             AD4                 AD3
82          PA6               AD3                 AD4
83          PA4               AD2                 AD5
84          PA3               AD1                  AD6
85          PA2               AD0                 AD7

Title: Re: Errors in Due board/schematic files
Post by: ard_newbie on Apr 01, 2017, 06:35 pm

ADC Channel 7 is A0
…………………………….
ADC Channel 0 is A7

It's weird…but correct. :smiley-confuse: