Arduino Forum

Forum 2005-2010 (read only) => General => Frequently-Asked Questions => Topic started by: Goobers on Mar 16, 2007, 04:10 pm

Title: Serial > Midi driver
Post by: Goobers on Mar 16, 2007, 04:10 pm
Hi,

I've been having problems getting the roland serial > midi driver working correctly. I've set up the driver with the arduino on COM2 (as it only supports COM1 > COM4) and I've altered the arduino serial usb drivers to support the correct rate, but I'm not getting any serial output from the arduino with the driver (the transmit light doesn't come on). I've got some basic code on the arduino sending a midi control change message repeatedly (getting the value from a potentiometer)

Does anybody have any idea why I might be getting these problems?

Thanks,

Andy
Title: Re: Serial > Midi driver
Post by: Goobers on Mar 17, 2007, 04:22 am
Nevermind, I got it working now, I hadn't altered the FTDI settings correctly. Controlling the crossfader in Traktor and controls in Ableton with it now!
Title: Re: Serial > Midi driver
Post by: leKuk on Mar 22, 2007, 04:06 pm
you're on windows, aren't you?

(still trying to get the roland driver to work under OS X)
Title: Re: Serial > Midi driver
Post by: Goobers on Mar 27, 2007, 01:06 am
Yeah, I'm using windows at the moment, but i'm tempted to give OS X a look at some point, cos I'd like to be able to use the controller I'm making with Isadora on the mac.
Title: Re: Serial > Midi driver
Post by: fire.is.real on Mar 27, 2007, 07:27 am
andy,

would you mind posting how you modified the serial usb drivers to usethe correct rate?

thanks,
nick
Title: Re: Serial > Midi driver
Post by: Goobers on Mar 30, 2007, 09:48 pm
I got the info from this thread http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1161023163
:)