Arduino Forum

International => Portugues => Topic started by: gui. on Aug 07, 2011, 07:41 am

Title: Dúvida - Sensor Ultrassônico SRF04
Post by: gui. on Aug 07, 2011, 07:41 am
Boa Noite pessoal. Meu problema é o seguinte: estou usando um sensor ultrassônico SRF04 como detector de obstáculos para o meu robô seguidor de linhas. Tudo funciona, mas não como eu queria; antes de usar o ultrassônico, o robô tinha uma leitura da linha muito boa, rápida e precisa. Agora, com o ultrassônico, a leitura está muito lenta e muitas vezes o robô sai da rota. Usei o "Serial Monitor" da IDE para checar a velocidade de leitura(apenas do ultrassônico e não dos demais sensores), e está realmente lenta, mesmo em um arduino com programação apenas para ler o sensor. Será se é normal para este modelo (HC-SRF04) ? Pode ser variáveis ocupando muito espaço da RAM ? Por favor me ajudem, ficarei muito grato!

Componentes usados:
•ATMEGA 328
•HC-SRF04
Title: Re: Dúvida - Sensor Ultrassônico SRF04
Post by: gui. on Aug 09, 2011, 10:51 pm
Problema resolvido...
Title: Re: Dúvida - Sensor Ultrassônico SRF04
Post by: ViniciusPolo on Aug 18, 2011, 06:40 pm
Olá.
Para ajudar a comunidade e quem mais tiver com seu problema, poderia nos dizer qual era o problema e a solução?
Obrigado.
Title: Re: Dúvida - Sensor Ultrassônico SRF04
Post by: Henriquinho on Jan 03, 2014, 06:11 pm
Aproveitando o assunto vocês sabem se existe algum tutorial vídeo para ensinar como usar esse detector (http://www.primeimports.com.br/produto/detector-eletronico-de-obstaculos-laser.html)?