Show Posts
Pages: [1]
1  Using Arduino / Displays / Re: LiquidCrystal 4x40 library for Arduino 1.0.1 on: July 29, 2012, 02:57:21 am
Working fine

Thanks all
2  Using Arduino / Displays / Re: LiquidCrystal 4x40 library for Arduino 1.0.1 on: July 28, 2012, 10:37:53 am
Well I feel as though I am getting closer   smiley

I renamed the LiquidCrystal library that came with IDE1.0.1

I then copied in the new library from LiquidCrystal1.0.zip/LiquidCrystal for Arduino 1.0/Sep 2011
as 'LiquidCrystal'

I then changed the code
//New line below
//Syntax
//LiquidCrystal lcd(RS,RW,Enable1,Enable2, data3,data2,data1,data0);
LiquidCrystal lcd(13,255,12,7, 11,10,9,8);

// Old line below
//LiquidCrystal lcd(13, 12, 11, 10, 9, smiley-cool;

In the void setup() I put
lcd.begin(40, 4);    // Set up the LCD's number of columns and rows:

On compile I get
no matching function for call to 'LiquidCrystal::LiquidCrystal(int,int,int,int,int,int,int,int)
MyProgName:345: error: no matching function for call to 'LiquidCrystal::LiquidCrystal(int, int, int, int, int, int, int, int)'
C:\arduino-1.0.1\libraries\LiquidCrystalorg/LiquidCrystal.h:56: note: candidates are: LiquidCrystal::LiquidCrystal(uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t)

I notice the compile error refers to LiquidCrystalorg, I renamed the original library to org

I have tried restarting IDE


Edit
I have now moved the  LiquidCrystalorg out of the Library folder whilst IDE was shutdown and get a good compile.
It seems as though IDE tracked the rename of the original library and did not like the additional parameters I passed in.
Will try the hardware tomorrow
Thanks
3  Using Arduino / Displays / Re: LiquidCrystal 4x40 library for Arduino 1.0.1 on: July 28, 2012, 09:50:52 am
Hi Don
The two instances of the regular library looks a little trick for me regarding incorporation into what I already have.
The liquidcrystal440 looks ideal but I am unsure of which download to take.
I assume LiquidCrystal440.zip/enhanced arduino liquidcrystal library /Apr 2010 will not be compatible with IDE1.0.1

Is this (top one on download page) the version I need to take LiquidCrystal1.0.zip/LiquidCrystal for Arduino 1.0/Sep 2011

Many thanks
Tony
4  Using Arduino / Displays / Re: LiquidCrystal 4x40 library for Arduino 1.0.1 on: July 28, 2012, 05:30:44 am
Andreas thanks
So
lcd.begin(40, 4);

Syntax

LiquidCrystal(rs, enable, d4, d5, d6, d7)
LiquidCrystal(rs, rw, enable, d4, d5, d6, d7)
LiquidCrystal(rs, enable, d0, d1, d2, d3, d4, d5, d6, d7)
LiquidCrystal(rs, rw, enable, d0, d1, d2, d3, d4, d5, d6, d7)

But my display has 2 enable lines
5  Using Arduino / Displays / LiquidCrystal 4x40 library for Arduino 1.0.1 on: July 28, 2012, 03:35:36 am
Hello, looking for a 4x40 LiquidCrystal library for Arduino 1.0.1
HD44780 based.
I assume the standard LiquidCrystal library will not handle 4 x 40 displays.
Can you help

Many thanks
Tony
6  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 02, 2012, 08:28:01 am
So I found the Leonardo board commented out in the
c:\arduino-1.0\hardware\arduino\boards.txt” file

I removed the comments, Leonardo appeared in the boards menu and we are away having a little fun.

Tony
7  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 02, 2012, 02:11:58 am
Ok so I just ordered an official Leonardo from one of your links, this will come with a 1.0.1 compatible bootloader I expect.

From this new standpoint I will be able to re-flash the the hooky Leonardo via the official working Leonardo?

Many thanks
Tony
8  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 02:20:57 pm
Ok, just working out what I have done.
Sorry I did not know the product was not yours.

Help here has been great so point me to a url to buy your Leonardo please.

Tony
9  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 01:29:01 pm
I down loaded 1.0.0 and the usb drivers are installed  smiley-mr-green

Arduino Leonardo on com 3

No Leonardo in the board choice though so will put 1.0.1 back on and see what happens





So 1.0.1 back and tried to upload blink, failed a few times giving
Quote
avrdude: ser_send(): write error: sorry no info avail

So I guess I need to burn the updated boot loader, might need some direction on this.

Many thanks
Tony
10  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 12:41:10 pm
Thanks Louis, you seem to have found my problem pretty fast, I was sure it was me doing something sooo stupid.

Not sure what the boot loader is, boot loader is initiated at run time from firmware maybe.

I have just been surfing and discovered there are different (clone) Leonardo on the market.
I had mine from http://www.olimex.com/dev/olimexino-32u4.html

At the bottom of the above page it mentions
Quote
Latest BOOTLOADER for ARDUINO IDE 1.0.1

Thanks
Tony
11  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 12:15:50 pm
Hardware Ids

USB\VID_2341&PID_0034&REV_0100&MI_00
USB\VID_2341&PID_0034&MI_00
12  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 11:49:44 am
Yes version and method just like your instruction.

Device manager adds two devices that I can see when the Leonardo is connected.

Device Manager \ Other Devices \ arduino leonardo bootloader
The drivers for this device are not installed. (Code 28)
this has the yellow ! and is what I try to install drivers for.

Device Manager \ Human interface devices \ USB input device
This device is working properly.

Tony
13  Development / Other Hardware Development / Re: Leonardo drivers for W7 on: June 01, 2012, 11:08:42 am
Thanks Louis

I can get to your Click OK step but windows says

windows was unable to install your arduino leonardo bootloader
windows could not find driver software for your device

before I can get to Click Next step

I know I will look back in this with amusement when I work out what is wrong but right now its been four hours of frustration.

Tony

14  Development / Other Hardware Development / Leonardo drivers for W7 on: June 01, 2012, 09:21:06 am
Hi, first post here.

Just had my first Arduino, a Leonardo.
Cant get the usb drivers on windows.
I get the message 'windows was unable to install your arduino leonardo bootloader'

The device is listed in device manager under \ other devices \ arduino leonardo bootloader.

Hope you can help me get over this first hurdle

Tony
Pages: [1]