Show Posts
Pages: [1]
1  International / Portugues / Re: [Ajuda] Problema ao ligar arduino no carro com bateria 12v, LCD 16x2 fica maluco on: June 30, 2012, 10:01:44 am
Boa tarde pessoal,

Obrigado pelas dicas.

Ainda não consegui resolver o problema.

Retornando as dicas:

Resp: mmoscz
Deixei um delay de 200ms antes de inicializar o display mais o problema persistiu.

Resp: fabiohbm007
Então eu montei o protótipo em uma daquelas placas com furos para soldar e a coloquei dentro de uma caixa de plástico preta, coloquei um fio para aterramento direto na lataria do carro, como não consegue um radio AM não testei, o ultimo teste que ainda não fiz é trocar o flat cable de 40 vias utilizados para ligar HD por fios menores, também acho que é interferência.

Resp: ailtonfacanha
A fonte que utilizei do GPS já trabalha com indutor e não resolveu o problema.

Resp: andrefe
A tensão passada para o arduino esta em 5.5v não varia muito.

Uma hora tem que resolver, vou persistir nos testes quem tiver mais alguma dica manda ai.
Vou tentar levar no eletricista pra ele dar uma olhada.
2  International / Portugues / Re: [Ajuda] Problema ao ligar arduino no carro com bateria 12v, LCD 16x2 fica maluco on: June 18, 2012, 10:33:09 am
Pessoal,

achei nestes outros dois forums dizendo que alguns displays tem que tem um delay para que ele seja energizado antes de ser ligado:

http://www.handmades.com.br/forum/index.php?topic=1048.0
http://forum.clubedohardware.com.br/resolvido-display-lcd/777386
http://www.asm51.eng.br/phpBB/viewtopic.php?t=9193&sid=51d09d1e382183bcf7bd89761384ab69

Não testei ainda, vou ver se consigo mexer mais tarde.
3  International / Portugues / Re: [Ajuda] Problema ao ligar arduino no carro com bateria 12v, LCD 16x2 fica maluco on: June 18, 2012, 08:20:27 am
Bom dia Amigo,

Obrigado pelo retorno.

Então eu fiz as medições com o carro ligado e somente com a chave ligada varia entre 12v e 14 v, eu fiz de duas formas para estabilizar para 5v para energizar o arduino, primeiro utilizei o conversor conforme o link que passei no post do "Renato Aloi", depois tentei utilizando uma fonte que tenho para alimentar o GPS que converte de 12v para 5.5v não deu diferença nenhuma ambos os conversores apresentaram de 5.04v a 5.5v na saida e essa alimentação é constante não varia para mais ou para menos. Infelizmente não tenho osciloscópio amigo.
4  International / Portugues / [Ajuda] Problema ao ligar arduino no carro com bateria 12v, LCD 16x2 fica maluco on: June 17, 2012, 10:37:27 pm
Boa noite Galera,

Montei um projeto no arduino para implantar no meu carro um Fiat Premio 1.3 ano 87.
É um projeto que lê o sensor de combustivel e exibe esta informação em um display LCD  16 x 2 com led Azul, resumindo fiz todos os testes na bancada deu tudo certinho, inclusive montei um conversor para converter os 12v do carro para 5v para poder alimentar o arduino, depois de todos os testes na bancada montei o projeto em uma placa e instalei no carro. De primeira funcionou tudo legalzinho (Segui o tutorial do Renato Aloi para montar o arduino na placa http://www.seriallink.com.br/lab/Arduino/Protuino_Bootloader_Seriallink.html), com o carro só com a chave ligada funciona perfeitamente mas quando eu dou partida no carro o display fica maluco, aparecendo varios caracteres diferentes um do outro e isso só ocorre quando eu estou com o carro ligado, só com a chave ligada ele funciona tranquilamente.

Alguem já passou por isto, pode me ajudar?
Pages: [1]