Show Posts
Pages: [1] 2 3
1  Forum 2005-2010 (read only) / Development / Re: T6963 Library on: November 02, 2009, 06:25:24 am
Nice work! ...

I've made some modifications on my side and changed the pins assignement. I use now digital pins 2->13 (Data first, then the 4 control lines you're using too) ... So that freed the analog pins.

Maybe it can be cool to ba able to choose between different pins configurations using #define and #ifdefs ... What do you think?

On the graphic side I have already adapted some functions to choose between black and white pen color and was planning to add some support of bitmaps upload as I plan to use my LCD as part of a remote control. I'll contact you as soon as I'll have something usable, so we can merge our code if you want.

++
2  Forum 2005-2010 (read only) / Français / Re: Projet "domotique", faisabilité on: August 07, 2009, 09:56:27 am
Bonjour,

Une petite remarque concernant les bus I2C et leur longueur limitée ... il existe des I2C bus extender comme le P82B715. Je n'ai pas encore eu l'occasion de tester personnellement, mais ça fait partie de mes projets futurs proche.
Il y a moyen d'atteindre des distances bien plus grandes à en croire ce papier : http://electro8051.free.fr/buslong/AN452.pdf .

3  Forum 2005-2010 (read only) / Français / Re: Re-Upload nécessaire après quelques semaines on: March 15, 2010, 04:19:32 pm
Oui, tout à fait ... mais si tu poses la question .... c'est que je sens qu'il y a anguille sous roche ...
4  Forum 2005-2010 (read only) / Français / Re: Re-Upload nécessaire après quelques semaines on: March 15, 2010, 01:55:10 pm
Oui, effectivement, ça marche sans le régulateur externe ... mais comme le circuit est en tension 24h/24 et que je trouvais que le régulateur intégré était un peu chaud, j'ai préféré en mettre un externe plus gros qui dissipait bien mieux la chaleur. Je ne suis pas convaincu de la nécessité, mais bon ... ça me rassurait smiley-wink
5  Forum 2005-2010 (read only) / Français / Re: Re-Upload nécessaire après quelques semaines on: February 23, 2010, 12:44:00 pm
Merci pour ta réponse ... Il est plus que probable que ce soit ce qui m'arrive. Hier soir, j'ai remis le système en place, il a bien fonctionné quelque temps et en allant me coucher j'ai eu droit à du 'Disco Inferno' ... ma rampe de led flashait par intermittence ...  ;D

Pourrais-tu me préciser à quel PDF tu fais référence dans ton post? J'ai bien trouvé dans le fichier hardware/boards.txt des références vers les valeurs de low fuse, high fuse et extended fuse ... il suffit que je les change là et que je reflashe mon programme ?

J'utilise pour le moment un arduino pro mini 5v (Atmega 328) ... J'utilise comme board type "Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328" mais c'est peut-être là qu'est mon erreur aussi ... Vu qu'il n'y a pas de preset arduino pro 5v ...

D'un point de vue plus hardware, j'ai un transfo 9v et j'ai mis un régulateur externe à l'arduino pour obtenir du 5V, j'avoue ne pas trop comprendre comment il peut passer à un voltage si bas ... mais bon, je ne suis qu'un débutant en électronique aussi, il reste encore beaucoup de choses qui m'échappe  smiley-razz ...
 
-Gil-
6  Forum 2005-2010 (read only) / Français / Re-Upload nécessaire après quelques semaines on: February 22, 2010, 04:53:36 pm
Bonjour à tous,

Je viens d'avoir un problème que je n'explique pas vraiment. J'ai un petit montage basé sur un arduino pro qui est installé dans ma cage d'escalier depuis maintenant plusieurs semaines. J'utilise un détecteur PIR qui, grâce à l'arduino fait varier doucement une rampe de leds vers un certain niveau lumineux, reste allumé tant qu'il y a du mouvement et s'éteint lentement après quelques secondes.

Le tout fonctionnait sans aucun soucis depuis plus d'un mois et là ... plus rien ... j'ai debranché et rebranché le transfo quelques fois, toujours rien, l'arduino était bien sous tension (led allumée), mais pas de réaction sur ma rampe de led qui est sensée faire un fade au démarrage ...
J'ai vérifié les connexions, pas de problème ... j'ai ensuite rebranché l'arduino seul sur mon pc pour vérifier qu'il fonctionnait toujours, j'ai re-uploadé mon programme et tout semblait fonctionner ... j'ai tout remonté et c'était reparti ...

Est-il possible que le software se retrouve corrompu à un moment donné ?  

J'avoue être assez perplexe vis-à-vis de ce problème ... je comptais à terme rendre le montage bien moins inaccessible, mais là, du coup  :-?

Merci d'avance,

-Gil-
7  Forum 2005-2010 (read only) / Français / Re: Comment fonctionne Xbee shield ? on: July 20, 2009, 01:37:51 am
Pour ce qui est de programmer l'Arduino à travers un Xbee, il semble que cela soit possible, j'avais mis de côté ce lien sans avoir eu l'occasion de l'essayer personnellement, mais vu la source, je pense qu'on peut leur faire confiance.

C'est ici : http://www.sparkfun.com/commerce/tutorial_info.php?tutorials_id=122

8  Forum 2005-2010 (read only) / Français / Re: Projet domotique on: July 19, 2009, 04:51:06 am
Merci pour tes lumières sur le problème ... Voilà bien la preuve que j'ai encore du progrès à faire  ;D, Je pensais naivement que la résistance la plus faible l'emportait.

Si ce que j'ai trouvé sur le net est bien correct :
La résistance totale de 2 résistances en série est bien R=R1+R2
La résistance totale de 2 résistances en parallèle R=R1R2/(R1+R2)

La solution que tu proposes peut rapidement devenir prise de tête au dela de 2 ou 3 boutons. Mais bon, comme je le disais, dans mon cas, je n'ai pas besoin de gérer les pressions multiples, donc ... je vais rester sur la solution la plus simple.

Encore merci!
9  Forum 2005-2010 (read only) / Français / Re: Projet domotique on: July 18, 2009, 03:48:05 pm
Effectivement, la résitance la plus faible passera et le reste sera ignoré. Mais vu que dans ce projet il s'agit de boutons qui vont sélectionner une configuration ou allumer/éteindre des lampes, ce n'est pas vraiment une contrainte.

Une autre solution pour brancher plusieurs boutons ou capteurs sur un nombre réduit d'entrées consite à utiliser un multiplexeur : par ex http://www.arduino.cc/playground/Learning/4051 ou encore http://www.arduino.cc/playground/Code/MUX151, mais c'est tout de suite plus complexe.
10  Forum 2005-2010 (read only) / Français / Re: Projet domotique on: July 18, 2009, 01:56:02 pm
Merci pour la remarque ... J'ai retourné les options dans tous les sens, mais je n'ai pas trouvé. Je ne pense pas que ce soit possible avec Tumblr. Le sens de lecture est le sens 'normal' pour qui suit le blog régulièrement, mais effectivement, lorsqu'on débarque pour la première fois, ce n'est pas idéal.

J'ai quand même trouvé une 'astuce'  8-) : sur la page principale il y a un lien vers le RSS feed ... Une fois dans le RSS feed, il y a moyen de choisir de trier par dates récentes vers plus anciennes ou le contraire en cliquant une ou deux fois sur Date sur la droite de la page.

Gil.
11  Forum 2005-2010 (read only) / Français / Projet domotique on: July 18, 2009, 11:01:27 am
Bonjour à tous,

Je viens de me lancer dans un projet domotique (au sens large) basé sur des Arduino. Dans un premier temps, je voudrais contrôler un switch DVI ainsi que mon ampli (Onkyo TX-SR705) qui a une connexion RS232. Par la suite, je compte m'attaquer au contrôle de l'éclairage de ma maison (entre autre). Si ce genre de projet vous intéresse, je vous invite à aller sur mon blog http://domoduino.tumblr.com.

Il s'agit de mon premier projet réel Arduino ainsi que mon premier blog ... soyez indulgents smiley-wink. J'ai déjà et je vais certainement rencontrer des problèmes assez courants, j'espère que le développement de mon projet servira à d'autres. J'avoue que je n'ai pas de bases solides en électronique (loin de là) mais je suis programmeur-analyste de métier, ça compense (dans une certaine mesure  :smiley ).

N'hésitez pas à laisser un petit message et/ou des questions si le projet vous branche.

++

Gil.
12  Forum 2005-2010 (read only) / Français / Re: Problème avec PCF8574 on: November 14, 2009, 04:38:59 pm
Re bonjour à tous,

Finalement, j'ai résolu mon problème ... en le contournant. Je donne toujours la solution que j'ai utilisé, si d'autres se retrouvent dans le même cas ...

J'utilisais un relais parce que je devais allumer ou éteindre la backlight de mon lcd qui pompe quand même 500ma ... Suivant les conseils de mon revendeur éléctronique, j'ai acheté un Mosfet IRLZ34N qui prend du 5v en entrée et permet de commuter des circuits jusqu'à 30A/55V ... Largement plus que mes besoins, mais ça marche, et en plus j'évite le cliquetis du relais en prime ... parfait quoi ... et évidemment, le problème que j'ai décris précédemment à disparu.

++
13  Forum 2005-2010 (read only) / Français / Problème avec PCF8574 on: November 12, 2009, 01:15:41 am
Bonjour à tous,

Afin d'augmenter le nombre d'IO sur mon projet, j'ai utilisé des PCF8574. Sur le principe, ça marche super bien, j'en utilise un en entrée, il fonctionne impec et j'en utilise un autre en sortie, et la, j'ai un soucis.

Lorsque je l'utilise pour controller des optocoupleurs, ça fonctionne sans problème, j'ai quand même du mettre un transistor vu le faible niveau de ses sorties (voici le schéma du montage que j'ai utilisé ... tiré de http://automatepc.fr/?page=I2cPcf8574)

J'ai tenté de controller un relais 6v avec ce montage, sans succès ... j'ai donc tenté le montage suivant (toujours tiré de la même page)


... C'est beaucoup mieux, mais de temps à autres, j'ai un comportement bizarre ... le relais s'enclenche, relache tout de suite et toutes les portes du pcf8574 passent à l'état haut ... Mais ce n'est pas systématique, ça marche 10 à 15 fois, puis problème ... puis ça refonctionne, puis problème, ce n'est pas du tout régulier ...

A noter que j'ai remplacé le +12V par un +5V qui était largement suffisant.

Quelqu'un aurait-il une piste ??? Je sèche un peu ...

Merci d'avance ...
14  Forum 2005-2010 (read only) / Français / Re: Switch case et inertevalles on: October 28, 2009, 03:43:39 am
Bonjour,

Le switch-case ne fonctionne qu'avec un ensemble de valeurs définies, il n'est pas possible d'avoir un test dans le case.

Pour faire des tests d'intervalles, il faut utiliser des if - else if ...

Pour reprendre ton example :

soit une variable var qui peut varier de 100 à 1200
si var compris entre 100 et 200 =>action1
si var compris entre 201 et 500 =>action2
si var compris entre 501 et 1200 =>action3

Code:
if (var>=100)
{
   if (var<=200)
   {
       // action 1
   }
   else if (var<=500)
   {
      // action 2
   }
   else if (var<=1200)
   {
      // action 3
   }
}

Il y a d'autres façons d'ordonner les tests, mais celui-ci à comme avantage de ne faire chaque test qu'une fois.

++
15  Forum 2005-2010 (read only) / Français / Re: Contrôle d'un portail (détection position) on: October 19, 2009, 01:53:49 pm
Bonjour,

Il y a aussi des "Bend sensor" qui sont des résistances variant en fonction de la pliure. Ce n'est sans doute pas l'idéal pour placer en extérieur, mais j'imagine qu'il est possible de les protéger avec de la toile isolante ou entourer de silicone …

Voici une réf : http://www.eztronics.nl/webshop/catalog/product_info.php/cPath/33/products_id/180

Il existe beaucoup de modèles différents et ce magasin n'est pas des meilleurs marché, mais je savais qu'ils en vendait, donc ...  smiley-razz

-Gil-
Pages: [1] 2 3