Show Posts
Pages: [1] 2
1  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 02:32:16 pm
l'out di Arduino sul fotoaccoppiatore, è fatto così:

2  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 10:39:37 am
scusami, allora non ho capito, che intendi per LED IR?
3  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 09:39:17 am
kappa che c'è, da 10K
4  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 09:22:21 am
Grazie Uwe,
non ho capito bene il perchè ora funziona, ma visto che è ok, non tocco niente e vado avanti con il resto.

Grazie ancora
Claudio
5  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 09:02:16 am
no, un fotoaccoppiatore.
comunque così ha funzionato

Quote
6
LOW1
5
LOW1
4
LOW1
5
LOW1
4
LOW1
4
LOW1
5
LOW1
4
LOW1
4
LOW1
6
LOW1
3
LOW1
4
LOW1
3
LOW1
3
LOW1
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
3
LOW1
Aspetta
LOW2
4
LOW1
4
LOW1
3
LOW1
5
LOW1
4
LOW1
4
LOW1
4
LOW1
4


6  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 08:48:24 am
Grazie per il tuo intervento Nagy, e stai tranquillo che pure io sono decisamente nabbo.
Vista la mia attività lavorativa, ho approcciato Arduino a scopo di hobby pensando di fare una passeggiata, ma non mi ero accorto di essere "Scalzo sui vetri"...

L'idea può essere sicuramente buona, tuttavia mi pare di capire che il problema stà nel fatto che non vuole saperne di fare quell'IF con l'AND tra il valore analogico e quello digitale, sia scritto come (&&) che come due IF in cascata.
Risolto questo dovrò capire come contare il tempo senza piantare il programma con il DELAY, ma per quello la tua può essere già la soluzione. Tuttavia avevo già sperimentato la libreria METRO con successo.
7  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 08:42:46 am
nel finale del codice mi dava errore, ho quindi scritto:
Code:
  if (digitalRead(cmd_tx))    //se il valore analogico è < di 50, e cmd_tx è a 1
    { 
    Serial.println("Aspetta"); 
        delay(3000);                                                     //attendo 3 secondi
        digitalWrite(cmd_tx, LOW);
    Serial.println("LOW2");                                        //scrivo a zero cmd_tx
}}
delay(100);
}

comunque:

Code:
(cut)
4
LOW1
5
LOW1
4
LOW1
4
LOW1
1023  //porto analogico 3 a livello alto
HIGH
1023
HIGH
1023
HIGH

taglio per non rubare troppo spazio

1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
4          //porto analogico 3 a livello basso...
LOW1
2
LOW1
3
LOW1
4
LOW1
5
LOW1
4
LOW1
4
LOW1
4
LOW1
....etc etc etc... fino a reset



8  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 08:12:13 am
Code:
5
5
3
5
4
5
4
4
4
5
3
4
4
4
4
6
4
4
4
4
5
4
4
5
4
4
4
1023     //qui ho alzato l'input analogico
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH
1023
HIGH                //qui ho portato al valore basso l'input analogico...
4
5
4
5
4
5
4
4
4
3
5
4
3
4
5
4
3
5
3
5
7
4
5
5
7
4
6
4
4
4
4
3
4
4
5
3
4
4
4
5
3
4
5
4
3
3
6
4
2
4
4
7
4
4
4
4
4
2
6
6
4
3
4
4
4
5
6
5
4
4
4
1
3
4
4
4
4
3
4
4
4
3
3
4
3
6
3
2
4
3
4
4
dopo circa una decina di secondi, non vedendo cambiamenti di stato ho interrotto premendo il tast reset
9  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 07:15:09 am
eccolo:
Code:
int cmd_tx = 5;
int analogPin = 3;
int rx_val = 0;


void setup()
{
  pinMode(cmd_tx, OUTPUT);

}

void loop()
{
    rx_val = analogRead(analogPin);
   
   
    if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); } //se il valore analogico è > di 50, metto a 1 l'output cmd_tx
    if ((rx_val < 50) && digitalRead(cmd_tx) == HIGH) {  //se il valore analogico è < di 50, e cmd_tx è a 1
        delay(3000);                                                     //attendo 3 secondi
        digitalWrite(cmd_tx, LOW);                                //scrivo a zero cmd_tx
}

}


10  International / Software / Re: "IF" tra segnale analogico e digitale on: July 24, 2012, 06:35:58 am
grazie per l'intervento Uwefed, purtroppo il risultato non cambia...

anche così se porto l'ingresso analogico a +4,9V (circa 1003 in digitale) cmd_tx va regolarmente HIGH perchè supero 50.
Quando porto il segnale analogico al livello basso di 32mV (circa 8 in digitale) cmd_tx rimane in HIGH, sia con il delay che senza.

Ovviamente ho provato a cambiare l'ingresso analogico, nel dubbio che fosse brasato...

Se invece scrivo:
Code:

     if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); } //se il valore analogico è > di 50, metto a 1 l'output cmd_tx
     if (rx_val < 50) {  //se il valore analogico è < di 50, e cmd_tx è a 1
        digitalWrite(cmd_tx, LOW);                                //scrivo a zero cmd_tx
}
funziona perfettamente, quando alzo Ax cmd_tx va in HIGH, quando abbasso Ax, cmd_tx va LOW.
Se però aggiungo un delay:

Code:
    if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); } //se il valore analogico è > di 50, metto a 1 l'output cmd_tx
     if (rx_val < 50) {  //se il valore analogico è < di 50, e cmd_tx è a 1
        delay(3000);                               //attendo 3 secondi
        digitalWrite(cmd_tx, LOW);                                //scrivo a zero cmd_tx
}
quando alzo Ax per poco circa un secondo non succede nulla, se lo tengo alto per 3 secondi cmd_tx va HIGH, per poi tornare LOW dopo 3 secondi come da istruzione quando Ax torna sotto il livello. E' come se avessi il delay anche sulla prima istruzione.

...non so, sembra proprio che voglia fare cioè che vuole lui, e non quello che voglio io  smiley-sad
11  International / Software / Re: "IF" tra segnale analogico e digitale on: July 23, 2012, 05:51:09 pm
per il cw ho già tutto il codice pronto e funzionante se ti serve. Non lo inserisco qui per non creare confusione con il topic.
Ciao, a presto.
12  International / Software / Re: "IF" tra segnale analogico e digitale on: July 23, 2012, 05:44:02 pm
http://arduino.cc/en/Reference/else

prova questo tipo di codice, e occhio cosa applichi, massimo 5 volt e massimo 40mA, e cmq hai un errore di quantizzazione non indifferente la precisione e di 10 bit... cosa stai facendo di bello li in zona 1?

ciao Pietro,
l'ingresso analogico lavora tra zero (circa) e 800mV, quindi in digitale con 50 sono assolutamente sia sopra che sotto la soglia.

comunque trattasi del core di un repeater che devo andare a rimettere su mercoledì, e devo ancora sistemare la coda e il secondo identificativo in cw.
Solo che le cose te le dicono come al solito a pezzi, ed ora sono un pò stretto con i tempi  smiley-red
13  International / Software / Re: "IF" tra segnale analogico e digitale on: July 23, 2012, 05:40:48 pm
Ciao

Apparentemente le righe dovrebbero fare quello che ti aspetti, le info che fornisci sono insufficienti per un aiuto mirato.
Mi sorge il dubbio che non ci vai mai sotto il 50, ed è difficile arrivarci (ad esempio) con un sensore tipo fotoresistore quando i valori analogici vanno da 0-1023.

Comunque se sostieni che la 1.0.1 ha un bug, mi aspetto che lo hai provato sulla 1.0 o versione inferiore con successo.
Non dici il sistema operativo che usi
sensore che usi
lo sketch copiato è un po' poco
lo schema che usi ? sicuro sia corretto?
Hai provato ad alzare le soglie?

Non hai modo di saperlo senza una visualizzazione a video. Devi far funzionare il serial monitor per osservare i valori restituiti dalla porta analog almeno come debug poi agisci di conseguenza

ciao

che sia un bug, l'ho letto sul forum...ma ora non ho il link sottomano, sembrerebbe l'interazione del serial monitor con java(?), e l'errore era lo stesso che appariva a me, tuttavia la soluzione era disponibile solo per linux. Purtroppo io uso xp.
Di certo, ho un gabinetto di netbook con a bordo la stessa versione 1.0.1, e li funziona senza problemi.
14  International / Software / Re: "IF" tra segnale analogico e digitale on: July 23, 2012, 05:38:04 pm
funziona perfettamente...

ho quindi aggiunto il delay:

Code:
 
if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); }
if (rx_val < 50) {
    delay(3000);
    digitalWrite(cmd_tx, LOW);
     }

e funziona anche così, tuttavia se immediatamente dopo che cmd_tx è passato in low, porto nuovamente rx_val > 50, cmd_tx per tornare high ci mette un pò....diciamo 3000ms
15  International / Software / "IF" tra segnale analogico e digitale on: July 23, 2012, 05:19:47 pm
Ciao a tutti,
come dicevo nel topic di presentazione, sono Claudio e vivo in provincia di Cuneo. Sono approdato qui perchè ormai sono allo stremo delle forze.

Devo comandare un'uscita digitale, leggendo un segnale analogico.
Quando il segnale analogico torna sotto la soglia stabilita, deve spegnere l'uscita con un breve delay.
Per complicare tutto, su questo pc non riesco a far girare il "Monitor seriale"...sembrerebbe che ci sia un bug nella versione 1.0.1 con java che bho... insomma se apro il monito seriale, si pianta tutto.

Comunque, le due strade intraprese senza successo sono:

Code:

 if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); }  //se il valore analogico è > di 50, metto a 1 l'output cmd_tx
 if (rx_val < 50) {                                            // se il valore analogico è < di 50
              if (cmd_tx == HIGH) {                        // e se cmd_tx è a 1
                  delay(3000);                                // attendo 3 secondi
                  digitalWrite(cmd_tx, LOW);           // e scrivo a zero cmd_tx
                  }
  }


l'altra strada provata è:

Code:

     if (rx_val > 50) { digitalWrite(cmd_tx, HIGH); } //se il valore analogico è > di 50, metto a 1 l'output cmd_tx
     if ((rx_val < 50) && digitalRead(cmd_tx) == HIGH) {  //se il valore analogico è < di 50, e cmd_tx è a 1
        delay(3000);                                                     //attendo 3 secondi
        digitalWrite(cmd_tx, LOW);                                //scrivo a zero cmd_tx
}
in entrambi i casi, quando rx_val supera 50, l'out cmd_tx va a 1, senza tornare però mai a zero quando rx_val scende sotto 50.
Dove stò sbagliando?

Grazie
Claudio
Pages: [1] 2