Show Posts
Pages: 1 ... 3 4 [5] 6 7 ... 9
61  International / Software / Re: Domanda su Pachube/Cosm on: September 03, 2012, 03:52:00 am
Buongiorno Massimo.
Questa sera ho intenzione di montare un partitore di 1.28V (1 x tutte e 3 le sonde) sul mille fori. Prendendo l’alimentazione die 5V di Arduino.

Settare L’Aref interno dell’arduino a 2.56V.

Dopodiche prendero una lampadina da 100w come referenza e cominceró a costruire il tutto da questo punto.

1,28V equivalgono a circa 26A (Valore che non raggiungeró mai a casa mia), penso che possa bastare, in compenso avró una risoluzione minima di 2.5 mV.

Dimmi se ho scritto una grande cavolata  smiley-eek

Saluti e buon inizio di giornata.
Remo
62  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 01:07:36 pm
No way :-(

situazione invariata....

Caro Massimo non voglio approfittare della tua disponibilità !!

Ti ringrazio tantissimo.

Domani riprendero in considerazione il fatto del partitore che setta lo "0" a 1.65V e da li l'onda del sensore potrà oscillare in tutta tranquillità fra + e -.
Bisognerà solo poter captare il max e min delle sinus.
Lo avevo già in funzione ma mi mancava lo sketch esatto, o meglio detto la formula esatta.

Dai godiamoci questa Inter-Roma....da domani ricontrollerò e riproverò .

Grazie Massimo e buona serata

Remo
63  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 12:39:02 pm
Con i trimmer nn cè possibilità di regolare l'offset.

Alla fine mi sono accorto che l'offset è dato dalla tolleranza dell'oscilloscopio !!!

Nn riesco a spiegarmi perche, se scelgo una scala da 2 V l'offset mi viene mostrato a -80 mV
Se scelgo 1 Volt viene mostrato -40 mV
Se scelgo 200mv viene mostrato -4 mV di offset.....

percio nn ha a che vedere con l'arduino.....

Scusami...tolgo i trimmer e rimetto i + degli Opam a massa....

Ciao

Remo
64  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 11:42:04 am
Ah ci sono arrivato da solo...
Intendi sul + di ogni amplificatore...
Sai che faccio? Ci metto un trimmer da 100 k e cerco di regolare lo 0 perfetto

Saluti
Remo
65  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 11:01:16 am
Scusa Massimo,
Nn ho capito dove di preciso collegare la resistenza da 78 kohm..

Saluti
Remo
66  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 05:49:44 am
ok, collegato un attimo.
Aref collegato sul pin 5 V

Wattcher = 800watt

Arduino = 0 :-(

Riprovero al pomeriggio

Saluti

Remo
67  International / Software / Re: Domanda su Pachube/Cosm on: September 02, 2012, 02:01:32 am
Buongiorno Massimo,
ecco i risultati dopo la Modifica con un resistore da 360KOhm.

Al massimo, con una entrata di 1.41Vp, all'uscita ho un valore Vpmin di -80mV
Al minimo, con una entrata di 110mVp, all,uscita ho un valore Vpmin di -8mV

Allegate le foto delle misure effettuate con l'oscilloscopio.

P.S. il valore dei 5Volt è tarato, ma nell'oscilloscopio salta fra 4.96 e 5.04.


Ulteriore domanda, ho bisogno ancora dell'Aref External ?
Se l'arduino di Default usa gia il range 5 volt ?

Le prove con Arduino potro farle al pomeriggio....



Saluti
Remo
68  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 02:48:40 pm
Posseggo 3 sensori identici
Sct013-030 con uscita in tensione 1v

Domanda...i 3 aref che dovrei tarare per le 3 sonde....alla fine solo una la colleghero sull aref giusto?

Saluti Remo
69  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 01:54:31 pm
Il resistore da 32 KOhm devo a questo punto inserirlo ?
Se mi dici che  è interno All'Arduino.....

Cmq il circuito è finito, faccio il cambio dei resistori, ma la taratura la faró domattina....

Grazie ancora e buona serata.

Remo
70  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 12:24:09 pm
Ciao Massimo,
vedo se in serata riesco a saldarlo.

Comunque per quanto riguarda la RL da 62 Ohm, non cè ne bisogno, il nostro sensore la ha incorporata questa resistenza.
a fondo pagina di questa specifica --> http://nicegear.co.nz/obj/pdf/SCT-013-datasheet.pdf

Solo per i sensori con uscita di corrente hanno bisogno di una resistenza di carico.

Vado a saldare e tarare....(senza la RL)

Grazie
Saluti

Remo
71  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 06:45:52 am
Caro Massimo,
ho tutta la pazienza,anzi mi sento pure in imbarazzo !!!

Remo
72  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 06:44:03 am
Aggiornamento : dimentica quello che ho detto riguardo la soglia di riconoscimento segnale. Ho notato or ora che la soglia di riconoscimento avviene dopo i primi 25 Step...in altre parole 0.0032*25 = 80 mVolt -->ca. 248 watt

Se puo aiutarti.....

saluti

Remo
73  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 06:37:19 am
Ciao Massimo,
io posseggo il secondo sensore SCT013-030 appunto col resistore interno da 62 Ohm.

Per quanto riguarda lo schema di cui ti parlavo, non era altro che un consiglio di Uwe che misi in Atto.

2 resistenze ed una uscita da 1.65V che dava l'offset al sensore.

In questo modo lo "0" era impostato a 1.65V e si puo misurare un'intera Sinusoide.

Io invece sto pensando se è possibile combinare questo Offset di 1.65V con un'amplificazione del segnale.

Comunque con la vecchia opzione (partitore) facendo un normale analog read vedevo i valori oscillare sopra e sotto i 512(1.65V) cio a significare che qualcosa arrivava.

Saluti
Remo
74  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 03:19:09 am
Per informazione,
ecco come sono collegati i sensori nel Tableau.
Le estremità dei cavi erano collegati a dei miniJack 3.5mm, li ho dovuti tagliare non avendo la femmina.

I cavetti del sensore a questo punto sono collegati a una specie di morsettiera.

Saluti

Remo
75  International / Software / Re: Domanda su Pachube/Cosm on: September 01, 2012, 02:11:29 am
Riciao,
dopo quanto scritto sopra, sono tornato in ditta a rileggere i valori della taratura (ho dimenticato il cell e non ho potuto fare una foto).

Ho comunque notato (non so l'espressione in italiano) che come valore Max dell' uscita mi segnava 3.28V e come valore minimo -40 mV.

Vale a dire che dovrei compensare quei 40mV nello sketch ? Tradotto in step ca. 13 per sonda ?

Confermo inoltre che L'arduino comincia a rilevare segnali dai 1200W in poi (sempre con il benedetto wattcher come referenza).

Al pomeriggio prendero l'oscilloscopio e mi collego direttamente sulle Entrate A0/1/2, sapro sicuramente molto di più.

Intanto grazie per l'aiuto, in qualche modo dovro sdebitarmi !!

Saluti

Remo
Pages: 1 ... 3 4 [5] 6 7 ... 9