Show Posts
Pages: [1] 2
1  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 11:06:09 am
Merci pour les conseils !!
2  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 09:15:33 am
J'alimente l'Arduino via le Vin du Motor Shield. Et je ne lui mets pas plus que du 9V... je n'assassine personne... non.... ?
3  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 08:59:43 am
Merci pour la réponse !

Donc pour toi, je mets une alim pour le Arduino tout seul et une dans le Vin du MotorShield ?
4  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 08:01:48 am
ouai rusé  smiley-grin !

Mais j'aurai un peu l'impression de demander à mon robot de commencer à marcher les yeux fermés et de lui dire de les ouvrir une fois qu'il est bien lancé...

Les assoc de protection de robots vont me tomber dessus....!
5  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 07:52:36 am
précision: le bloc de piles alimente le tout via le Vin du Motor Shield (celui à visses).
6  International / Français / Re: Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 07:49:04 am
Voici les specs:

2 moteurs de ce type: http://www.dfrobot.com/index.php?route=product/product&path=47&product_id=100#.Ucg_9pz65zc

et pour l'alim ce sont 6 piles AA.

Merci pour le coup de main !
7  International / Français / Chute de tension aux pin qd demarrage moteurs on: June 24, 2013, 07:37:15 am
Hello tout le monde,

Le contexte: Un arduino uno + 1 moteur shield + 2 petits moteurs + un Ping + alimentation par Vin en 9V ( = robot detecteur d'obstacles ;-) )

Mon problème se situe au niveau de la tension dans les pins: dès que j'allume mes moteurs, la tension aux bornes des pins baisse et mon Ping du coup me donne une distance tronquée. Bilan, des q mon robot démarre, il a déjà l'impression d'etre dans le mur...

Une fois que les moteurs sont lancés, là, pas de soucis tout se déroule normalement, c'est juste à l'allumage.

Avez-vous une idée/solution pour que mon robot est l'air moins stupide....?

Merci beaucoup !!!

8  International / Français / Re: conseil sur les Capteurs de distance on: June 18, 2013, 01:59:17 pm
Même en en mettant plusieurs car il me semble qu'en gros le capteur fait une "photo" de l'environnement a un temps T et la compare à une photo à un temps T+1. Et envoie 1 au pin si il y a eu une modif !

Pour le capteur infra, oui tu peux mais du coup faut effectuer une sorte de cadrillage en en mettant plusieurs !

Bon courage
9  International / Français / Re: conseil sur les Capteurs de distance on: June 18, 2013, 07:47:35 am
Je confirme ce qu'à écrit: Artouste.

Il te faut du openCV.

Le petit capteur que tu as trouvé (je l'ai testé) détecte si il y a du mouvement dans un rayon donné.

Il ne peut malheureusement te dire d'ou ca vient.
10  International / Français / Re: structure ou class question pratique? on: May 31, 2013, 05:01:02 am
Hello,

@skywodd, mais un tableau de Classe devra être défini en global dans ton code, non ?

Tandis que le tableau de pointeur de Classe sera déclaré dans la fonction de setup.

Après, je ne sais pas si ca change grand chose en mémoire très concretement...

11  International / Français / Re: structure ou class question pratique? on: May 30, 2013, 05:15:54 am
Tu n'auras pas vraiment à faire:

Code:
terra1.recuper_temperature();
terra2.recuper_temperature();
terra"n".recuper_temperature();

Car tu feras un tableau de poiteurs de classes avec un code du type
Code:
for (...)
  terra[i]->recup_temp()

Les pro pourront confirmer ? ;-)
12  International / Français / Re: Interface ARDUINO - page Web on: March 19, 2013, 12:01:23 pm
Le plus simple serait, si tu en as la possibilité, d'heberger un serveur websocket.

les +: Tu maitrises à fond tout le protocole de bout en bout
        Tu es en temps réel
        Ca se programme facile (php/JS)

les -: ca oblige une machine a rester allumée
13  International / Français / [GPRS] deco/reco on: February 25, 2013, 09:33:18 am
Hello,

J'ai monté mon GPRS shield sur mon Arduino.
Le Arduino discute tranquillement avec mon server via le GPRS, ca c'est OK.

Maintenant, lorsque je simule une perte de réseau, le shield se reconnect au réseau mais n'arrive plus à obtenir d'IP

Je pense q la perte subite du réseau laisse mon GRPS shield un peu à l'ouest et comprend pas trop ce qu'il se passe autour de lui...

Du coup je pensais mettre en place une vrai déconnexion propre dès la perte de réseau.

Mon problème c'est q je ne trouve pas les commandes pour.
La commande AT CLOSE ferme le truc à moitié et ne me permet pas de me reconnecter. Pour le moment, je suis contraint d'appuyer sur le bouton d'alim du GPRS Shield.

Merci de votre aide.

14  International / Français / Re: Passerelle GSM on: December 18, 2012, 07:19:45 am
Honnetement, le wiki seeedstudio est vraiment au top:

http://www.seeedstudio.com/wiki/GPRS_Shield_V1.0

en bas de la page tu trouveras en plus le pdf des commandes AT qui sont vraiment très claires !
15  Using Arduino / Networking, Protocols, and Devices / Re: Cannot send SMS with SIM900 on: December 07, 2012, 08:24:58 am
Could you test with the function written into the wiki:

Code:
void SendTextMessage()
{
  mySerial.print("AT+CMGF=1\r");    //Because we want to send the SMS in text mode
  delay(100);
  mySerial.println("AT + CMGS = \"+86138xxxxx615\"");//send sms message, be careful need to add a country code before the cellphone number
  delay(100);
  mySerial.println("A test message!");//the content of the message
  delay(100);
  mySerial.println((char)26);//the ASCII code of the ctrl+z is 26
  delay(100);
  mySerial.println();
}
Pages: [1] 2