Show Posts
Pages: [1]
1  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 05, 2012, 03:55:24 am
Exacto, un lapsus smiley-razz.

Muchas gracias por la ayuda ADLC

Saludosss
2  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 04, 2012, 06:26:42 pm
mira, acabo de ver un nema 17 y en las especificaciones pone:

Voltage:                          12V

Current:                          0.4 A/phase

Resistance:                   30 Ohm/phase

Con esas especificaciones en teoria podria darle los 12 voltios y el consumo serian 0,4A segun la ley de ohm smiley-lol, de esta manera el l293b en teoria no deberia calentarse ya que segun parece aguanta hasta 1A
 (corrigeme si me equivoco, --que sera lo mas probable XDD--)

Gracias de antemano

Saludoss
3  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 04, 2012, 05:08:07 pm
ya jaja pero como dije aun me quedan 3 l239b y me gustaria aprovecharlos smiley-razz
4  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 04, 2012, 04:32:34 pm
Hola

Vale realizé la comprobación que me recomendaste, medi la tension conectando el motor a 7V y me dio 1,65A si le aplico la ley de ohm me salen los 4 ohmnios por bobina. Y conectandole 13V mas o menos sale 4,1A. aplicando la ley de ohm

¿Esto quiere decir que poniendole 7V y 13V ya estoy haciendo que pasen 1,65A y 4,1A por el L293 no?

¿tambien es malo para el motor que este deba consumir esas cantidades de amperios no?

Si es ese el caso, este motor parece que no es valido para el l293b segun parece.

¿Sabriais algun motor paso a paso que pudiese funcionar con el l293b de una manera eficiente?
¿o hay alguna manera de que me pueda funcionar el motor que tengo con un l293b de una manera correcta?

Basicamente necesito unos motores para una CNC y en muchos videos y tutoriales que he visto usan este chip.


Gracias de nuevo

Saludoss
5  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 04, 2012, 11:20:33 am
Hola,

acabo de comprobar las resistencias de las bobinas con un multimetro (un borne en cada cable de la bobina, creo q es asi T_T) y me da 5,4 ohmnios.

Lo de que solo puedo alimentar el motor con 1,5v supongo que has aplicado la ley de ohm con 0,4A y 3,9 omhnios, pero en las mismas especificaciones pone que puede usar 12 voltios (me estoi armando un cacao impresionante lo siento T_T)

He mirado otro motor por internet el NEMA 17:

Current    1.5 A
Resistance:    2.8 Ohm

si le aplico la ley de ohm me sale que solo lo puedo alimentar con 4,2v

Lo siento si parece que soy medio analfabeto en esto, solo intento comprender como los videos que veo la gente tiene el l293b con una fuente externa de 12v y que le funcione perfectamente.

Saludoss

Graciassss
6  International / Hardware / Re: problemas con driber L293B y motor paso a paso on: October 04, 2012, 09:13:26 am
Hola, gracias por contestar tan rapidamente, aqui te muestro el esquemático que he seguido:



como puedes ver en el pin 16 conecto los 5v del arduino y el en pin 8 los 12v de la fuente atx, y todas las masas a masa del arduino.

En lo referente a las resistencias de las bobinas, aqui tienes lo que me pone el datasheet del motor(aqui tienes el enlace al datasheet por si te sirve de ayuda DATASHEET:

Coil DC Resistance 5Ω/phase±7%

aunque en la etiqueta del motor me pone esto otro:



En el tema de cambiar de driver, por ahora aun me quedan 3 l329b para "fundir" ya que los compre para hacer los drivers de 3 motores para una CNC.

Gracias de nuevo.

Saludosss!!
7  International / Hardware / problemas con driver L293B y motor paso a paso on: October 04, 2012, 07:18:27 am
Hola.

Bueno, soy algo (bastante) nuevo en esto smiley-lol, estoy intentando hacer funcionar correctamente un motor paso a paso mediante un driver l293b.

El motor que estoy utilizando es el siguiente:

MITSUMI M42SP-6NK
Rated Voltage             DC 12V DC 24V
Working Voltage          DC 10.8~13.2V DC 21.6~26.4V
Rated Current/Phase    400mA(PEAK)

La cuestion esque lo he montando todo poniendole 5v en el pin 16 (desde el arduino). Bien pues solo asi el motor ya empezó a girar, sin ponerle nada en el pin 8 que se supone que es la alimentacion de los motores (o eso tengo yo entendido, estoy muy verde jaja). El problema de esto esque el motor casi no tenia fuerza y entonces decidí ponerla la alimentacion de 12v de una fuente ATX de un ordenador viejo. Puse la masa de la uente a la masa del arduino y los 12V los puse por el pin 8 del l293b. Llegados a este punto salio algo de humo del l293b y lo desconecte enseguida, el driver siguio funcionando algo despues de eso con los 5v del pin 16 pero al final murió XDD.

Yo supongo que es algun problema con la intensidad porque el motor pone que funciona con 12v, ademas comprobe con un multimetro que la funte sacaba 12v.

Las conexiones las he revisado 1000 veces y creo que estan bien.

Si alguien sabe como hacerlo funcionar con una fuente de alimentacion externa (si pude ser de pc) por favor si puede que lo comente estoy muy interesado en hacerlo funcionar correctamente.

PD: he visto montajes de motores PaP con este driver y fuentes ATX y parece que funcionan perfectamente, no se donde puedo tener el error.

Gracias de antemano.

Saludos
Pages: [1]