Show Posts
Pages: [1]
1  Using Arduino / Displays / Re: glcd from dx.com on: April 11, 2013, 12:24:57 am
I live on a Island called Mayotte where a pot. is hard to find ! ;-)
The post service are very slow (approx. 3 month to get my glcd from dx after shipping)

I've tried to connect the contrast to 0, 3.3V, 5V and differents values that I made with some resistances.
I can assure you the at 3.3V and 5V the contrast is very high.

I realy think that my problem is not here... :-(
Thanks.
2  Using Arduino / Displays / Re: glcd from dx.com on: April 10, 2013, 11:30:35 pm
Thanks for help,

I've tried this :
Code:
for (int brightness = 0; brightness < 255; brightness++) {
      analogWrite(3, brightness);
      delay(3);
}
So I can see all values for the contrast. It works well.

BUT I don't see the "Helloworld" :-(

Is the call of the u8glib ok ? I have tried those :
Code:
U8GLIB_ST7920_128X64_1X u8g(52, 51, 53);
//OR
U8GLIB_ST7920_128X64_4X u8g(52, 51, 53);
I don't understand the difference but with both of them my glcd don't want to say hello...

Am I right with the 52, 51, 53 pins ?

Thanks
3  Using Arduino / Displays / glcd from dx.com on: April 10, 2013, 01:15:03 pm
Hi,

I've bought this glcd : http://dx.com/p/5v-3-2-lcd12864-screen-module-with-backlit-yellow-green-screen-english-word-stock-121820
It's very hard to find what kind of hardware it is...
On this site you can see the pins. (http://skyduino.wordpress.com/2012/05/25/arduino-ecran-lcd12864-dealextreme-pas-chere-et-puissant/)

I'm using a arduino Mega 2530.

My hardware connexion is :
1 -> gnd
2 -> 5V
3 -> ~3V
4 -> pin 53 (CS)
5 -> pin 51 (MOSI)
6 -> pin 52 (SCLK)
15 -> Gnd (for SPI mode)
19 -> 3.3V (Backlight anode)
20 -> gnd (Backlight cathode)

I've tried the helloworld example from the u8glib :

Code:
#include "U8glib.h"
U8GLIB_ST7920_128X64_4X u8g(52, 51, 53);

void draw(void) {
  // graphic commands to redraw the complete screen should be placed here 
  u8g.setFont(u8g_font_unifont);
  //u8g.setFont(u8g_font_osb21);
  u8g.drawStr( 0, 22, "Hello World!");
}

void setup(void) {
 
  // flip screen, if required
  // u8g.setRot180();
 
  // set SPI backup if required
  //u8g.setHardwareBackup(u8g_backup_avr_spi);

  // assign default color value
  if ( u8g.getMode() == U8G_MODE_R3G3B2 )
    u8g.setColorIndex(255);     // white
  else if ( u8g.getMode() == U8G_MODE_GRAY2BIT )
    u8g.setColorIndex(3);         // max intensity
  else if ( u8g.getMode() == U8G_MODE_BW )
    u8g.setColorIndex(1);         // pixel on
}

void loop(void) {
  // picture loop
  u8g.firstPage(); 
  do {
    draw();
  } while( u8g.nextPage() );
 
  // rebuild the picture after some delay
  delay(500);
}

The backlght led shines correctly but there is no "helloworld"...
Does someone know what's wrong ?

Thanks for help
4  Products / Arduino Due / max digital read speed ? on: February 23, 2013, 08:04:05 am
Hello,

I would like to connect a parallel ADC to an arduino due. (http://fr.farnell.com/analog-devices/ad9235bruz-40/12bit-adc-40msps-dual-smd-tssop28/dp/1438560)

What's the maximun reed speed I can expect ? I would like to save the value in the RAM.

Thanks for help
5  Products / Arduino Due / ADC speed on: February 04, 2013, 11:39:13 pm
Hello,

I would like to buy an arduino due to make a little oscilloscope. I read that the adc speed of the ┬ÁC is 1Mech/s.
Is it possible to have realy this speed on 2 channels ?

Thanks for help
6  Using Arduino / Motors, Mechanics, and Power / how use a step motor on: December 23, 2012, 06:54:26 pm
Hi,

I bought this motor : http://www.miniinthebox.com/fr/l-electronique-automobile-et-le-bricolage-5v-moteur-pas-a-pas-avec-chauffeur-uln2003_p340890.html
but I don't find informations to use this. Does someone know a tutorial for this ?
Thanks.
7  Using Arduino / Programming Questions / Soft MPide problem on: October 27, 2012, 02:15:44 pm
Hi,

I bought a CUI32STern card who is arduino compatible. I haven't received the card yet but I've installed MPide.
My problem is that any code return the same error when I verify it. (I took the examples code)

C:\Program Files (x86)\MPide\hardware\pic32\cores\pic32\HardwareSerial.cpp:670:60: error: Interrupt priority must be specified as 'single' or 'IPLn[AUTO|SOFT|SRS]', where n is in the range of 0..7, inclusive.
C:\Program Files (x86)\MPide\hardware\pic32\cores\pic32\HardwareSerial.cpp:698:60: error: Interrupt priority must be specified as 'single' or 'IPLn[AUTO|SOFT|SRS]', where n is in the range of 0..7, inclusive.

Does someone know what's my problem ?

Thanks
Pages: [1]