Show Posts
Pages: [1]
1  Products / Arduino Due / Re: MPU6050 library and Arduino Due on: March 24, 2013, 03:26:45 pm
There are two aspect you need to take into account:

1. Hardware compatibility (voltage level): here there is no problem. MPU6050 work with DUE. Just connect the VDD and VIO to 3.3V.
2. Software (CPU) compatibility. I had to copy this code: http://arduino.cc/forum/index.php/topic,129407.msg976225.html#msg976225 to MPU6050.h to get the library working with DUE.
2  Products / Arduino Due / Re: Arduino Due and Galaxy Nexus Problem with ADK on: November 25, 2012, 03:20:11 pm
Hi, read this. I have not been able to get further than what is described in the topic.

http://arduino.cc/forum/index.php/topic,129390.0.html
3  Products / Arduino Due / Re: Due pinout diagram on: November 16, 2012, 01:30:43 am
EDIT: Just created an SVG, it had two issues but I uploaded anyway. It looks like crap in a browser, can you guys try in a graphics program.

Looks great in Inkscape! Thanks for the good work.
4  Products / Arduino Due / Re: Due pinout diagram on: November 15, 2012, 04:12:21 pm
Would it be possible to export to SVG?

Another vote from my side.  smiley
5  Products / Arduino Due / Re: Arduino Due and ADK on: November 08, 2012, 01:41:34 am
I did some more testing and actually got it to work ... kind of smiley-sad

I have the Galaxy S (i9000) with the CyanogenMod 9 (Android version 4.0.4). The setup works if I power the Due over the USB connection and does not work, if I power it via the power jack. Is that by design?

However, the operation is inconsistent, sometimes the enumerates the devices and gets to adk.IsReady() == 1 and most of the time it does not. I've tried to printout the status of the usb_getUsbTaskState function and get different readouts (USB_STATE_RUNNING, USB_STATE_ERROR, USB_DETACHED_SUBSTATE_WAIT_FOR_DEVICE) when plugging the phone in and out.

Sometimes it even goes to USB_STATE_RUNNING and then straight to USB_DETACHED_SUBSTATE_WAIT_FOR_DEVICE. It could be a problem with the phone, since things get better (but not ideal) after the reboot of the phone. Unfortunately I don't have any other device to try it with.
6  Products / Arduino Due / Re: IDE 1.5.1 on: November 07, 2012, 02:09:10 am
Solved the problem on Win8 64 bit.
7  Products / Arduino Due / Re: Arduino Due and ADK on: November 07, 2012, 02:08:43 am
Only tried Samsung Galaxy S (i9000)
- MIUI (Android version 4.1.2)
- CyanogenMod 9 (Android version 4.0.4)
- CyanogenMod 7.2 (Android version 2.3.7)

None of them worked. Can anyone confirm a working ADK mode on Galaxy S on any firmware? Unfortunately I don't have access to any other Android device at the moment ...

Edit: the following command on the phone returns android.hardware.usb.accessory
pm list feature | grep accessory
8  Products / Arduino Due / Re: Arduino Due and ADK on: November 06, 2012, 08:12:03 am
I'll try to get my hands on an Android 2.3.* phone and test it. Maybe this could be the reason?
9  Products / Arduino Due / Re: Arduino Due and ADK on: November 06, 2012, 04:58:36 am
The sample sketch for ADK from Arduino IDE 1.5 and the APK mentioned in the sketch.
10  Products / Arduino Due / Re: IDE 1.5.1 on: November 06, 2012, 04:58:19 am
Windows 8 64-bit.
11  Products / Arduino Due / Re: Arduino Due and ADK on: November 06, 2012, 04:10:58 am
I tried the ADK sample with the OTG cable with no luck.

The phone starts charging, but nothing else happens. The app on the phone states: No USB device found. And the Arduino Code does not go into if(adk.isReady()) { ... } section.
12  Products / Arduino Due / Re: IDE 1.5.1 on: November 06, 2012, 03:56:45 am
I get the same error.
13  Products / Arduino Due / Re: Arduino Due and ADK on: October 28, 2012, 03:53:25 pm
That is exactly what I have tried. Thank for pointing me in the right direction. I'll get an OTG cable and try it out.
14  Products / Arduino Due / Arduino Due and ADK on: October 27, 2012, 01:17:22 pm
Hi everyone!

I hope someone can offer some guidance ... I am trying to run the Arduino Due ADK sample sketch from the Arduino Studio 1.5. My Setup is:
- Samsung Galaxy S with MIUI (Android version is 4.1.2)
- Arduino Due board -> ADK sample sketch uploaded
- The apk file mentioned in the sketch http://labs.arduino.cc/uploads/ADK/ArduinoTerminal/ThibaultTerminal_ICS_0001.apk uploaded to the phone
- home made USB cable (Micro USB to Micro USB, wired one to one (VCC to VCC, D+ to D+, D- to D-, GND to GND)

I cannot get the sample to work. Do I need a special cable (OTG)? Can something else be the reason?

Thanks, Tomaz
Pages: [1]