Show Posts
Pages: [1]
1  Forum 2005-2010 (read only) / Interfacing / Re: newbie having problems with 4bit LCD (4x20) on: September 30, 2009, 10:15:18 pm
I see... I used a potentiometer to edit the contrast and also grounded the RW pin.. I have not edited the library code to false.. i'm not sure if I have to do that.  but I see all kinds of symbols scrolling through the lcd.  

I think i might be send it incorrect  commands.

I have the following

LCD pin       Arduino pin
1                 ground
2                 5v
3                 potentionmeter to ground
4                 12
5                  ground
6                 3
11               7
12               8
13               9
14               10
15               14
16               ground

this worked for us.

the library we used was LCD4Bit 4X40  even though we have a 4X20 8-) 8-) 8-) 8-) 8-)

2  Forum 2005-2010 (read only) / Interfacing / Re: newbie having problems with 4bit LCD (4x20) on: September 30, 2009, 09:31:37 pm
SUGESTION!!! use a potentiometer from pin 3 to ground.  This is the contrast display.  It took me 5 hours to find out that you have to use a potentiometer to edit the contrast otherwise you will not see anyting on the lcd.  Just the backlit.   Also, I got to see bargled symbols sent to the lcd, but I have not been able to send actual messages to it..

let mek now if you have any success.  My email is monstertech5000@gmail.com
thanx

so far I downloaded the LCD4Bit library and added it to both \hardware\libraries\LCD4Bit


please help.
 :-/
Leo
Pages: [1]