Show Posts
Pages: [1] 2
1  International / Generale / Riduzione prestazioni on: July 14, 2013, 02:51:25 am
Salve a tutti.

Utilizzando arduino (mega 2560) per un progetto a cui sto lavorando mi sono accorto che dopo molte (MOLTE) programmazioni
del micro le sue prestazioni tendono a diminuire.
Cioè, sembra che il clock di arduino sia inferiore a quando la scheda era nuova.
Sò che che le programmazioni sono limitate a 10000 (mi pare) ma non credo di averne fatte così tante

è possibile oppure ho qualche problema hardware io (arduino pilota una scheda che controlla 5 motori a spazzole,3 resistenze saldatrici e vari sensori)

Grazie in anticipo.

Ciao van.
2  International / Hardware / Re: [RISOLTO]Chiarimento su transistor npn on: January 13, 2013, 01:15:56 pm
Ingresso con partitore provato,misurato e funzionante alla perfezione!!!
Ho provato anche a "maltrattarlo" un po' :

Dandogli come ingresso 24V (non ho un alimentatore più grande) invece di 12V , il voltaggio risultante è sempre 4,7V.
Inversione di polarità, non ne risente minimamente.

è proprio vero il detto : Chi ci sputa ci lecca!! smiley

Grazie a tutti ragazzi mi avete dato un grande aiuto.

Ciao Van.
3  International / Hardware / Re: [RISOLTO]Chiarimento su transistor npn on: January 12, 2013, 03:58:23 pm
Ho modificato lo schema del partitore, ora dovrebbe andare.
(Mi sa che siamo andati mooolto OT smiley )

Ciao Van.
4  International / Hardware / Re: [RISOLTO]Chiarimento su transistor npn on: January 12, 2013, 02:47:51 pm
Allora,la scheda è alimentata a 12V , i 5V sono presi da un regolatore di tensione 7805 presente sulla scheda stessa,
i 12V in questione in realtà sono l'uscita del sensore (contatto normalmente aperto).

Ecco le 3 soluzioni raccolte :

Optoisolatore:


Transistor:


Partitore:


Quale è la più sicura secondo voi?
Se poi uno mette i 24V su queso connettore bene che gli si bruci!!!
5  International / Hardware / Re: [RISOLTO]Chiarimento su transistor npn on: January 12, 2013, 08:17:10 am
Certo che vista così assume tutto un altro aspetto.
La mia paura era che, siccome questo circuito , una volta realizzato non dovrò installarlo io,
potessero accadere errori vari, tipo inversione di polarità o contatti attaccati male ecc...
Ma ripensandoci credo di essermi fatto solo "un bel film in testa", perchè , se invertono l'alimentazione la fotocellula
non va, e se la bruciano non mi importa (tanto la pagano loro) e nel caso che brucino la scheda, meglio, me ne comprano un altra  smiley-twist  smiley-money.
Stasera passo a comprare le resisenze da 15KΩ ,provo il tutto e poi faccio sapere (c'è da sapere poco ma per correttezza...).
E se proprio voglio essere sicuro metto un bel diodo tra 12V e GND e mi levo ogni dubbio.

Grazie mille.

Ciao Van.
6  International / Hardware / Re: Chiarimento su transistor npn on: January 11, 2013, 06:16:40 pm
Perfetto , ho esaurito le domande (solo sull'argomento smiley ).

Risolto tutto.

GRAZIE MILLE!!!
7  International / Hardware / Re: Chiarimento su transistor npn on: January 11, 2013, 04:27:06 pm
Ma avendo la massa in comune (5V regolato da 12V quindi accoppiato x definizione) il foto accoppiatore è inutile, meglio il transistor semplice o sbaglio? (come da schema consigliato da uwe)
Il partitore di tensione , come direbbero dalle mie parti , "Un mi garba per nulla" per questa applicazione.

Ciao van.
8  International / Hardware / Re: Chiarimento su transistor npn on: January 10, 2013, 07:58:45 pm
Ciao uwe.

Ho provato a seguire il tuo consiglio e ... ok è il normale funzionamento del transistor
però devo "leggere" il segnale invertito giusto? (non è assolutamente un problema , è solo per chiarezza)

Con esempio:
Code:
digitalWrite(13,!digitalRead(6));

Ciao van.
9  International / Hardware / Re: Chiarimento su transistor npn on: January 10, 2013, 04:03:08 pm
@qsecofr: Infatti 2 resistenze e pure un led in serie (x lo stato) x l'optocoupler

Mi sa che ritorno su i miei passi e rimetto l'optocoupler, so che il partitore funziona a modo , ma non gli do molta fiducia (nulla di tecnico è "una cosa mia")

Credo di poter mettere risolto.

Ciao e grazie a tutti.

Van.
10  International / Hardware / Re: Chiarimento su transistor npn on: January 10, 2013, 02:47:14 pm
@Michele : No, arduino è alimetato solo da usb, quindi l'errore c'è stato, ma non c'entra niente con il circuito che volevo realizzare, una svista diciamo.
Con l'alimentatore esterno (che è un ATX modificato) alimento tutto il circuito di interfaccia x la fotocellula (5V-12V).

@qsecofr: Si , è una fotocellula industriale a 12V e il primo progetto l'avevo realizzato con dei optocoupler ma visto che nel circuito finale i 5V della logica vengono ricavati (7805) da i 12V
mi sembrava inutile usare un fotoaccoppiatore (x l'ingobro soprattutto) [ho detto na boiata?]

Ciao van.
11  International / Hardware / Re: Chiarimento su transistor npn on: January 10, 2013, 12:38:18 pm
Grazie Michele.

NoNo , non invio tensioni ad arduino dal pin 6 , e successo che ho scollegato arduino dall'usb lasciando l'alimetatore esterno
acceso e la fotocellula attiva il risultato e che non si è spento.
Ho spento subito l'alimetatore esterno xchè anche a me pareva molto strano,
comunque ho riprovato il pin (x paura di averlo danneggiato) e funziona tutto.
Ho provato a risimulare l'errore e si è verificato nuovamente.
Bho , "misteri dell'elettronica" !!!

EDIT:Mi sa che devo stare più attento nell'ordine di spegnimento dei device smiley

Ciao van.
12  International / Hardware / [RISOLTO]Chiarimento su transistor npn on: January 10, 2013, 12:04:39 pm
Salve a tutti,
come da titolo vorrei dei chiarimenti sull'utilizzo di transistor npn (BC337).

Ho realizzato questo schema:


Il quale prende come ingresso un voltaggio di 12V , ricevuto da una fotocellula,innesca il transistor che fa passare il segnale (+5V) verso un ingrsso digitale di arduino (pin 6).

Il problema è che mi succede una cosa "strana",
se stacco l'alimentazione di arduino e faccio condurre la fotocellula arduino si accende regolarmente o quasi (il LED ON sembra un po' meno brillante).

é normale questo comportamento od ho fatto una ciofeca di interfaccia?

Ciao van.
13  International / Hardware / Re: Zero crossing integrato o circuito separato? on: December 27, 2012, 06:43:14 pm
Una cosa del genere? (trovato in rete)



Ovviemente sostituendo triac e moc con quelli elencati in precedenza.

A sto punto devo pensare anche ad i costi di produzione. (di sti tempi si guarda anche al centesimo  smiley-money )
Effettivamente , quanto mi serve il circuito RC?
Essendo un carico resistivo non dovrei averne bisogno o in caso di mal funzionamento della resistenza mi ritrovo dei transienti in giro? (mi sa che ho detto uno sfondone)

Ciao Van.
14  International / Hardware / Re: Zero crossing integrato o circuito separato? on: December 27, 2012, 08:10:31 am
Grazie Uwe, esauriente come sempre.

Avevo già visto quell'immagine (forse in un tuo vecchio post, non ricordo) e mi aveva già chiarito molto.
Basandomi su quello che mi avete detto ho realizzato questo schema (un po' scopiazzato smiley-grin):



Credo possa andare (correggietemi se ho sbagliato qualcosa).

L'opto-triac è un TLP3062
Il triac è un BTA12-600

Il resto è puro software smiley.

Ciao Van.
15  International / Hardware / Re: Zero crossing integrato o circuito separato? on: December 26, 2012, 12:34:43 pm
Grazie a tutti.

@Uwe
Si! si chiama ganascia.

TERMOCOPPIE:
Io devo realizzare questa scheda x conto terzi (una azienda  metalmeccanica che si fa fare le schede da altri)
Il problema (chiamiamolo così) è che questa macchina ha già una scheda elettronica fatta (con i piedi) da un professionista,
quindi di sensori (termocoppie comprese , tipo j) ne hanno già acquistati un treno (dei geni a parere mio  smiley-confuse).
Anche io avevo consigliato il tipo K proprio grazie al MAX6675 che facilitava tutto ma "ciccia", mi hanno risposto che vogliono usare le J.

SALDATORE:
Riguardo alla regolazione della temperatura (che a regime ideale sarebbero 130°) si ostinano a dire che già 2-3 gradi di differenza fanno una brutta saldatura (è vero oppure è una boiata? non ho potuto verificare di persona),
quindi mi ritroverei a dover far fare al micro molte letture e quindi , visto il basso range di temperature , molte commutazioni del relè e, a lungo andare , ciao contatti (è per questo che avevo pensato al triac).

Comunque ,da quel che ho capito, potrei usare un triac+optocoupler (o SSR, devo vedere i prezzi) come semplice interruttore on/off (ma dai!!  smiley ) senza considerare minimamente lo zero crossing (non credo che 10ms max. varino + di tanto la temperatura), semplicemente basandomi sulle teperature, giusto?

Ri-grazie a tutti....

ciao Van.
Pages: [1] 2