Show Posts
Pages: [1] 2 3 ... 8
1  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 17, 2014, 07:35:18 am
Hello,

I shunt resistors on the card-reader and it does not works, even with the "good" Sd-card.

Then, I tried and work with UTFT and Mega2560.
I spend much time and finaly find the declaration to write in every example :

UTFT myGLCD(ILI9341_S5P, 51, 52, 53, 48, 49);

Now, I can execute all the demo given in the library and I have to write my own programms.

 
2  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 16, 2014, 04:26:38 am
To use 5 V ProMini, I followed what MrBurnett said on another page : I did as if it were a 3.3 Volts.

I had like to show you the 2 ProMini working together, but amongst all my SD-cards, one only works well with ILI9340 card reader. Other card are sometimes recognised and their files listed, but pictures are never shown.
 



3  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 16, 2014, 12:26:47 am
Hello Casemod.

I followed all links. I have a raw picture made with ImageConverter 565. I installed UTFT library, too big for ProMini so I now use my MEGA2560. The program SDImageViewer seems to have some bugs so I begin with a smaller program : UTFT_TextRotation_Demo.

I wander about pins for the prototype UTFT(Byte model, RD, WR, CS, RST, SER=0)  whose name are not familiar for me.
I keep my old wirings so WR=51, CS=53, RST=48, but what are RS and SER ?
Now, I'm about trying one after each other "ILI_9341_S4P" and "ILI_9341_S5P" for Byte model and 49 or 52 as RS.

I read all pdf without finding which Henning Karlsen's pin names correspond to SPI current pin names.

4  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 15, 2014, 09:21:31 am
Thank you for your quick answer.

You give me two ways of work. The hardware way will wait for another day and I explore the sotware way because the slideshow on the linked page is very attractive.
The link to a converter in the page is no more valid.

I downloaded another converter but it does not match. It is RGB565Converter_V0.3.
The result cannot be open by any software, even if I change the suffixe by .bmp.

The input picture size is 225 KO, the output size is 300 KO.
 smiley-roll
5  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 15, 2014, 04:15:19 am
On yesterday, after about 4 months trying, I have got a bmp picture on my ILI9340.

I succeed with a ProMini 3.3 volts, witch avoid resistors and 4050. I don't know if it is the reason.
I use Adafruit_9340 library.  I don't succeed with Adafruit_9341 library.
I don't succed with ProMini 5 volts nor UNO nor MEGA.



Then, I modified the program so as to show several pictures alternantively. It works.

To save time, I made bmp pictures with 1 bit color (for instance black and white) but the program does not accept them and says : "BMP format not recognized". Is there any way to work with such pictures ?
6  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 12, 2014, 04:20:12 am
Hello Rastud,

You problem is exactly the same as mine. What you write is like my post N° 147 (page 10) and my photo (post #152 page 11)
Either with Adafruit library 9340 and woof.bmp or with Adafruit library 9341 and flower.bmp
I tried with MEGA, UNO, ProMini with the same results.

For other applications, I now use Ucglib library, but it dont allow showing a picture from SD.

7  Using Arduino / Displays / Re: Ucglib: A new Color OLED and TFT Library... on: August 11, 2014, 01:05:12 pm
My constructors are either
Ucglib_ILI9341_18x240x320_SWSPI ucg(/*sclk=*/ 13, /*data=*/ 11, /*cd=*/ 9 , /*cs=*/ 10, /*reset=*/ 8 ) ;
or
Ucglib_ILI9341_18x240x320_HWSPI ucg(/*cd=*/ 9 , /*cs=*/ 10, /*reset=*/ 8 );

Now, it works well though I have not changed anything to wiring. I only tried and played other example programs.


I have not installed UTFT library.
Before your library, I tried 2 Adafruit libraries (9340 then 9341) and their examples. Some worked, other not, but I use ProMini 3.3V only today.
My TFT is a low cost ILI9341 one withour any datasheet.
8  Using Arduino / Displays / Re: Ucglib: A new Color OLED and TFT Library... on: August 11, 2014, 03:01:53 am
To get rid of 4050 or resistors, I ordered ProMini 3.3Volts.
Now, all works fine (HwdSpi and SwdSpi).

I had a surprise with GraphicsTest.ino whose texts are upside down.


9  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 11, 2014, 02:51:45 am
Hello !

I cut the pin Vcc (input) of the card and sold a wire from the cable to Raw and now it works.




The 3.3 V data outputs are strong enough to drive the ILI9340.
10  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 10, 2014, 12:51:10 pm
Thank you for your answers.

My FTDI adapter has no option and is like this one which do not need pressing reset during transfert :



I shall modify the wiring to-morrow and tell you soon the result.
11  Using Arduino / Displays / Re: LCD display with ILI9341 driver on Arduino on: August 10, 2014, 09:24:33 am
I wished avoid all problems coming from 4050 or resistors. So, I ordered ProMini 3.3 Volts. I received them during the week. Happy of receiving them soon, I gave a good appreciation to the seller.
To-day, I discover they are not true 3.3 volts. Powered by USB adaptor, they give 5 volts either on Vcc pin and high level Data pins .



do not order these items.

I hope they have not damaged my ILI9340.
12  Using Arduino / Displays / Re: Ucglib: A new Color OLED and TFT Library... on: August 01, 2014, 12:13:41 am
Hello,

I tried other examples. All work with SWD spi only.
Scale runs since yesterday. It tells now 12982  12983 ...
I stop it à 13000.
13  International / Français / Re: Conflit interne de librairie SD ? on: July 31, 2014, 11:32:51 am
Au pif, il me semble que quand tu as ouvert un fichier, il n'est plus accessible par un programme autre que celui qui l'a ouvert avant que tu le fermes. N'as tu pas oublié de les fermer après les modifs ?
14  Using Arduino / Displays / Re: Ucglib: A new Color OLED and TFT Library... on: July 31, 2014, 07:23:37 am
Hello,

Congratulation for you library. I load it on yesterday. I tried the programm hello world with a mega2560 and SWD SPI  (HWD gives only a white screen).
I change some lines so as to test functions and had a surprise : when using setRotate(270), it rotate text of 270° but rotate background color of another angle.

Here is my code :

Code:
void loop(void)
{
  ucg.setRotate90();
  ucg.setFont(ucg_font_ncenB24r);
  ucg.setColor(1, 255, 255, 255);   //  text background color
 
  ucg.setColor(255, 0, 0);    //  red
  ucg.setPrintPos(0,25);
  ucg.print("Hello World!");

  ucg.setRotate270();
  ucg.setColor(0, 0, 255);   //  blue
  ucg.setPrintPos(0, 75);
  ucg.print("Hello World!");

  delay(500); 
}

and here is the result :





15  International / Français / Re: alimenter arduino avec 5 volts externe ? on: July 27, 2014, 12:17:42 am
Bonjour,

Le 7805 alimentera bien ta carte sans problème.
Le problème est en aval de la carte : les sorties de la carte sont-elles capables d'alimenter tes servo-moteurs ?

De mémoire (tu peux vérifier j'ai la flemme de faire des recherches) chaque sortie est limitée à 40 mA et la totalité des sorties à 200 mA.

Si ça ne passe pas, la solution est d'utiliser la 7805 pour alimenter des transistors dont les bases sont commandées par les sorties d'Arduino.
Pages: [1] 2 3 ... 8