Show Posts
Pages: [1]
1  Using Arduino / LEDs and Multiplexing / Re: Hooking up TLC5940 to 12V on: November 18, 2012, 06:02:40 am
Looks like it. The +12 is connected to the anodes of the LEDs and the -ve from the 12V is connected to the arduino ground.
The TLC5940 chip can stand about 16V so the 12V is fine.
Thanks Mike smiley I'll try it out, just have to get hold of a few resistors and I can hook it all up smiley-wink
2  Using Arduino / LEDs and Multiplexing / Hooking up TLC5940 to 12V on: November 17, 2012, 05:37:05 am
Hi everyone!

Yes, another thread about the TLC5940 smiley-razz
I've read numerous threads on several forums about the TLC5940, daisy chaining, power dissipation, and I'm slowly learning the inner workings of this awesome little chip smiley

My setup: My idea is to learn the TLC5940 using parts I've got lying around. I'm attempting to drive a 12 V RGB LED strip cut up to 16 short parts with an Arduino UNO. 16 RGB channels means 3 TLC5940s which I will daisy chain. The load won't be very high, since the strip is cut up, at max 15 mA per output pin on the TLC5940s.

My question: Of all the threads and guides I've read, few of them use anything other than the same 5 V for the LEDs and the TLC5940. See the attached image. Is this the correct way to hook up the LEDs to a 12 V rail?

Note that I have hidden the daisy chain wires for better visibility.

EDIT: It just hit me that the image is a bit misleading. There is no single LED on the outputs, but instead the short LED strips, with mounted resistors.
Pages: [1]