Show Posts
Pages: [1]
1  International / Software / Re: El puerto serie está en uso. on: January 09, 2013, 06:44:55 pm
No por exceso de información, estar mucho tiempo prendida no genera ningún tipo de inconveniente de por si, de hecho suele aumentar la vida útil de una maquina quedar prendida que prenderse 2 veces por día como sucede en algunos casos. Lo que si puede pasar es que alguna utilidad haya usado el puerto de serie y deje algún archivo temporal que moleste al arduino, y al no reiniciarse hace mucho ese archivo no se elimina... puede ser un temporal u otro tipo de dato que intervenga con el funcionamiento del puerto. Reiniciar la maquina puede solucionar el inconveniente, mientras buscaba una solución para el mío vi que muchos solucionan este tipo de problemas al reiniciar las computadoras... vi en un par de lugares cosas como: ...a mi en general se me soluciona con tal o cual cosa pero la única solución que funciona siempre es reiniciar la PC...

No comente de esto porque asumí que habías reiniciado la maquina, pero si no se puede por algún motivo habría que investigar un poco mas o intentar en otra maquina que si se pueda reiniciar para descartar problemas con el arduino.

JS
2  International / Software / Re: El puerto serie está en uso. on: January 08, 2013, 11:12:27 am
seguramente haya una libreria similar en windows donde hacerlo, puede ayudar, tambien hay otras opciones pero salen antes al buscarlas por eso no las comente, pero cualquier soft que pueda estar abriendo los puertos de serie en busca de alguna conexión puede generar problemas, como los drivers y apps para celulares sobretodo de blackberry. Busca en FAQs y troubleshooting de la pagina principal que aparecen.

JS
3  International / Software / Re: El puerto serie está en uso. on: January 06, 2013, 06:20:40 am
yo tuve un problema con "el puerto de serie esta en uso" y lo solucione moviendo o borrando una carpeta, elegí moverla por seguridad...

es en mac y no se me solucionaba reiniciando el puerto, me aparecia siempre el cartel, no despues de un rato de uso... pero por ahi te sirve algo...

http://arduino.cc/forum/index.php/topic,139464.0.html
4  International / Software / Re: Ayuda con error "El puerto serial ya esta en uso" (MAC) [SOLUCIONADO] on: December 30, 2012, 04:44:57 am
Gracias por la recomendación, muy buena para tener el foro ordenado y ayudar al proximo que venga...

JS
5  International / Software / Re: Ayuda con error "El puerto serial ya esta en uso" on: December 29, 2012, 12:32:56 pm
Encontre la solucion... cambiar el nombre o mover la carpeta libreria/java/extensions

Esta carpeta contiene un archivo RXTXcomm.jar que es quien have que 2 applicaciones no puedan usar el puerto de serie...

Lo explican mejor aca que es donde lo encontre.
http://arduino.cc/forum/index.php/topic,49173.0.html


Saludos.

JS
6  Using Arduino / Interfacing w/ Software on the Computer / Re: Is my Arduino broken? [serial port already in use problem] on: December 29, 2012, 04:07:49 am
Today I get it working on the i3... Really hard to get drivers working in W7 if you are not used to that SO...

Still can't do my mac close the app that is using the serial port, it only use it when arduino is connected, I can use mouse or annything in all USB, but when arduino connected to any USB it start runing something on it, still if arduino isn't sending data, 'Blink' loaded with the i3 and the problem persist.

I'll look for a solution in some mac forums because is a SO issue and not an arduino, maybe some mac users around could help, but I guess a mac forum will be more helpfull.

JS

EDIT: solved here http://arduino.cc/forum/index.php/topic,49173.0.html
7  International / Software / Re: Ayuda con error "El puerto serial ya esta en uso" on: December 28, 2012, 08:45:21 pm
Gracias, me voy a fijar lo del IDE...

De lo que pude ver no tengo ninguna otra aplicación abierta, al iniciar la maquina lo primero que hago es correr el arduino e intentar cargar algo, como no me lo carga intento cerrar desde el monitor de actividad del SO todas las tareas que puedan estar relacionadas con puertos usb...

Por las dudas, no es puerto COM sino /dev/tty.usbmodem... porque es mac y no windows...

JS
8  International / Software / Ayuda con error "El puerto serial ya esta en uso" (MAC) [SOLUCIONADO] on: December 28, 2012, 02:12:43 am
Hola, tengo un problema al cargar el programa al arduino mega, me marca un error "El puerto serial ya esta en uso" y no me permite cargarlo...

Hace 2 días me llego a casa la placa, estuve probando algunos programas de ejemplos y funcionaron sin problema, cuando quise leer los datos de una entrada analógica con el programa AnalogInOutSerial de los ejemplos no tuve inconvenientes, luego intente leer estos valores desde MAX5 y lo conseguí, después desde Processing, tuve algunos inconvenientes, no conseguía comunicarme con el puerto usb, cuando lo conseguí no me devolvió ninguna lectura pero el programa corrió... Cuando quise verificar desde el monitor de serial de arduino empezaron los problemas, un cartel que decía que el puerto serial estaba en uso y cuando quería cargarle otro sketch no me lo permitía por el mismo error. Tengo una macbook con OSX 10.5.8, luego de reiniciarla varias veces, reiniciar el SMC y PRAM, abriendo únicamente el arduino una vez reiniciada el problema persiste, desinstale MAX5 y Processing, aun así el problema persiste... Mi única idea es que el puerto este abierto por el arduino, es decir, que sigue enviando datos a través del USB del ultimo programa que le cargue y esto no me deje cargarle un nuevo programa, desde la maquina no me queda mucho para hacer...

Intentando cargar 'Blink'


Cualquier idea es bienvenida.. Desde ya, muchas gracias.

JS
9  Using Arduino / Interfacing w/ Software on the Computer / Re: Is my Arduino broken? [serial port already in use problem] on: December 27, 2012, 11:58:09 pm
I'd like to know how it ends, I get my arduino yesterday after a month waiting for it, I'd run a couple of examples on it and play a little bit with them... changing pins and simple stuff to check everything was warking, then I start trying to read serial port with max5 first and with processing later. With max I get it working, but when I tried with processing put me a couple of errors, didn't read the serial port... I get it working after a while.

When I came back to Arduino to load a new program it start saying me that same message:

"processing.app.SerialException: Serial port '/dev/tty.usbmodem3d11' already in use. Try quiting any programs that may be using it."

The last program uploaded to arduino is still working, ('AnalogInOutSerial')
I tried a lot of things, restarting the computer and starting the arduino with anything else opened, also restarting SMC and PRAM just in case... anything work so far... I trash all processing and max files I had on the computer, nothing yet. I tried with other computers but I couldn't make it work, but other 2 are PCs in bad working condition so no reference here... one is an i3 with W7 last a life to open 'tools tab' and didn't let me open the 'serial port' tab (grey text instead of black).

I'm working with a MacBook with Mac OS X 10.5.8 (I wish this donesn't matter) and arduino 1.0.2 with an Arduino Mega2560

Any other tips will be apreciated.

JS
Pages: [1]