Show Posts
Pages: [1]
1  International / Español / Re: Ayuda con lcd Serial-IIC-I2C y mi mega (solucionado) on: December 06, 2012, 04:52:06 pm
Buenas Fm antes de nada darte las gracias por tomarte las molestias.

Prueba con la libreria del compañero Sergegsx el mismo resultado, ya he llegado a pensar que hay algo roto, pues no hace ni muestra nada mas que los cuadros (lo mismo que cuando se le da alimentacion y sin nada mas).

Despues lo del compañero fm: He bajado las librerias y leido como instalarlas (he tenido que quitar todo lo que tenia de pasados intentos, librerias y demas cosas) He paso el test y no me mostraba nada el monitor serial, pero cuando lo he mirado con el Hyperterminal me salia esto:
Scanning...
I2C device found at address 0x3F !
done


Raro verdad, segun el fabricante era 0x27 (pues NO y NO) despues he puesto el codigo primero de ejemplo y .... FUNCIONA .....

FM eres un mostro. Muchas gracias .

He comentado todo los pasos por si algun compañero pasa por el mismo tortuoso camino. Gracias  a todos.
2  International / Español / Re: Ayuda con lcd Serial-IIC-I2C y mi mega on: December 05, 2012, 05:17:18 am
Gracias por la libreria, he tenido problemas con el login, la probare en estos dias y te cuento, pero desde ya agradezco tu ayuda. Un saludo.
3  International / Español / Re: Ayuda con lcd Serial-IIC-I2C y mi mega on: November 30, 2012, 04:17:15 am
Buenas pues si, es 16,2 ya lo he probado con el mismo resultado. Esa es la ultima configuración que probé pero como bien dices tu, también probé con 16,2. He probado varias librerías y demás, pero agradecería que me pasaras las tuyas y el cod que uses y si me puedes indicar k versión usas yo estoy con la 1.0.1.

Gracias a ver si entre todos podemos hacer funcionar esto k empieza a ser un poco ... 
4  International / Español / Ayuda con lcd Serial-IIC-I2C y mi mega on: November 29, 2012, 02:54:51 pm
Buenas a tod@s y desde ya agradezco toda vuestra ayuda.

Os pondré en antecedentes:

He empezado hace muy poco con el gusanillo del arduino y como es normal estoy pagando la torpeza del novato.

El caso es que tengo una mega 2560 y una lcd ( http://www.ebay.com/itm/Serial-IIC-I2C-TWI-2004-204-20X4-Character-LCD-Module-Display-For-Arduino-Blue-/300736978496 )

Estoy programando (copiando y modificando) con arduino 1.0.1 y he conectado los cables de la pantalla a la mega
 
Gnd => GND
Vcc => 5v
SDA =>pin 20 (SDA)
SCL=> ping 21 (SCL)

El caso es que he probado multitud de código y ninguno ha funcionado la pantalla lo único que hace encenderse y muestra series de cuadraditos blancos.

Podrían guiarme en esto.

Un saludo y gracias.

Este es mi codigo


#include <Wire.h> 
    #include <LiquidCrystal_I2C.h>
    LiquidCrystal_I2C lcd (0x27,20,4); 
    // fijó la dirección del LCD a 0x27 para 20 caracteres y 4 la línea
void setup()
    {
delay (500);
      lcd.init ();                      // inicializa el lcd 
 
      lcd.backlight ();
      lcd.setCursor (0, 0);
      delay (100);
      lcd.setCursor (1, 0);
      lcd.print("más barato y");
      lcd.setCursor (0, 1);
      lcd.print ("alta calidad en aquí");
      lcd.setCursor (1, 2);
      lcd.print ("www.b2cqshop.com");
      lcd.setCursor (0, 3);
      lcd.print ("recepción a B2CQSHOP");
    }
void loop()
    {
    }

El caso es que lo hace todo bien pero no muestra nada.


Pages: [1]