Show Posts
Pages: [1] 2
1  International / Réalisations et Projets Finis / Re: Drawbot - Le robot qui dessine on: June 21, 2013, 03:35:09 pm
Merci d'avoir partagé ton excellent projet, très très intéressant ! smiley
2  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 04:05:01 pm
Oui tu avais raison ! En me débrouillant avec du scotch ( j'ai pas de fer à souder ), j'ai finalement réussi à faire marcher ce potentiomètre ! smiley-mr-green
Merci à tous de votre aide, c'est super sympa ! smiley
3  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 03:23:30 pm
Pas de problèmes avec les fils :/ Je pense que le problème vient du potentiomètre mais je ne vois pas comment le brancher à l'Arduino autrement qu'en passant les fils dans les trous des languette ( et par conséquent, les fils bougent car les trous sont plus larges que les fils )
4  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 03:07:00 pm
Les valeurs semblent normales ( 1023 pour 5V, 685 pour 3.3V et 0 pour GND ) smiley-fat

PS : as-tu vu les photos ?
5  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 02:50:11 pm
J'ai essayé avec 5, c'est la même chose smiley-lol Je t'envoie une photo de mon potentiomètre, car il y a une chose qui est peut-être la source du problème smiley

EDIT : voila, en fait les "languettes" de mon potentiomètre sont trop grosses pour rentrer dans les trous de ma platine d'essai, mais j'ai remarqué qu'il y avait un trou dans chacune des 3 trois languettes. J'ai donc branché un fil dans la platine d'essai qui passe par ces trous. Voici les photos :

Potentiomètre seul :



Branchage :

6  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 02:37:02 pm
Il s'agit d'une carte Arduino Uno REV 3. Oui, les broches A0 à A5 sont les broches 14 à 19 donc pas de soucis ici je pense ^^
7  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 02:20:05 pm
Les deux broches extérieures sur GROUND et +5V, et la broche du milieu sur A5.

( merci pour vos réponses ultra rapides smiley-eek )
8  International / Français / Re: analogRead qui joue au yoyo ... on: April 06, 2013, 02:17:16 pm
Heu non il n'y en avait pas dans le tutoriel donc je n'en ai pas acheté smiley-sweat
9  International / Français / analogRead qui joue au yoyo ... on: April 06, 2013, 02:13:59 pm
Bonjour à tous,

ayant fait l'acquisition d'un potentiomètre monotour linéaire 10 kilo-ohms, j'ai voulu le tester en affichant les valeurs reçues par la fonction analogRead(). Mais le problème, c'est que les valeurs affichées dans le terminal série varient sans raison ( sans que je touche le potentiomètre ). Pensez-vous que j'ai fait un mauvais montage ou est-ce le potentiomètre qui est défectueux ? D'où vient ce problème ? smiley-eek

Potentiomètre en question : http://www.electronique-diffusion.fr/product_info.php?products_id=23839

Code ( tiré d'un exemple de l'IDE ) :

Code:
void setup() {
 
  Serial.begin(9600);
}

void loop() {
  int sensorValue = analogRead(19);
  Serial.println(sensorValue);
  delay(100);       
}



Merci d'avance pour vos réponses smiley
10  International / Français / Re: Clavier PS/2 avec prise mâle on: December 31, 2012, 11:34:08 am
Et comment pourrais-je réaliser un montage dans ce genre ? smiley-eek

J'ai essayé de relier des fils avec les pins du fil du clavier ( en scotchant smiley-mr-green ) mais ca ne marche pas. smiley-fat
11  International / Français / Clavier PS/2 avec prise mâle on: December 29, 2012, 03:51:23 pm
Bonjour,

voulant relier un clavier avec ma carte Arduino, je me suis procuré un clavier PS/2 pour l'utiliser avec la librairie PS2Keyboard. Mais sur les illustrations de la page de la librairie ( http://playground.arduino.cc/Main/PS2Keyboard ), il me semble que c'est une prise femelle ( il y a des trous ) et je possède un clavier avec une prise mâle ( il n'y a pas de trous ). Y'a t'il un moyen de l'utiliser quand même ou faut-il que j'achète un adapteur ?

Merci et joyeuses fêtes.
12  International / Français / Re: Je ne comprends pas pourquoi mon code marche on: December 28, 2012, 12:18:35 pm
Mystère résolu ! Merci beaucoup à vous tous pour votre aide smiley

Et bonnes fêtes de fin d'année à vous aussi smiley
13  International / Français / Re: Je ne comprends pas pourquoi mon code marche on: December 28, 2012, 09:45:08 am
Ca m'affiche :

2
1

Et les LEDs s'allument un dixième de seconde puis s'éteignent. Mais mon code d'avant marchait, le problème n'est pas de faire un code qui marche. Je veux juste savoir pourquoi mettre 1 et pas 0 à la ligne if ( Serial.available()>0). Ca m'intrigue cette histoire ! smiley-mr-green
14  International / Français / Re: Je ne comprends pas pourquoi mon code marche on: December 28, 2012, 06:50:45 am
Alors j'ai essayé ton code :

quand je rentre 1 caractère dans le moniteur série : il affiche 1, saute une ligne, réaffiche 1. Pourtant il ne devrait afficher qu'un seul 1, non ?
15  International / Français / Re: Je ne comprends pas pourquoi mon code marche on: December 28, 2012, 06:36:14 am
En fait le but de mon programme est le suivant :

lorsqu'on entre une lettre dans le moniteur série ( qui est intégré au compilateur ), certaines LEDs s'allument ( en fonction du code Braille). Et puis elles restent allumées tant que l'on n'entre pas un nouveau caractère. Si on entre un nouveau caractère, les LEDs s'allument en fonction de ce nouveau caractère et restent allumées. Et ainsi de suite ^^

La ce qui me perturbe c'est que lorsqu'on utilise la fonction Serial.read(), la fonction Serial.available() devrait renvoyer 0 ( du moins, si l'on a rentré qu'un seul caractère. Et puis le programme les LEDs et vérifient si il y a d'autres caractères dans le buffer. Logiquement on devrait utiliser if ( Serial.available()>0) mais ca ne marche pas ! Les LEDs s'allument un dixième de seconde puis s'éteignent. Je me casse la tête pour comprendre pourquoi, en vain ! smiley-eek
Pages: [1] 2