Show Posts
Pages: [1]
1  Using Arduino / Installation & Troubleshooting / Re: Problem with lmv358 and usb at UNO on: December 18, 2012, 02:50:27 am
Thanks for your help guys.
I will inform you if I have any news.  smiley
2  Using Arduino / Installation & Troubleshooting / Re: Problem with lmv358 and usb at UNO on: December 14, 2012, 11:31:02 pm


1)Power the board from the USB cable only, jumper digital pin 13 to ground.  The pins on the LMV328 should read as follows;
  • Pin 1 ~ 0V
  • Pin 2 ~ 3.3V
  • Pin 3 ~ 0V
  • Pin 4 ~ 0V
  • Pin 5 ~ 0V
  • Pin 6 ~ 0V
  • Pin 7 ~ 0V
  • Pin 8 ~ 5V

2) Does the 16U2 get hot at all?

1)
  • Pin 1 = 107mV
  • Pin 2 = 3.27V
  • Pin 3 = 2.1V
  • Pin 4 = 0V
  • Pin 5 = 0V
  • Pin 6 = 90mV
  • Pin 7 = 90mV
  • Pin 8 = 4.67V

2) Nop, 16U2 doesn't get hot. Even with USB power, lmv358 becomes hot again, but it's at the limits to touch it by hand.

So, do you think that I need change mosfet and lmv358 or there is also something more to check?
If these 2 chips have problem, would this be the reason that 16U2 doesn't communicate with pc anymore?


Edit: I can hear the windows connected sound when I plug in the usb, but I can't see something at the device manager under com ports.
Do you think that I need reprogram the 16U2? Is there any way to read the code of this, to check with this way if the chip needs reprogramming or if it is finally damaged?
3  Using Arduino / Installation & Troubleshooting / Re: Problem with lmv358 and usb at UNO on: December 13, 2012, 11:18:55 pm
Oups, sorry my mistake, it's 4.96V  smiley
4  Using Arduino / Installation & Troubleshooting / Re: Problem with lmv358 and usb at UNO on: December 13, 2012, 05:23:15 pm
First, did you try using a different USB port on the PC?

-Yes I tried different usb ports and also another pc.

The only things the LMV358 is connected to are the "L" led and the MOSFET.  It is unlikely that the "L" LED is to blame so we are left with the LMV358 and the MOSFET.  If the MOSFET is buggered, it might have taken the 3V3 regulator with it too

So, here's what I'd do.  First I'd make some basic checks.  I made the following measurements on a working UNO R3.


1. Remove the ATmega328 to eliminate it.

-Atmega removed.

2. Connect the external supply (12V) but do not plug the USB cable in.  Connect digital pin 13 to ground. Pin 1 of the LMV358 should be at ~5V.  Pin 3 should be at about 6V and pin 2 at ~3.3V.  Pins 5,6 and 7 should be at 0V and the "L" LED should be off.

-Ground connected with 13 pin.
Results:

pin 1= 4.96V
pin 2= 3.27V
pin 3= 5.46V
pin 4= 1mV
pin 5= 0V
pin 6= 95mV
pin 7= 95mV
pin 8= 4.96V
"L" Led= off

3. Connect digital pin 13 to 5V.  Pin 5 should be at ~5V, and pins 6 and 7 should be at ~4.5V and the yellow "L" LED should go on.

-13pin connected at 5V.
Results:

pin 5= 4.96V
pin 6= 4.5V
pin 7= 4.5V
"L" led= on

If the results of steps 2 and 3 are okay and the LMV358 does not get hot, then it is at least behaving as expected and is likely okay.

-At both steps the LMV358 gets really hot as always.


Both the gate and the source of the MOSFET should be at 5V.  The drain should not have any appreciable voltage on it.  Mine measure ~0.5V.

-That's exactly what I measure at mine too.

The MOSFET is going to be tough to test in circuit, but with no power applied to the Uno, there should be no dead shorts between any of the pins when measured in either direction with a decent DVM.

-Mosfet seems fine with the DVM, as when you measure a good transistor or diode, so it has not dead shorts at any of the pins.

If the LMV358 measurements and MOSFET check out, the problem is likely the ATmega328.

Anyway, make these checks and let us know the results.


Dear Billo, first of all thanks for your time, that's exactly what I was mean about help.
So if these components are ok, then what cause the too much heat at lmv358?
I noticed also that the NCP1117 start gets hot too after a while, but not that much as the lmv358.
I took some measurements of this too, but it is confusing me, as I can see, when you measure it from positive or ground pin, you take different results.

Here is the results with the black connector of multimeter at ground.

pin 1= 0V
pin 2= 4.95V
pin 3= 11.33V
tab pin = 4.95V

So what's next? smiley


Edit: I corrected a mistype.
5  Using Arduino / Installation & Troubleshooting / Problem with lmv358 and usb at UNO on: December 12, 2012, 10:39:23 pm
Hi.
I have an arduino UNO R3 and I was trying to make a laser engraver from cd-rom spare parts, as I read at instructables site (if there is not problem, I can upload the link of the constraction's topic).

But something went wrong at the constraction of the laser drive circuit and it seems it ruined up the arduino. I was using the same ground and power for the whole circuits, for arduino and the laser driver too.
But I did a big mistake that I realized it too late, I had connect the negative output of the laser driver at the common earth, so after a while, as I was trying to upload something at arduino, it became really hot and then the pc turned off. Then I removed arduino and left it to become cold, I turned on my pc again and I tried one more time, but this time arduino was not communicate anymore with the pc and it was becoming hot very fast.
I forgot to tell you that the only part that becomes hot is the lmv358 into 10-15 seconds, that you can't touch it at all, without any load or connected devices at arduino. The arduino seems to start working when you plug in the power socket, the "on" led becomes green and the "L" led blinks for some times, then stops and then it is doing one blink and turn off again. When you push the reset button it happens the same, so does this mean that Atmega328 is working finally?
I am using an external power supply at 12 volts.

Do you have any idea about how to fix this problem? If I change the lmv358, will this make my arduino back to life again or it is more complicated?
I can change it, smd is not problem for me, but I will need your help to determine where is the exact problem, as it might be another component that cause this problem.
I don't know where to start and what to measure to find the problem, so if you drive me about what to measure, I can tell you the results and maybe we can find the faulty parts.

Do you think also that the atmegaU16 might be dead? Is there any way to check this?

And something last.. Nice to meet you guys!  smiley

Arvacon
Pages: [1]