Show Posts
Pages: [1]
1  Using Arduino / Programming Questions / Re: can't get NmraDcc lib working on: May 21, 2014, 12:32:53 pm
Hi Paul!
The library is linked in my initial posting - no need to search for it.

I hope to find people who use the library ... Not folks who love to joke around!
-AH-
2  Using Arduino / Programming Questions / Re: can't get NmraDcc lib working on: May 21, 2014, 08:26:24 am
Hi PaulS!
Do you think your post is of any help?

I described clearly I'm looking for advice to A. Shepherd|s NMRADCC library. The NmraDCC library is used to implement a DCC decoder. My problem is that other libraries with less functionality work fine. So most likely HW is not the issue. When I moved over to that other library I do not get useful results. Charging on the DL statistics I guess there are many Arduino users using it. So maybe there is a known issue or somebody has some other useful hints for me...

Arnold
3  Using Arduino / Programming Questions / can't get NmraDcc lib working on: May 21, 2014, 01:56:38 am
Folks!
I used to use other libraries to receive DCC commands with success. So the well known HW with the opto coupler works fine. (http://www.mynabay.com/images/DCC_Monitor/schematic.png)

I moved over to Alex Shepherd's NmraDcc library *), it compiles with success for a UNO but I receive random data on the console. There is no correlation between DCC comand's I'm sending and the output. My impression is that I just receive noise or so. So I guess I have an extremly basic problem which I cant see by now.

The HW is connected to UNO's pin 2. I'm using the sample which is included with the lib.

Thanks for any ideas or advices

Arnold
*) http://sourceforge.net/projects/opendcc/?source=directory
4  Community / Website and Forum / Re: I.E. problem with WEB site on: July 12, 2013, 11:46:24 am
Thanks!
Your procedure works for me as well. But this proves that the Arduino pages have a coding problem. That's independent of the personal like/dislike level against IE.
-AH-
5  Using Arduino / Installation & Troubleshooting / Re: Windows 8 install on: July 12, 2013, 11:26:46 am
There is no classic installation. Just move the "arduino" folder where you want to have it - or if you want to get rid of it just delete it.
HTH
-AH-
6  Community / Website and Forum / Re: Explorer 9, tokens and arduino.cc on: May 25, 2013, 07:47:15 am
There is definitely a site bug. I'm running W8/64 with IE10. Anonymous browsing is fine but as soon as I log in Forum and Playground is broken. I get only a blank page. I'm posting this wit FF but I really prefer IE for speed and security reasons!
-AH-
7  International / Deutsch / Re: analogRead bringt immer zu hohe Werte on: December 28, 2012, 05:10:28 pm
Hi!
Wenn wir schon über analogRead reden bietet das die Möglichkeit über einen Pin mehrere Taster einzulesen. Die Tasten greifen von einem mehrstufigen Spannungsteiler über Taster die Spannung ab. So kann man die jeweils niedrigste Taste lesen. Auch hier muß der Eingang mit einem Widerstand der zumindest *10 größer ist als die Spannungsteilerkette auf ein definiertes Signal geführt werden um ein Floaten zu verhindern.
-AH-
8  Development / Other Software Development / suggestion for enhancing the tone() page on: December 23, 2012, 11:54:53 am
Folks!

I found out that on the tone() reference page (http://arduino.cc/en/Reference/Tone) there is a misleading advice. it currently explains: Use of the tone() function will interfere with PWM output on pins 3 and 11 (on boards other than the Mega). On my Leonardo analogWrite works fine in pin3. tone() causes troubles with pin5!!!

rgds
-AH-
9  Using Arduino / Audio / Re: tone() and analogWrite what are the limits on: December 23, 2012, 05:39:05 am
Folks!
Thanks for the advice I was sure it will turn out as a layer 8 issue! I've checked the tone() page several times but I have overseen the hint "Use of the tone() function will interfere with PWM output on pins 3 and 11 (on boards other than the Mega). "

On my Leonardo the interference of the tone function is not on pin 3 but on pin 5. It took me some more time to verify each analog output line to find this out. I x-checked that with 3 Leonardos.

How can we feed back this info to update the reference page for tone()?
-AH-
10  Using Arduino / Audio / tone() and analogWrite what are the limits on: December 20, 2012, 04:45:51 pm
Folks!
I'm using analogWrite to drive LEDs via power FETs. To improve theuser interface I want to confirm key strokes with short beeps. Currently I use 4 analog outputs - all fine. As soon as I engage a tone() command one of the analog outputs dies. I guess I'm hitting a limit on Interrupts or so but as far as I was able to find resources I do not expect that.
I'm using a leonardo board.

Any ideas or pointers where I could find information to a solution?
tks
-AH-
Pages: [1]